aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2014-06-22 20:08:16 +0000
committerChristian Grothoff <christian@grothoff.org>2014-06-22 20:08:16 +0000
commiteeaa12c3dbd18925c1177cfc66f52711b612fd9e (patch)
tree012f822b6d20f324f68ea29d9fe2237a0716935e /src/transport/Makefile.am
parent194669680385bd40ce7c84b11021b21b6ed6d295 (diff)
downloadgnunet-eeaa12c3dbd18925c1177cfc66f52711b612fd9e.tar.gz
gnunet-eeaa12c3dbd18925c1177cfc66f52711b612fd9e.zip
-split up transport_api_monitoring into monitor_peers and monitor_validation
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 5f35125dc..5a4a443a7 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -33,13 +33,13 @@ if HAVE_LIBGNURL
33 HTTP_REL_TEST = test_transport_api_reliability_http 33 HTTP_REL_TEST = test_transport_api_reliability_http
34 HTTP_QUOTA_TEST = test_quota_compliance_http \ 34 HTTP_QUOTA_TEST = test_quota_compliance_http \
35 test_quota_compliance_http_asymmetric 35 test_quota_compliance_http_asymmetric
36 HTTP_SWITCH = test_transport_address_switch_http 36 HTTP_SWITCH = test_transport_address_switch_http
37 HTTPS_API_TEST = test_transport_api_https 37 HTTPS_API_TEST = test_transport_api_https
38 HTTPS_API_TIMEOUT_TEST = test_transport_api_timeout_https 38 HTTPS_API_TIMEOUT_TEST = test_transport_api_timeout_https
39 HTTPS_REL_TEST = test_transport_api_reliability_https 39 HTTPS_REL_TEST = test_transport_api_reliability_https
40 HTTPS_QUOTA_TEST = test_quota_compliance_https \ 40 HTTPS_QUOTA_TEST = test_quota_compliance_https \
41 test_quota_compliance_https_asymmetric 41 test_quota_compliance_https_asymmetric
42 HTTPS_SWITCH = test_transport_address_switch_https 42 HTTPS_SWITCH = test_transport_address_switch_https
43endif 43endif
44endif 44endif
45 45
@@ -137,7 +137,8 @@ libgnunettransport_la_SOURCES = \
137 transport_api.c transport.h \ 137 transport_api.c transport.h \
138 transport_api_blacklist.c \ 138 transport_api_blacklist.c \
139 transport_api_address_to_string.c \ 139 transport_api_address_to_string.c \
140 transport_api_monitoring.c 140 transport_api_monitor_peers.c \
141 transport_api_monitor_validation.c
141libgnunettransport_la_LIBADD = \ 142libgnunettransport_la_LIBADD = \
142 $(top_builddir)/src/hello/libgnunethello.la \ 143 $(top_builddir)/src/hello/libgnunethello.la \
143 $(top_builddir)/src/util/libgnunetutil.la \ 144 $(top_builddir)/src/util/libgnunetutil.la \
@@ -1032,7 +1033,7 @@ test_transport_address_switch_tcp_LDADD = \
1032 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 1033 $(top_builddir)/src/statistics/libgnunetstatistics.la \
1033 $(top_builddir)/src/util/libgnunetutil.la \ 1034 $(top_builddir)/src/util/libgnunetutil.la \
1034 $(top_builddir)/src/transport/libgnunettransporttesting.la 1035 $(top_builddir)/src/transport/libgnunettransporttesting.la
1035 1036
1036 test_transport_address_switch_udp_SOURCES = \ 1037 test_transport_address_switch_udp_SOURCES = \
1037 test_transport_address_switch.c 1038 test_transport_address_switch.c
1038test_transport_address_switch_udp_LDADD = \ 1039test_transport_address_switch_udp_LDADD = \
@@ -1041,8 +1042,8 @@ test_transport_address_switch_udp_LDADD = \
1041 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 1042 $(top_builddir)/src/statistics/libgnunetstatistics.la \
1042 $(top_builddir)/src/util/libgnunetutil.la \ 1043 $(top_builddir)/src/util/libgnunetutil.la \
1043 $(top_builddir)/src/transport/libgnunettransporttesting.la 1044 $(top_builddir)/src/transport/libgnunettransporttesting.la
1044 1045
1045 1046
1046 test_transport_address_switch_http_SOURCES = \ 1047 test_transport_address_switch_http_SOURCES = \
1047 test_transport_address_switch.c 1048 test_transport_address_switch.c
1048test_transport_address_switch_http_LDADD = \ 1049test_transport_address_switch_http_LDADD = \
@@ -1051,7 +1052,7 @@ test_transport_address_switch_http_LDADD = \
1051 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 1052 $(top_builddir)/src/statistics/libgnunetstatistics.la \
1052 $(top_builddir)/src/util/libgnunetutil.la \ 1053 $(top_builddir)/src/util/libgnunetutil.la \
1053 $(top_builddir)/src/transport/libgnunettransporttesting.la 1054 $(top_builddir)/src/transport/libgnunettransporttesting.la
1054 1055
1055 test_transport_address_switch_https_SOURCES = \ 1056 test_transport_address_switch_https_SOURCES = \
1056 test_transport_address_switch.c 1057 test_transport_address_switch.c
1057test_transport_address_switch_https_LDADD = \ 1058test_transport_address_switch_https_LDADD = \