aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorNils Durner <durner@gnunet.org>2010-06-29 15:58:34 +0000
committerNils Durner <durner@gnunet.org>2010-06-29 15:58:34 +0000
commit0bd8cc55c82bedce06f65f52ea446f82427d2c0d (patch)
tree0b077ae3d52819ad5be412b94f678b71a4e5dcb9 /src/util/Makefile.am
parent4b6526cb3b6b9f323b3f9f4020db2f493d286939 (diff)
downloadgnunet-0bd8cc55c82bedce06f65f52ea446f82427d2c0d.tar.gz
gnunet-0bd8cc55c82bedce06f65f52ea446f82427d2c0d.zip
HKDF (does not work yet)
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 9cc402fc5..0b878c673 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -40,6 +40,7 @@ libgnunetutil_la_SOURCES = \
40 crypto_aes.c \ 40 crypto_aes.c \
41 crypto_crc.c \ 41 crypto_crc.c \
42 crypto_hash.c \ 42 crypto_hash.c \
43 crypto_hkdf.c \
43 crypto_ksk.c \ 44 crypto_ksk.c \
44 crypto_random.c \ 45 crypto_random.c \
45 crypto_rsa.c \ 46 crypto_rsa.c \
@@ -112,6 +113,7 @@ check_PROGRAMS = \
112 test_crypto_aes_weak \ 113 test_crypto_aes_weak \
113 test_crypto_crc \ 114 test_crypto_crc \
114 test_crypto_hash \ 115 test_crypto_hash \
116# test_crypto_hkdf \
115 test_crypto_ksk \ 117 test_crypto_ksk \
116 test_crypto_random \ 118 test_crypto_random \
117 test_crypto_rsa \ 119 test_crypto_rsa \
@@ -227,6 +229,11 @@ test_crypto_hash_SOURCES = \
227test_crypto_hash_LDADD = \ 229test_crypto_hash_LDADD = \
228 $(top_builddir)/src/util/libgnunetutil.la 230 $(top_builddir)/src/util/libgnunetutil.la
229 231
232test_crypto_hkdf_SOURCES = \
233 test_crypto_hkdf.c
234test_crypto_hkdf_LDADD = \
235 $(top_builddir)/src/util/libgnunetutil.la
236
230test_crypto_ksk_SOURCES = \ 237test_crypto_ksk_SOURCES = \
231 test_crypto_ksk.c 238 test_crypto_ksk.c
232test_crypto_ksk_LDADD = \ 239test_crypto_ksk_LDADD = \