aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2009-11-01 21:00:19 +0000
committerChristian Grothoff <christian@grothoff.org>2009-11-01 21:00:19 +0000
commit4ef69642e14a2d44008e9d7cf72f0d81fb149598 (patch)
treeacff9fdb2b43396787fbb3dc9d1d21b12fbee772 /src/util/Makefile.am
parent652e89b59ed2207c2c12172fdabcd6e659995c81 (diff)
downloadgnunet-4ef69642e14a2d44008e9d7cf72f0d81fb149598.tar.gz
gnunet-4ef69642e14a2d44008e9d7cf72f0d81fb149598.zip
trick automake/libtool into NOT linking with g++ on non-W32 systems -- hopefully without breaking W32 build
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 9c9802847..822ed19a6 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -3,8 +3,17 @@ INCLUDES = -I$(top_srcdir)/src/include
3plugindir = $(libdir)/gnunet 3plugindir = $(libdir)/gnunet
4 4
5if MINGW 5if MINGW
6 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols -lole32 -lshell32 -luuid -liconv -lstdc++ -lcomdlg32 -lgdi32 6noinst_LIBRARIES = \
7 WINSRC = win.cc winproc.c 7 libgnunetutilwin.a
8libgnunetutilwin_a_SOURCES = \
9 win.cc \
10 winproc.c
11libgnunetutilwin_a_LDFLAGS = \
12 -Wl,--no-undefined -Wl,--export-all-symbols
13libgnunetutilwin_a_LIBADD = \
14 -lole32 -lshell32 -luuid -liconv -lstdc++ \
15 -lcomdlg32 -lgdi32
16WINLIB = libgnunetutilwin.a
8endif 17endif
9 18
10if USE_COVERAGE 19if USE_COVERAGE
@@ -59,12 +68,12 @@ libgnunetutil_la_SOURCES = \
59 68
60 69
61libgnunetutil_la_LIBADD = \ 70libgnunetutil_la_LIBADD = \
62 $(GCLIBADD) \ 71 $(GCLIBADD) $(WINLIB) \
63 $(LIBGCRYPT_LIBS) \ 72 $(LIBGCRYPT_LIBS) \
64 -lgmp -lltdl -lz -lextractor $(XLIB) 73 -lgmp -lltdl -lz -lextractor $(XLIB)
65 74
66libgnunetutil_la_LDFLAGS = \ 75libgnunetutil_la_LDFLAGS = \
67 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 76 $(GN_LIB_LDFLAGS) \
68 -version-info 4:0:0 77 -version-info 4:0:0
69 78
70 79