aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2011-10-06 07:45:59 +0000
committerChristian Grothoff <christian@grothoff.org>2011-10-06 07:45:59 +0000
commit7c761db5dc34daba09b587c6b5abc3090b253010 (patch)
tree96ad5463d81ce5452c54b172214f3715fd29ab0b /src/util/Makefile.am
parent09ba4f230cd95676753a791c30db18489dca5c49 (diff)
downloadgnunet-7c761db5dc34daba09b587c6b5abc3090b253010.tar.gz
gnunet-7c761db5dc34daba09b587c6b5abc3090b253010.zip
testcase for runtime loglevels form LRN
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am17
1 files changed, 15 insertions, 2 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 02f823442..d816bc42c 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -26,7 +26,8 @@ if USE_COVERAGE
26endif 26endif
27 27
28noinst_PROGRAMS = \ 28noinst_PROGRAMS = \
29 gnunet-config-diff 29 gnunet-config-diff \
30 test_common_logging_dummy
30 31
31gnunet_config_diff_SOURCES = \ 32gnunet_config_diff_SOURCES = \
32 gnunet-config-diff.c 33 gnunet-config-diff.c
@@ -35,6 +36,12 @@ gnunet_config_diff_LDADD = \
35gnunet_config_diff_DEPENDENCIES = \ 36gnunet_config_diff_DEPENDENCIES = \
36 libgnunetutil.la 37 libgnunetutil.la
37 38
39test_common_logging_dummy_SOURCES = \
40 test_common_logging_dummy.c
41test_common_logging_dummy_LDADD = \
42 $(top_builddir)/src/util/libgnunetutil.la
43test_common_logging_dummy_DEPENDENCIES = \
44 libgnunetutil.la
38 45
39lib_LTLIBRARIES = libgnunetutil.la 46lib_LTLIBRARIES = libgnunetutil.la
40 47
@@ -175,7 +182,8 @@ check_PROGRAMS = \
175 test_strings \ 182 test_strings \
176 test_time \ 183 test_time \
177 $(BENCHMARKS) \ 184 $(BENCHMARKS) \
178 test_os_start_process 185 test_os_start_process \
186 test_common_logging_runtime_loglevels
179 187
180if ENABLE_TEST_RUN 188if ENABLE_TEST_RUN
181TESTS = $(check_PROGRAMS) 189TESTS = $(check_PROGRAMS)
@@ -212,6 +220,11 @@ test_common_logging_SOURCES = \
212test_common_logging_LDADD = \ 220test_common_logging_LDADD = \
213 $(top_builddir)/src/util/libgnunetutil.la 221 $(top_builddir)/src/util/libgnunetutil.la
214 222
223test_common_logging_runtime_loglevels_SOURCES = \
224 test_common_logging_runtime_loglevels.c
225test_common_logging_runtime_loglevels_LDADD = \
226 $(top_builddir)/src/util/libgnunetutil.la
227
215test_configuration_SOURCES = \ 228test_configuration_SOURCES = \
216 test_configuration.c 229 test_configuration.c
217test_configuration_LDADD = \ 230test_configuration_LDADD = \