aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorNils Durner <durner@gnunet.org>2009-10-03 15:36:09 +0000
committerNils Durner <durner@gnunet.org>2009-10-03 15:36:09 +0000
commitd5f3c16326273625b37cd0f2d5b4716ac650f51d (patch)
tree558efc6c02137036c8984fdb24b966117e3470d2 /src/util/Makefile.am
parent382d50480d96cbd5b5b7a45997cfe6f33b914a3b (diff)
downloadgnunet-d5f3c16326273625b37cd0f2d5b4716ac650f51d.tar.gz
gnunet-d5f3c16326273625b37cd0f2d5b4716ac650f51d.zip
use singly linked lists instead of vectors
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index f69c64b9f..32d1299d0 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -27,6 +27,7 @@ libgnunetutil_la_SOURCES = \
27 container_heap.c \ 27 container_heap.c \
28 container_meta_data.c \ 28 container_meta_data.c \
29 container_multihashmap.c \ 29 container_multihashmap.c \
30 container_slist.c \
30 crypto_aes.c \ 31 crypto_aes.c \
31 crypto_crc.c \ 32 crypto_crc.c \
32 crypto_hash.c \ 33 crypto_hash.c \
@@ -96,6 +97,7 @@ check_PROGRAMS = \
96 test_container_meta_data \ 97 test_container_meta_data \
97 test_container_multihashmap \ 98 test_container_multihashmap \
98 test_container_heap \ 99 test_container_heap \
100 test_container_slist \
99 test_crypto_aes \ 101 test_crypto_aes \
100 test_crypto_aes_weak \ 102 test_crypto_aes_weak \
101 test_crypto_crc \ 103 test_crypto_crc \
@@ -175,6 +177,11 @@ test_container_heap_SOURCES = \
175test_container_heap_LDADD = \ 177test_container_heap_LDADD = \
176 $(top_builddir)/src/util/libgnunetutil.la 178 $(top_builddir)/src/util/libgnunetutil.la
177 179
180test_container_slist_SOURCES = \
181 test_container_slist.c
182test_container_slist_LDADD = \
183 $(top_builddir)/src/util/libgnunetutil.la
184
178test_crypto_aes_SOURCES = \ 185test_crypto_aes_SOURCES = \
179 test_crypto_aes.c 186 test_crypto_aes.c
180test_crypto_aes_LDADD = \ 187test_crypto_aes_LDADD = \