aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2009-10-01 16:23:25 +0000
committerChristian Grothoff <christian@grothoff.org>2009-10-01 16:23:25 +0000
commitf0aa7bc0a136b1e436018ef72e1c814f04c33379 (patch)
treed52c0ad69e3507610fb3271f1f5273bd4d05c124 /src/util/Makefile.am
parent028a762caf0c2e1cc7b23a9dc4becf9859d13c15 (diff)
downloadgnunet-f0aa7bc0a136b1e436018ef72e1c814f04c33379.tar.gz
gnunet-f0aa7bc0a136b1e436018ef72e1c814f04c33379.zip
moving resolver to util, making DNS lookups asynchronous in util
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am20
1 files changed, 19 insertions, 1 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 240c86247..f69c64b9f 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -46,6 +46,7 @@ libgnunetutil_la_SOURCES = \
46 plugin.c \ 46 plugin.c \
47 program.c \ 47 program.c \
48 pseudonym.c \ 48 pseudonym.c \
49 resolver_api.c \
49 scheduler.c \ 50 scheduler.c \
50 server.c \ 51 server.c \
51 server_tc.c \ 52 server_tc.c \
@@ -66,6 +67,16 @@ libgnunetutil_la_LDFLAGS = \
66 -version-info 4:0:0 67 -version-info 4:0:0
67 68
68 69
70bin_PROGRAMS = \
71 gnunet-service-resolver
72
73gnunet_service_resolver_SOURCES = \
74 gnunet-service-resolver.c
75gnunet_service_resolver_LDADD = \
76 $(top_builddir)/src/util/libgnunetutil.la \
77 $(GN_LIBINTL)
78
79
69plugin_LTLIBRARIES = \ 80plugin_LTLIBRARIES = \
70 libgnunet_plugin_test.la 81 libgnunet_plugin_test.la
71 82
@@ -106,6 +117,7 @@ check_PROGRAMS = \
106 test_plugin \ 117 test_plugin \
107 test_program \ 118 test_program \
108 test_pseudonym \ 119 test_pseudonym \
120 test_resolver_api \
109 test_scheduler \ 121 test_scheduler \
110 test_scheduler_delay \ 122 test_scheduler_delay \
111 test_server \ 123 test_server \
@@ -157,7 +169,7 @@ test_container_multihashmap_SOURCES = \
157 test_container_multihashmap.c 169 test_container_multihashmap.c
158test_container_multihashmap_LDADD = \ 170test_container_multihashmap_LDADD = \
159 $(top_builddir)/src/util/libgnunetutil.la 171 $(top_builddir)/src/util/libgnunetutil.la
160 172
161test_container_heap_SOURCES = \ 173test_container_heap_SOURCES = \
162 test_container_heap.c 174 test_container_heap.c
163test_container_heap_LDADD = \ 175test_container_heap_LDADD = \
@@ -268,6 +280,11 @@ test_pseudonym_SOURCES = \
268test_pseudonym_LDADD = \ 280test_pseudonym_LDADD = \
269 $(top_builddir)/src/util/libgnunetutil.la 281 $(top_builddir)/src/util/libgnunetutil.la
270 282
283test_resolver_api_SOURCES = \
284 test_resolver_api.c
285test_resolver_api_LDADD = \
286 $(top_builddir)/src/util/libgnunetutil.la
287
271test_scheduler_SOURCES = \ 288test_scheduler_SOURCES = \
272 test_scheduler.c 289 test_scheduler.c
273test_scheduler_LDADD = \ 290test_scheduler_LDADD = \
@@ -319,4 +336,5 @@ EXTRA_DIST = \
319 test_container_meta_data_image.jpg \ 336 test_container_meta_data_image.jpg \
320 test_program_data.conf \ 337 test_program_data.conf \
321 test_pseudonym_data.conf \ 338 test_pseudonym_data.conf \
339 test_resolver_api_data.conf \
322 test_service_data.conf 340 test_service_data.conf