aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorSchanzenbach, Martin <martin.schanzenbach@aisec.fraunhofer.de>2018-01-03 10:11:40 +0100
committerSchanzenbach, Martin <martin.schanzenbach@aisec.fraunhofer.de>2018-01-03 10:11:40 +0100
commitfb85cf602c67994646c156aa9e05d2b9aa10816c (patch)
treeed14e694bb1ce9c11e7cebd0aa445ad41f7c2c7e /src/util/Makefile.am
parent7c1f035ed971e12882cd7a65c7d36883842945b1 (diff)
downloadgnunet-fb85cf602c67994646c156aa9e05d2b9aa10816c.tar.gz
gnunet-fb85cf602c67994646c156aa9e05d2b9aa10816c.zip
-move abe functionality out of util; prepare for release
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am23
1 files changed, 0 insertions, 23 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index cc9ff4745..eb655157d 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -119,18 +119,6 @@ libgnunetutil_la_LIBADD = \
119 $(LTLIBINTL) \ 119 $(LTLIBINTL) \
120 -lltdl $(Z_LIBS) -lunistring $(XLIB) 120 -lltdl $(Z_LIBS) -lunistring $(XLIB)
121 121
122if HAVE_PBC
123if HAVE_ABE
124libgnunetutil_la_SOURCES += \
125 crypto_abe.c
126libgnunetutil_la_LIBADD += \
127 $(ABE_LIBADD) \
128 -lgabe \
129 -lpbc \
130 -lglib-2.0
131endif
132endif
133
134libgnunetutil_la_LDFLAGS = \ 122libgnunetutil_la_LDFLAGS = \
135 $(GN_LIB_LDFLAGS) \ 123 $(GN_LIB_LDFLAGS) \
136 -version-info 13:0:0 124 -version-info 13:0:0
@@ -564,17 +552,6 @@ test_speedup_SOURCES = \
564test_speedup_LDADD = \ 552test_speedup_LDADD = \
565 libgnunetutil.la 553 libgnunetutil.la
566 554
567if HAVE_PBC
568if HAVE_ABE
569test_crypto_abe_SOURCES = \
570 test_crypto_abe.c
571test_crypto_abe_LDADD = \
572 libgnunetutil.la
573check_PROGRAMS += \
574 test_crypto_abe
575endif
576endif
577
578perf_crypto_hash_SOURCES = \ 555perf_crypto_hash_SOURCES = \
579 perf_crypto_hash.c 556 perf_crypto_hash.c
580perf_crypto_hash_LDADD = \ 557perf_crypto_hash_LDADD = \