aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorAlessio Vanni <vannilla@firemail.cc>2021-07-23 18:20:33 +0200
committerAlessio Vanni <vannilla@firemail.cc>2021-07-24 22:28:04 +0200
commitfd1bcccb9b6063d0501c81323eef81c0dd7a6340 (patch)
treecac2c551ef0cab8671546afa0190d02e13f2c895 /src/util/Makefile.am
parent31eae6bbe16302d2593b806ef3d2ac2ca9c2d8de (diff)
downloadgnunet-fd1bcccb9b6063d0501c81323eef81c0dd7a6340.tar.gz
gnunet-fd1bcccb9b6063d0501c81323eef81c0dd7a6340.zip
5708: allow gnunet-config to output build config informations
With this commit, `gnunet-config' is now able to print some informations about how GNUnet was built through some additional flags (here `--cflags', `--libs' and `--prefix'.) These flags allow `gnunet-config' to behave like other `*-config' tools provided by other applications/libraries, which are used by third-party applications, especially when the tool is provided by a library, to properly compile using the flags recommended by the library/application. In terms of GNUnet, any client or service connecting to any GNUnet service can now be built using some variation of the following: cc $(gnunet-config --cflags) -o my-client client.c $(gnunet-config --libs)
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index e720112be..ab66756b4 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -227,6 +227,11 @@ gnunet_config_SOURCES = \
227gnunet_config_LDADD = \ 227gnunet_config_LDADD = \
228 libgnunetutil.la \ 228 libgnunetutil.la \
229 $(GN_LIBINTL) 229 $(GN_LIBINTL)
230gnunet_config_CPPFLAGS = \
231 -DINCLUDEDIR=\"$(includedir)\" \
232 -DLIBDIR=\"$(libdir)\" \
233 -DPREFIX=\"$(prefix)\" \
234 $(AM_CPPFLAGS)
230 235
231gnunet_uri_SOURCES = \ 236gnunet_uri_SOURCES = \
232 gnunet-uri.c 237 gnunet-uri.c