aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2011-05-24 16:26:10 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2011-05-24 16:26:10 +0000
commitfef362e060524f45452a6f4f2c31f52474f9cf7e (patch)
treef1ce418865d4efaff221e5976d7bc73cae0504b2 /src/util/Makefile.am
parent5cdc9eb4091dfbfd1d65c4aaf1e3dfdd4b5b6316 (diff)
downloadgnunet-fef362e060524f45452a6f4f2c31f52474f9cf7e.tar.gz
gnunet-fef362e060524f45452a6f4f2c31f52474f9cf7e.zip
testcase
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index b24b3ab7c..3a03516db 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -16,6 +16,10 @@ libgnunetutilwin_la_LIBADD = \
16WINLIB = libgnunetutilwin.la 16WINLIB = libgnunetutilwin.la
17endif 17endif
18 18
19if !MINGW
20 SERVER_CLIENT_UNIX = test_server_with_client_unix
21endif
22
19if USE_COVERAGE 23if USE_COVERAGE
20 AM_CFLAGS = --coverage -O0 24 AM_CFLAGS = --coverage -O0
21 XLIB = -lgcov 25 XLIB = -lgcov
@@ -150,6 +154,7 @@ check_PROGRAMS = \
150 test_server \ 154 test_server \
151 test_server_disconnect \ 155 test_server_disconnect \
152 test_server_with_client \ 156 test_server_with_client \
157 $(SERVER_CLIENT_UNIX) \
153 test_service \ 158 test_service \
154 test_strings \ 159 test_strings \
155 test_time \ 160 test_time \
@@ -362,6 +367,12 @@ test_server_with_client_SOURCES = \
362test_server_with_client_LDADD = \ 367test_server_with_client_LDADD = \
363 $(top_builddir)/src/util/libgnunetutil.la 368 $(top_builddir)/src/util/libgnunetutil.la
364 369
370test_server_with_client_unix_SOURCES = \
371 test_server_with_client_unix.c
372test_server_with_client_unix_LDADD = \
373 $(top_builddir)/src/util/libgnunetutil.la
374
375
365test_service_SOURCES = \ 376test_service_SOURCES = \
366 test_service.c 377 test_service.c
367test_service_LDADD = \ 378test_service_LDADD = \