aboutsummaryrefslogtreecommitdiff
path: root/src/vpn/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-01-25 21:26:27 +0000
committerChristian Grothoff <christian@grothoff.org>2012-01-25 21:26:27 +0000
commit62947a2d1690f607276aa84c36f269fe188fcb20 (patch)
tree21ee19033fdd544f18daf8efd1cd54df76728ba1 /src/vpn/Makefile.am
parent95b2bc87d15ff0f44005081da8b5925839f30cf6 (diff)
downloadgnunet-62947a2d1690f607276aa84c36f269fe188fcb20.tar.gz
gnunet-62947a2d1690f607276aa84c36f269fe188fcb20.zip
-expanding tests to cover 4-to-6, 6-to-4 and 6-over-4 as well
Diffstat (limited to 'src/vpn/Makefile.am')
-rw-r--r--src/vpn/Makefile.am31
1 files changed, 28 insertions, 3 deletions
diff --git a/src/vpn/Makefile.am b/src/vpn/Makefile.am
index fea89724d..2cd798591 100644
--- a/src/vpn/Makefile.am
+++ b/src/vpn/Makefile.am
@@ -34,7 +34,11 @@ bin_PROGRAMS = \
34 34
35 35
36if HAVE_MHD 36if HAVE_MHD
37 VPN_TEST = test_gnunet_vpn 37 VPN_TEST = \
38 test_gnunet_vpn-4_to_6 \
39 test_gnunet_vpn-6_to_4 \
40 test_gnunet_vpn-6_over \
41 test_gnunet_vpn-4_over
38endif 42endif
39 43
40check_PROGRAMS = $(VPN_TEST) 44check_PROGRAMS = $(VPN_TEST)
@@ -75,9 +79,30 @@ libgnunetvpn_la_LDFLAGS = \
75 $(GN_LIB_LDFLAGS) 79 $(GN_LIB_LDFLAGS)
76 80
77 81
78test_gnunet_vpn_SOURCES = \ 82test_gnunet_vpn_4_over_SOURCES = \
79 test_gnunet_vpn.c 83 test_gnunet_vpn.c
80test_gnunet_vpn_LDADD = -lmicrohttpd @LIBCURL@ \ 84test_gnunet_vpn_4_over_LDADD = -lmicrohttpd @LIBCURL@ \
85 $(top_builddir)/src/vpn/libgnunetvpn.la \
86 $(top_builddir)/src/arm/libgnunetarm.la \
87 $(top_builddir)/src/util/libgnunetutil.la
88
89test_gnunet_vpn_6_over_SOURCES = \
90 test_gnunet_vpn.c
91test_gnunet_vpn_6_over_LDADD = -lmicrohttpd @LIBCURL@ \
92 $(top_builddir)/src/vpn/libgnunetvpn.la \
93 $(top_builddir)/src/arm/libgnunetarm.la \
94 $(top_builddir)/src/util/libgnunetutil.la
95
96test_gnunet_vpn_4_to_6_SOURCES = \
97 test_gnunet_vpn.c
98test_gnunet_vpn_4_to_6_LDADD = -lmicrohttpd @LIBCURL@ \
99 $(top_builddir)/src/vpn/libgnunetvpn.la \
100 $(top_builddir)/src/arm/libgnunetarm.la \
101 $(top_builddir)/src/util/libgnunetutil.la
102
103test_gnunet_vpn_6_to_4_SOURCES = \
104 test_gnunet_vpn.c
105test_gnunet_vpn_6_to_4_LDADD = -lmicrohttpd @LIBCURL@ \
81 $(top_builddir)/src/vpn/libgnunetvpn.la \ 106 $(top_builddir)/src/vpn/libgnunetvpn.la \
82 $(top_builddir)/src/arm/libgnunetarm.la \ 107 $(top_builddir)/src/arm/libgnunetarm.la \
83 $(top_builddir)/src/util/libgnunetutil.la 108 $(top_builddir)/src/util/libgnunetutil.la