aboutsummaryrefslogtreecommitdiff
path: root/src/zonemaster/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2017-01-04 22:11:55 +0100
committerChristian Grothoff <christian@grothoff.org>2017-01-04 22:11:55 +0100
commit5672e0e27b671fa878143e5eed8a9b677588b178 (patch)
tree91a9a5bbeac95a3a65b08484d3295ee3cd03e8b8 /src/zonemaster/Makefile.am
parent60c6dfd1fe22a01a3f7723e7e2bb18d52895c527 (diff)
downloadgnunet-5672e0e27b671fa878143e5eed8a9b677588b178.tar.gz
gnunet-5672e0e27b671fa878143e5eed8a9b677588b178.zip
move functionality of publishing namestore zone in DHT from GNS service to new zonemaster service
Diffstat (limited to 'src/zonemaster/Makefile.am')
-rw-r--r--src/zonemaster/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/src/zonemaster/Makefile.am b/src/zonemaster/Makefile.am
new file mode 100644
index 000000000..21f986498
--- /dev/null
+++ b/src/zonemaster/Makefile.am
@@ -0,0 +1,35 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4plugindir = $(libdir)/gnunet
5
6pkgcfgdir= $(pkgdatadir)/config.d/
7
8libexecdir= $(pkglibdir)/libexec/
9
10pkgcfg_DATA = \
11 zonemaster.conf
12
13if MINGW
14 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
15endif
16
17if USE_COVERAGE
18 AM_CFLAGS = --coverage -O0
19 XLIBS = -lgcov
20endif
21
22libexec_PROGRAMS = \
23 gnunet-service-zonemaster
24
25gnunet_service_zonemaster_SOURCES = \
26 gnunet-service-zonemaster.c
27
28gnunet_service_zonemaster_LDADD = \
29 $(top_builddir)/src/dht/libgnunetdht.la \
30 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
31 $(top_builddir)/src/statistics/libgnunetstatistics.la \
32 $(top_builddir)/src/util/libgnunetutil.la \
33 $(top_builddir)/src/namestore/libgnunetnamestore.la \
34 $(GN_LIBINTL)
35