aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f56d2f508..f1c93b309 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1357,7 +1357,6 @@ DATAROOTDIR=$datarootdir
1357AC_SUBST(DATAROOTDIR) 1357AC_SUBST(DATAROOTDIR)
1358 1358
1359# test for sudo 1359# test for sudo
1360# TODO: do we need to change anything for "doas" on openbsd?
1361AC_MSG_CHECKING(for sudo) 1360AC_MSG_CHECKING(for sudo)
1362AC_ARG_WITH(sudo, 1361AC_ARG_WITH(sudo,
1363 [ --with-sudo=PATH path to sudo binary (or just yes)], 1362 [ --with-sudo=PATH path to sudo binary (or just yes)],
@@ -1371,6 +1370,10 @@ AC_SUBST(SUDO_BINARY)
1371AM_CONDITIONAL([HAVE_SUDO], 1370AM_CONDITIONAL([HAVE_SUDO],
1372 [test "x$SUDO_BINARY" != "x" -o -w /]) 1371 [test "x$SUDO_BINARY" != "x" -o -w /])
1373 1372
1373# test for doas
1374AC_MSG_CHECKING(for doas)
1375AC_CHECK_PROGS(DOAS_BINARY, [doas], false)
1376AM_CONDITIONAL(HAVE_DOAS_BINARY, test x$DOAS_BINARY != xfalse)
1374 1377
1375# test for gnunetdns group name 1378# test for gnunetdns group name
1376GNUNETDNS_GROUP=gnunetdns 1379GNUNETDNS_GROUP=gnunetdns