aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ee85f474e..16a4cf686 100644
--- a/configure.ac
+++ b/configure.ac
@@ -86,11 +86,11 @@ AC_DEFUN([CC_CHECK_CFLAGS_SILENT], [
86# Check for CFLAG and appends them to CFLAGS if supported 86# Check for CFLAG and appends them to CFLAGS if supported
87AC_DEFUN([CC_CHECK_CFLAG_APPEND], [ 87AC_DEFUN([CC_CHECK_CFLAG_APPEND], [
88 AC_CACHE_CHECK([if $CC supports -Wno-$1 flag], 88 AC_CACHE_CHECK([if $CC supports -Wno-$1 flag],
89 AS_TR_SH([cc_cv_cflags_$1]), 89 AS_TR_SH([cc_cv_cflags_-W$1]),
90 CC_CHECK_CFLAGS_SILENT([-W$1]) #gcc is stupid. It does not fail with the -W-no option for backwards compat but then shows the error "in case something goes wrong". 90 CC_CHECK_CFLAGS_SILENT([-W$1]) #gcc is stupid. It does not fail with the -W-no option for backwards compat but then shows the error "in case something goes wrong".
91 ) 91 )
92 92
93 AS_IF([eval test x$]AS_TR_SH([cc_cv_cflags_$1])[ = xyes], 93 AS_IF([eval test x$]AS_TR_SH([cc_cv_cflags_-W$1])[ = xyes],
94 [CFLAGS="$CFLAGS -Wno-$1"; $2], [$3]) 94 [CFLAGS="$CFLAGS -Wno-$1"; $2], [$3])
95]) 95])
96 96