aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac466
1 files changed, 211 insertions, 255 deletions
diff --git a/configure.ac b/configure.ac
index 60ff7e4b9..316257f97 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
1# This file is part of GNUnet. 1# This file is part of GNUnet.
2# (C) 2001--2022 GNUnet e.V. 2# (C) 2001--2023 GNUnet e.V.
3# 3#
4# GNUnet is free software: you can redistribute it and/or modify it 4# GNUnet is free software: you can redistribute it and/or modify it
5# under the terms of the GNU Affero General Public License as published 5# under the terms of the GNU Affero General Public License as published
@@ -20,12 +20,22 @@
20# 20#
21# 21#
22AC_PREREQ([2.69]) 22AC_PREREQ([2.69])
23AC_INIT([gnunet],[m4_esyscmd_s(sh contrib/get_version.sh)],[bug-gnunet@gnu.org]) 23AC_INIT([gnunet],[m4_esyscmd_s(sh scripts/get_version.sh)],[bug-gnunet@gnu.org])
24
25gnunet_version=m4_esyscmd_s(sh scripts/get_version.sh)
26gnunet_major_version=m4_esyscmd_s(sh scripts/get_version.sh --major)
27gnunet_minor_version=m4_esyscmd_s(sh scripts/get_version.sh --minor)
28gnunet_micro_version=m4_esyscmd_s(sh scripts/get_version.sh --micro)
29
30AC_SUBST([gnunet_version])
31AC_SUBST([gnunet_major_version])
32AC_SUBST([gnunet_minor_version])
33AC_SUBST([gnunet_micro_version])
24 34
25AC_CONFIG_AUX_DIR([build-aux]) 35AC_CONFIG_AUX_DIR([build-aux])
26AC_CONFIG_MACRO_DIRS([m4]) 36AC_CONFIG_MACRO_DIRS([m4])
27 37
28AC_CONFIG_HEADERS([gnunet_config.h]) 38AC_CONFIG_HEADERS([gnunet_private_config.h])
29 39
30AC_CANONICAL_TARGET 40AC_CANONICAL_TARGET
31AC_CANONICAL_HOST 41AC_CANONICAL_HOST
@@ -442,15 +452,10 @@ AC_ARG_ENABLE([documentation],
442 [documentation=${enableval}], 452 [documentation=${enableval}],
443 [documentation=yes]) 453 [documentation=yes])
444 454
445AC_CHECK_PROG([SPHINX_BINARY], [sphinx-build], [true], [false]) 455AC_CHECK_PROG([DOXY_BINARY], [doxygen], [true], [false])
446AM_CONDITIONAL([HAVE_SPHINX_BINARY], [$SPHINX_BINARY]) 456AM_CONDITIONAL([HAVE_DOXY_BINARY], [$DOXY_BINARY])
447 457
448AM_CONDITIONAL([DOCUMENTATION], [test "x$documentation" = "xyes"]) 458AM_CONDITIONAL([DOCUMENTATION], [test "x$documentation" = "xyes"])
449AS_IF([test "x$documentation" = "xyes"],
450 [AS_IF([$SPHINX_BINARY],
451 [AC_DEFINE([DOCUMENTATION], [1], [Define to 1 if documentation is built])],
452 [AC_MSG_ERROR([Documentation requires sphinx])])],
453 [AC_DEFINE([DOCUMENTATION], [0], [Define to 1 if documentation is built])])
454 459
455AC_CHECK_PROGS([MANDOC_BINARY], [mandoc], [false]) 460AC_CHECK_PROGS([MANDOC_BINARY], [mandoc], [false])
456AM_CONDITIONAL([HAVE_MANDOC], [test "x$MANDOC_BINARY" != "xfalse"]) 461AM_CONDITIONAL([HAVE_MANDOC], [test "x$MANDOC_BINARY" != "xfalse"])
@@ -484,7 +489,7 @@ AC_ARG_ENABLE([gcc-hardening],
484 [AS_HELP_STRING([--enable-gcc-hardening], [enable compiler security checks])], 489 [AS_HELP_STRING([--enable-gcc-hardening], [enable compiler security checks])],
485 [AS_IF([test "x$enableval" = "xyes"], 490 [AS_IF([test "x$enableval" = "xyes"],
486 [CFLAGS="$CFLAGS -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-all" 491 [CFLAGS="$CFLAGS -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-all"
487 CFLAGS="$CFLAGS -fwrapv -fPIE -Wstacl-protector" 492 CFLAGS="$CFLAGS -fwrapv -fPIE -Wstack-protector"
488 CFLAGS="$CFLAGS --param ssp-buffer-size=1" 493 CFLAGS="$CFLAGS --param ssp-buffer-size=1"
489 LDFLAGS="$LDFLAGS -pie"])]) 494 LDFLAGS="$LDFLAGS -pie"])])
490 495
@@ -598,16 +603,6 @@ gcry_md_close (mac);]])],
598 [AC_MSG_RESULT([cross compiling, test skipped])]) 603 [AC_MSG_RESULT([cross compiling, test skipped])])
599 AC_LANG_POP([C])]) 604 AC_LANG_POP([C])])
600 605
601AC_MSG_CHECKING([for static assertion support])
602AC_COMPILE_IFELSE([AC_LANG_PROGRAM([],
603 [[_Static_assert(sizeof(int) >= 4, "not big enough");]])],
604 [AC_MSG_RESULT([yes])
605 AC_DEFINE([HAVE_STATIC_ASSERT], [1],
606 [Define to 1 if static assert is supported])],
607 [AC_MSG_RESULT([no])
608 AC_DEFINE([HAVE_STATIC_ASSERT], [0],
609 [Define to 1 if static assert is supported])])
610
611dnl Helper function to shorten the amount of repeated code 606dnl Helper function to shorten the amount of repeated code
612dnl It will create a --with-<lib> option for configure. 607dnl It will create a --with-<lib> option for configure.
613dnl 608dnl
@@ -719,35 +714,36 @@ AS_IF([test "x$pulse" != "x1" || test "x$opus" != "x1" || test "x$ogg" != "x1"],
719AM_CONDITIONAL([BUILD_CONVERSATION], [test "x$conversation_backend" != "xnone"]) 714AM_CONDITIONAL([BUILD_CONVERSATION], [test "x$conversation_backend" != "xnone"])
720AC_MSG_RESULT([$conversation_backend]) 715AC_MSG_RESULT([$conversation_backend])
721 716
722# check for libgnurl 717# NOTE: If we find libcurl-gnutls here we set LIBCURL to -lcurl-gnutls
723LIBGNURL_CHECK_CONFIG([], [7.34.0], 718# This affects the LIBCURL_CHECK_CONFIG call below as it takes LIBCURL into
724 [gnurl=1 719# account when checking for curl.
725 curl=0], 720LIBCURL="-lcurl"
726 [gnurl=0 721AC_CHECK_LIB([curl-gnutls],
727 curl=0]) 722 [curl_easy_getinfo],
728AS_IF([test "x$gnurl" = "x0"], 723 [LIBCURL="-lcurl-gnutls"])
729 [LIBCURL_CHECK_CONFIG([], [7.34.0], [curl=1], [curl=0]) 724
730 AS_IF([test "x$curl" = "x0"], 725LIBCURL_CHECK_CONFIG([], [7.85.0], [],
731 [AC_CHECK_HEADER([curl/curl.h], 726 [AC_MSG_ERROR([cURL must have a version >= 7.85.0])])
732 [AC_CHECK_DECLS([CURLINFO_TLS_SESSION], 727
733 [curl=1], 728OLD_LIBS=$LIBS
734 [curl=0], 729LIBS="$LIBS $LIBCURL"
735 [[#include <curl/curl.h>]])]) 730AC_RUN_IFELSE(
736 AC_CHECK_LIB([curl-gnutls], 731 [AC_LANG_PROGRAM([[#include <curl/curl.h>]],
737 [curl_easy_getinfo], 732 [[return (CURLSSLSET_OK != curl_global_sslset(CURLSSLBACKEND_GNUTLS, NULL, NULL));]])],
738 [curl_gnutls=1], 733 [curl_gnutls=1],
739 [curl_gnutls=0])]) 734 [AC_MSG_WARN([cURL does not have GnuTLS backend])
740 AS_IF([test "x$curl" = "x0" || test "x$curl_gnutls" = "x0"], 735 curl_gnutls=0])
741 [AC_MSG_ERROR([cURL must have a version >= 7.34.0 and must support CURLINFO_TLS_SESSION])])]) 736LIBS=$OLD_LIBS
742 737AM_CONDITIONAL([HAVE_GNUTLS_CURL], [test "x$curl_gnutls" = "x1"])
743AS_IF([test "x$gnurl" = "x0" && test "x$curl" = "x0"], 738AC_SUBST([curl_gnutls])
744 [AC_MSG_ERROR([either gnurl or cURL must be available])]) 739
745 740# Even if curl is found, we check for this constant in order to determine
746AM_CONDITIONAL([HAVE_LIBGNURL], [test "x$gnurl" = "x1"]) 741# if we can use this feature.
747AC_DEFINE_UNQUOTED([HAVE_LIBGNURL], [$gnurl], [Define to 1 if libgnurl is used]) 742AC_CHECK_HEADER([curl/curl.h],
748AM_CONDITIONAL([HAVE_LIBCURL], [test "x$curl" = "x1"]) 743 [AC_CHECK_DECLS([CURLINFO_TLS_SSL_PTR],
749AC_DEFINE_UNQUOTED([HAVE_LIBCURL], [$curl], [Define to 0 if libcurl is used]) 744 [],
750 745 [AC_MSG_ERROR([cURL must support CURLINFO_TLS_SSL_PTR])],
746 [[#include <curl/curl.h>]])])
751# libatomic 747# libatomic
752AC_SEARCH_LIBS([__atomic_load_8], [atomic], 748AC_SEARCH_LIBS([__atomic_load_8], [atomic],
753 [have_libatomic=1 749 [have_libatomic=1
@@ -772,13 +768,9 @@ AC_CHECK_LIB([kstat], [kstat_open])
772 768
773# check for libsodium version >= 1.0.18 769# check for libsodium version >= 1.0.18
774libsodium=0 770libsodium=0
775AC_CHECK_HEADER([sodium.h], 771CHECK_WITH_LIB([sodium], [crypto_core_ed25519_scalar_mul], [sodium.h], [HAVE_SODIUM])
776 [AC_CHECK_LIB([sodium], [crypto_core_ed25519_scalar_mul], 772AS_IF([test "x$sodium" = "x0"],
777 [libsodium=1], 773 [AC_MSG_ERROR([GNUnet requires libsodium >= 1.0.18])])
778 [libsodium=0])])
779
780AS_IF([test "x$libsodium" = "x0"],
781 [AC_MSG_ERROR([GNUnet requires libsodium >= 1.0.18])])
782 774
783# check for libextractor 775# check for libextractor
784CHECK_WITH_LIB([extractor], 776CHECK_WITH_LIB([extractor],
@@ -788,6 +780,14 @@ CHECK_WITH_LIB([extractor],
788AS_IF([test "x$extractor" = "x0"], 780AS_IF([test "x$extractor" = "x0"],
789 [AC_MSG_RESULT([GNU libextractor not found, some features disabled])]) 781 [AC_MSG_RESULT([GNU libextractor not found, some features disabled])])
790 782
783# check for cloudflare-quiche
784CHECK_WITH_LIB([quiche],
785 [quiche_header_info],
786 [quiche.h],
787 [HAVE_QUICHE])
788AS_IF([test "x$quiche" = "x0"],
789 [AC_MSG_RESULT([cloudflare-quiche not found, some features disabled])])
790
791# check for libltdl 791# check for libltdl
792CHECK_WITH_LIB([ltdl], [lt_dlopenext], [ltdl.h], [HAVE_LTDL]) 792CHECK_WITH_LIB([ltdl], [lt_dlopenext], [ltdl.h], [HAVE_LTDL])
793AS_IF([test "x$ldtl" = "x0"], 793AS_IF([test "x$ldtl" = "x0"],
@@ -882,9 +882,9 @@ AC_DEFINE_UNQUOTED([HAVE_ZLIB], [$zlib_ok], [Define to 1 if zlib is available])
882AM_ICONV 882AM_ICONV
883 883
884# check for libunistring 884# check for libunistring
885gl_LIBUNISTRING 885CHECK_WITH_LIB([unistring], [u16_strstr], [unistr.h], [HAVE_UNISTRING])
886AS_IF([test "x$HAVE_LIBUNISTRING" != "xyes"], 886AS_IF([test "x$unistring" = "x0"],
887 [AC_MSG_ERROR([GNUnet requires libunistring])]) 887 [AC_MSG_ERROR([GNUnet requires unistring])])
888 888
889# Currently broken on Debian :-( 889# Currently broken on Debian :-(
890# AS_VERSION_COMPARE([$LIBUNISTRING_VERSION], [0.9.1.1], 890# AS_VERSION_COMPARE([$LIBUNISTRING_VERSION], [0.9.1.1],
@@ -904,76 +904,6 @@ AM_CONDITIONAL([HAVE_POSTGRESQL], [test "x$postgres" = "x1"])
904AC_DEFINE_UNQUOTED([HAVE_POSTGRESQL], [$postgres], 904AC_DEFINE_UNQUOTED([HAVE_POSTGRESQL], [$postgres],
905 [Define to 1 if Postgres is available]) 905 [Define to 1 if Postgres is available])
906 906
907# check for mysql
908SAVE_LDFLAGS="$LDFLAGS"
909SAVE_CPPFLAGS="$CPPFLAGS"
910AC_ARG_WITH([mysql],
911 [AS_HELP_STRING([--with-mysql=PFX], [base of mysql installation])],
912 [AS_CASE([$withval],
913 [no],
914 [],
915 [yes|""],
916 [AC_CHECK_HEADERS([mysql/mysql.h],
917 [AC_CHECK_LIB([mysqlclient], [mysql_init],
918 [mysql=true], [mysql=false])])],
919 [LDFLAGS="-L$with_mysql/lib -L$with_mysql/lib/mysql $LDFLAGS $ZLIBS"
920 CPPFLAGS="-I$with_mysql/include $CPPFLAGS"
921 AC_CHECK_HEADERS([mysql/mysql.h],
922 [AC_CHECK_LIB([mysqlclient], [mysql_init],
923 [MYSQL_LDFLAGS="-L$with_mysql/lib -L$with_mysql/lib/mysql"
924 MYSQL_CPPFLAGS="-I$with_mysql/include"
925 mysql=true],
926 [mysql=false])])])],
927 [AS_IF([test -d "/usr/lib64/mysql"],
928 [MYSQL_LIBDIR="/usr/lib64/mysql"],
929 [AS_IF([test -d "/usr/lib/mysql"],
930 [MYSQL_LIBDIR="/usr/lib/mysql"],
931 [MYSQL_LIBDIR="/usr/lib"])])
932 LDFLAGS="-L$MYSQL_LIBDIR $LDFLAGS $ZLIBS"
933 AC_CHECK_LIB([mysqlclient], [mysql_init],
934 [AC_CHECK_HEADERS([mysql/mysql.h],
935 [MYSQL_LDFLAGS="-L$MYSQL_LIBDIR"
936 mysql=true],
937 [mysql=false])],
938 [mysql=false])])
939AC_SUBST(MYSQL_LDFLAGS)
940AC_SUBST(MYSQL_CPPFLAGS)
941
942# additional version checks for mysql
943AS_IF([test "x$mysql" = "xtrue"],
944 [AC_MSG_CHECKING([for mysql version])
945 AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
946 [[#include <mysql/mysql_version.h>]],
947 [[#if (MYSQL_VERSION_ID < 40100)
948#error required at least version 4.1
949#endif]])],
950 [mysql=true],
951 [mysql=false])
952 AS_IF([test "x$mysql" = "xfalse"],
953 [AC_MSG_RESULT([< 4.1])
954 AC_MSG_RESULT([mysql version >= 4.1 required. Will not use MySQL])])
955 AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
956 [[#include <mysql/mysql_version.h>]],
957 [[#if (MYSQL_VERSION_ID < 80000)
958#error needs at least version 8.0
959#endif]])],
960 [mysql8=true],
961 [mysql8=false])])
962
963AS_IF([test "x$mysql" = "xtrue"],
964 [AS_IF([test "x$mysql8" = "xfalse"],
965 [AC_MSG_RESULT([between 4.1 and 8.0])],
966 [AC_MSG_RESULT([> 8.0])
967 AC_DEFINE([HAVE_MYSQL8], [1],
968 [Define to 1 if MySQL is at least version 8])])])
969
970AM_CONDITIONAL([HAVE_MYSQL], [test "x$mysql" = "xtrue"])
971AM_CONDITIONAL([HAVE_MYSQLE], [false])
972
973AS_IF([test "x$sqlite3" = "x0" && test "x$mysql" = "xfalse" && test "x$postgres" = "x0"],
974 [AC_MSG_ERROR([GNUnet requires either SQLite, MySQL/MariaDB or PostgreSQL])])
975
976LDFLAGS="$SAVE_LDFLAGS"
977CPPFLAGS="$SAVE_CPPFLAGS" 907CPPFLAGS="$SAVE_CPPFLAGS"
978 908
979# check for libmicrohttpd 909# check for libmicrohttpd
@@ -1187,6 +1117,10 @@ AC_ARG_ENABLE([experimental],
1187 [enable_experimental=1])], 1117 [enable_experimental=1])],
1188 [enable_experimental=0]) 1118 [enable_experimental=0])
1189AM_CONDITIONAL([HAVE_EXPERIMENTAL], [test "x$enable_experimental" = "x1"]) 1119AM_CONDITIONAL([HAVE_EXPERIMENTAL], [test "x$enable_experimental" = "x1"])
1120AS_IF([test "x$enable_experimental" = "x1"],
1121 AC_DEFINE([GNUNET_EXPERIMENTAL], 1, [Set to 1 is this is an experimental build]))
1122
1123AC_SUBST([enable_experimental])
1190 1124
1191# check if malicious code should be compiled (for testing) 1125# check if malicious code should be compiled (for testing)
1192AC_ARG_ENABLE([malicious], 1126AC_ARG_ENABLE([malicious],
@@ -1278,9 +1212,10 @@ AC_DEFINE_UNQUOTED([VCS_VERSION], [$vcs_version],
1278 1212
1279AC_CONFIG_FILES([ 1213AC_CONFIG_FILES([
1280Makefile 1214Makefile
1281bin/Makefile
1282contrib/Makefile 1215contrib/Makefile
1283contrib/hellos/Makefile 1216data/Makefile
1217data/hellos/Makefile
1218scripts/Makefile
1284contrib/services/Makefile 1219contrib/services/Makefile
1285contrib/services/openrc/Makefile 1220contrib/services/openrc/Makefile
1286contrib/services/systemd/Makefile 1221contrib/services/systemd/Makefile
@@ -1292,108 +1227,138 @@ doc/doxygen/Makefile
1292m4/Makefile 1227m4/Makefile
1293po/Makefile.in 1228po/Makefile.in
1294src/Makefile 1229src/Makefile
1295src/arm/Makefile 1230src/lib/Makefile
1296src/arm/arm.conf 1231src/lib/util/Makefile
1297src/ats/Makefile 1232src/lib/block/Makefile
1298src/ats/ats.conf 1233src/lib/curl/Makefile
1299src/ats-tool/Makefile 1234src/lib/gnsrecord/Makefile
1300src/auction/Makefile 1235src/lib/json/Makefile
1301src/block/Makefile 1236src/lib/pq/Makefile
1302src/cadet/Makefile 1237src/lib/sq/Makefile
1303src/cadet/cadet.conf 1238src/plugin/Makefile
1304src/core/Makefile 1239src/plugin/block/Makefile
1305src/core/core.conf 1240src/plugin/datacache/Makefile
1306src/consensus/Makefile 1241src/plugin/datastore/Makefile
1307src/consensus/consensus.conf 1242src/plugin/dht/Makefile
1308src/conversation/Makefile 1243src/plugin/dns/Makefile
1309src/conversation/conversation.conf 1244src/plugin/fs/Makefile
1310src/curl/Makefile 1245src/plugin/gns/Makefile
1311src/datacache/Makefile 1246src/plugin/gnsrecord/Makefile
1312src/datastore/Makefile 1247src/plugin/namecache/Makefile
1313src/datastore/datastore.conf 1248src/plugin/namestore/Makefile
1314src/dht/Makefile 1249src/plugin/peerstore/Makefile
1315src/dht/dht.conf 1250src/plugin/reclaim/Makefile
1316src/dhtu/Makefile 1251src/plugin/regex/Makefile
1317src/dns/Makefile 1252src/plugin/revocation/Makefile
1318src/dns/dns.conf 1253src/plugin/seti/Makefile
1319src/exit/Makefile 1254src/plugin/setu/Makefile
1320src/fragmentation/Makefile 1255src/plugin/messenger/Makefile
1321src/fs/Makefile 1256src/service/Makefile
1322src/fs/fs.conf 1257src/service/arm/Makefile
1323src/gns/Makefile 1258src/service/arm/arm.conf
1324src/gns/gns.conf 1259src/service/cadet/Makefile
1325src/gns/nss/Makefile 1260src/service/cadet/cadet.conf
1326src/gnsrecord/Makefile 1261src/service/core/Makefile
1327src/hello/Makefile 1262src/service/core/core.conf
1328src/identity/Makefile 1263src/service/datacache/Makefile
1329src/identity/identity.conf 1264src/service/datastore/Makefile
1265src/service/datastore/datastore.conf
1266src/service/dht/Makefile
1267src/service/dht/dht.conf
1268src/service/dns/Makefile
1269src/service/dns/dns.conf
1270src/service/exit/Makefile
1271src/service/fs/Makefile
1272src/service/fs/fs.conf
1273src/service/gns/Makefile
1274src/service/gns/gns.conf
1275src/service/gns/nss/Makefile
1276src/service/hostlist/Makefile
1277src/service/identity/Makefile
1278src/service/identity/identity.conf
1279src/service/messenger/Makefile
1280src/service/messenger/messenger.conf
1281src/service/namecache/Makefile
1282src/service/namecache/namecache.conf
1283src/service/namestore/Makefile
1284src/service/namestore/namestore.conf
1285src/service/nat/Makefile
1286src/service/nat/nat.conf
1287src/service/nat-auto/Makefile
1288src/service/nat-auto/nat-auto.conf
1289src/service/nse/Makefile
1290src/service/nse/nse.conf
1291src/service/peerstore/Makefile
1292src/service/peerstore/peerstore.conf
1293src/service/pt/Makefile
1294src/service/reclaim/Makefile
1295src/service/regex/Makefile
1296src/service/regex/regex.conf
1297src/service/rest/Makefile
1298src/service/revocation/Makefile
1299src/service/revocation/revocation.conf
1300src/service/seti/Makefile
1301src/service/seti/seti.conf
1302src/service/setu/Makefile
1303src/service/setu/setu.conf
1304src/service/statistics/Makefile
1305src/service/statistics/statistics.conf
1306src/service/testing/Makefile
1307src/service/topology/Makefile
1308src/service/transport/Makefile
1309src/service/transport/transport.conf
1310src/service/util/Makefile
1311src/service/util/resolver.conf
1312src/service/vpn/Makefile
1313src/service/vpn/vpn.conf
1314src/service/zonemaster/Makefile
1315src/service/zonemaster/zonemaster.conf
1316src/cli/Makefile
1317src/cli/arm/Makefile
1318src/cli/cadet/Makefile
1319src/cli/core/Makefile
1320src/cli/datastore/Makefile
1321src/cli/dht/Makefile
1322src/cli/fs/Makefile
1323src/cli/gns/Makefile
1324src/cli/identity/Makefile
1325src/cli/messenger/Makefile
1326src/cli/namecache/Makefile
1327src/cli/namestore/Makefile
1328src/cli/peerstore/Makefile
1329src/cli/nat/Makefile
1330src/cli/nat-auto/Makefile
1331src/cli/nse/Makefile
1332src/cli/reclaim/Makefile
1333src/cli/revocation/Makefile
1334src/cli/statistics/Makefile
1335src/cli/util/Makefile
1336src/cli/vpn/Makefile
1337src/contrib/Makefile
1338src/contrib/service/Makefile
1339src/contrib/service/abd/Makefile
1340src/contrib/service/abd/abd.conf
1341src/contrib/service/auction/Makefile
1342src/contrib/service/consensus/Makefile
1343src/contrib/service/consensus/consensus.conf
1344src/contrib/service/conversation/Makefile
1345src/contrib/service/conversation/conversation.conf
1346src/contrib/service/scalarproduct/Makefile
1347src/contrib/service/scalarproduct/scalarproduct.conf
1348src/contrib/service/secretsharing/Makefile
1349src/contrib/service/secretsharing/secretsharing.conf
1350src/contrib/service/set/Makefile
1351src/contrib/service/set/set.conf
1352src/contrib/service/rps/Makefile
1353src/contrib/service/rps/rps.conf
1354src/contrib/service/template/Makefile
1355src/contrib/cli/Makefile
1356src/contrib/cli/template/Makefile
1357src/lib/hello/Makefile
1330src/include/Makefile 1358src/include/Makefile
1331src/integration-tests/Makefile 1359src/include/gnunet_config.h
1332src/json/Makefile
1333src/hostlist/Makefile
1334src/my/Makefile
1335src/mysql/Makefile
1336src/namecache/Makefile
1337src/namecache/namecache.conf
1338src/namestore/Makefile
1339src/namestore/namestore.conf
1340src/nat/Makefile
1341src/nat/nat.conf
1342src/nat-auto/Makefile
1343src/nat-auto/nat-auto.conf
1344src/nse/Makefile
1345src/nse/nse.conf
1346src/nt/Makefile
1347src/peerinfo/Makefile
1348src/peerinfo/peerinfo.conf
1349src/peerinfo-tool/Makefile
1350src/peerstore/Makefile
1351src/peerstore/peerstore.conf
1352src/pq/Makefile
1353src/pt/Makefile
1354src/regex/Makefile
1355src/regex/regex.conf
1356src/revocation/Makefile
1357src/revocation/revocation.conf
1358src/rps/Makefile
1359src/rps/rps.conf
1360src/secretsharing/Makefile
1361src/secretsharing/secretsharing.conf
1362src/scalarproduct/Makefile
1363src/scalarproduct/scalarproduct.conf
1364src/set/Makefile
1365src/set/set.conf
1366src/seti/Makefile
1367src/seti/seti.conf
1368src/setu/Makefile
1369src/setu/setu.conf
1370src/sq/Makefile
1371src/statistics/Makefile
1372src/statistics/statistics.conf
1373src/template/Makefile
1374src/testbed/Makefile
1375src/testbed/testbed.conf
1376src/testbed-logger/Makefile
1377src/testbed-logger/testbed-logger.conf
1378src/testing/Makefile
1379src/topology/Makefile
1380src/transport/Makefile
1381src/transport/transport.conf
1382src/util/Makefile
1383src/util/resolver.conf
1384src/vpn/Makefile
1385src/vpn/vpn.conf
1386src/zonemaster/Makefile
1387src/zonemaster/zonemaster.conf
1388src/rest/Makefile
1389src/abd/Makefile
1390src/abd/abd.conf
1391src/reclaim/Makefile
1392src/messenger/Makefile
1393src/messenger/messenger.conf
1394pkgconfig/Makefile 1360pkgconfig/Makefile
1395pkgconfig/gnunetarm.pc 1361pkgconfig/gnunetarm.pc
1396pkgconfig/gnunetats.pc
1397pkgconfig/gnunetblock.pc 1362pkgconfig/gnunetblock.pc
1398pkgconfig/gnunetcadet.pc 1363pkgconfig/gnunetcadet.pc
1399pkgconfig/gnunetconsensus.pc 1364pkgconfig/gnunetconsensus.pc
@@ -1403,19 +1368,18 @@ pkgconfig/gnunetdatacache.pc
1403pkgconfig/gnunetdatastore.pc 1368pkgconfig/gnunetdatastore.pc
1404pkgconfig/gnunetdht.pc 1369pkgconfig/gnunetdht.pc
1405pkgconfig/gnunetdns.pc 1370pkgconfig/gnunetdns.pc
1406pkgconfig/gnunetenv.pc
1407pkgconfig/gnunetfragmentation.pc
1408pkgconfig/gnunetfs.pc 1371pkgconfig/gnunetfs.pc
1409pkgconfig/gnunetgns.pc 1372pkgconfig/gnunetgns.pc
1410pkgconfig/gnunethello.pc 1373pkgconfig/gnunethello.pc
1411pkgconfig/gnunetidentity.pc 1374pkgconfig/gnunetidentity.pc
1375pkgconfig/gnunetjson.pc
1376pkgconfig/gnunetmessenger.pc
1412pkgconfig/gnunetmicrophone.pc 1377pkgconfig/gnunetmicrophone.pc
1413pkgconfig/gnunetmysql.pc
1414pkgconfig/gnunetnamestore.pc 1378pkgconfig/gnunetnamestore.pc
1415pkgconfig/gnunetnat.pc 1379pkgconfig/gnunetnat.pc
1416pkgconfig/gnunetnse.pc 1380pkgconfig/gnunetnse.pc
1417pkgconfig/gnunetpeerinfo.pc
1418pkgconfig/gnunetpq.pc 1381pkgconfig/gnunetpq.pc
1382pkgconfig/gnunetreclaim.pc
1419pkgconfig/gnunetregex.pc 1383pkgconfig/gnunetregex.pc
1420pkgconfig/gnunetrevocation.pc 1384pkgconfig/gnunetrevocation.pc
1421pkgconfig/gnunetrps.pc 1385pkgconfig/gnunetrps.pc
@@ -1423,7 +1387,6 @@ pkgconfig/gnunetscalarproduct.pc
1423pkgconfig/gnunetset.pc 1387pkgconfig/gnunetset.pc
1424pkgconfig/gnunetspeaker.pc 1388pkgconfig/gnunetspeaker.pc
1425pkgconfig/gnunetstatistics.pc 1389pkgconfig/gnunetstatistics.pc
1426pkgconfig/gnunettestbed.pc
1427pkgconfig/gnunettesting.pc 1390pkgconfig/gnunettesting.pc
1428pkgconfig/gnunettransport.pc 1391pkgconfig/gnunettransport.pc
1429pkgconfig/gnunetutil.pc 1392pkgconfig/gnunetutil.pc
@@ -1458,10 +1421,10 @@ AS_IF([test "x$MANDOC_BINARY" = "xfalse"],
1458 [mandoc_msg="no"], 1421 [mandoc_msg="no"],
1459 [mandoc_msg="yes"]) 1422 [mandoc_msg="yes"])
1460 1423
1461# sphinx 1424# doxy
1462AS_IF([test "x$documentation" = "xyes"], 1425AS_IF([$DOXY_BINARY],
1463 [sphinx_msg="yes"], 1426 [doxy_msg="yes"],
1464 [sphinx_msg="no"]) 1427 [doxy_msg="no"])
1465 1428
1466# conversation 1429# conversation
1467conversation_msg="no" 1430conversation_msg="no"
@@ -1495,6 +1458,8 @@ AS_IF([test "x$extractor" = "x0"],
1495 AC_MSG_WARN([libextractor not found, but various file-sharing operations require it])], 1458 AC_MSG_WARN([libextractor not found, but various file-sharing operations require it])],
1496 [libextractor_msg="yes"]) 1459 [libextractor_msg="yes"])
1497 1460
1461AC_SUBST([extractor])
1462
1498# libzbar 1463# libzbar
1499AS_IF([test "x$zbar" = "x1"], 1464AS_IF([test "x$zbar" = "x1"],
1500 [libzbar_msg="yes"], 1465 [libzbar_msg="yes"],
@@ -1505,12 +1470,9 @@ AS_IF([test "x$png" = "x1"],
1505 [libpng_msg="yes"], 1470 [libpng_msg="yes"],
1506 [libpng_msg="no"]) 1471 [libpng_msg="no"])
1507 1472
1508# curl or gnurl 1473AS_IF([test "x$curl_gnutls" = "x0"],
1509AS_IF([test "x$gnurl" = "x1"], 1474 [curl_tls_backend="OpenSSL"],
1510 [http_client="gnurl"], 1475 [curl_tls_backend="GnuTLS"])
1511 [AS_IF([test "x$curl_gnutls" = "x1"],
1512 [http_client="curl-gnutls"],
1513 [http_client="curl-openssl"])])
1514 1476
1515# ifconfig 1477# ifconfig
1516AS_IF([test "x$IFCONFIG_BINARY" = "xfalse"], 1478AS_IF([test "x$IFCONFIG_BINARY" = "xfalse"],
@@ -1553,11 +1515,6 @@ AS_IF([test "x$sqlite3" = "x1"],
1553 features_msg="sqlite $features_msg"], 1515 features_msg="sqlite $features_msg"],
1554 [sqlite_msg="no"]) 1516 [sqlite_msg="no"])
1555 1517
1556AS_IF([test "x$mysql" = "xtrue"],
1557 [mysql_msg="yes"
1558 features_msg="mysql $features_msg"],
1559 [mysql_msg="no"])
1560
1561AS_IF([test "x$postgres" = "x1"], 1518AS_IF([test "x$postgres" = "x1"],
1562 [postgres_msg="yes" 1519 [postgres_msg="yes"
1563 features_msg="postgres $features_msg"], 1520 features_msg="postgres $features_msg"],
@@ -1586,10 +1543,9 @@ Build Target: ${build_target}
1586Default Interface: ${interface_msg} 1543Default Interface: ${interface_msg}
1587 1544
1588sqlite3: ${sqlite_msg} 1545sqlite3: ${sqlite_msg}
1589MySQL: ${mysql_msg}
1590PostgreSQL: ${postgres_msg} 1546PostgreSQL: ${postgres_msg}
1591 1547
1592HTTP Client: ${http_client} 1548cURL TLS backend: ${curl_tls_backend}
1593Bluetooth: ${bluetooth_msg} 1549Bluetooth: ${bluetooth_msg}
1594iptables: ${iptables_msg} 1550iptables: ${iptables_msg}
1595ifconfig: ${ifconfig_msg} 1551ifconfig: ${ifconfig_msg}
@@ -1608,7 +1564,7 @@ gstreamer: ${gstreamer_msg}
1608 1564
1609Java: ${java_msg} 1565Java: ${java_msg}
1610 1566
1611sphinx: ${sphinx_msg} 1567doxygen: ${doxy_msg}
1612mandoc: ${mandoc_msg} 1568mandoc: ${mandoc_msg}
1613 1569
1614GNUnet configuration 1570GNUnet configuration
@@ -1623,7 +1579,7 @@ Transpiled mdocml Manual: ${mdocml_msg}
1623]) 1579])
1624 1580
1625AS_IF([test "x$MSG_USER_SETUP" != "xfalse"], 1581AS_IF([test "x$MSG_USER_SETUP" != "xfalse"],
1626 [AC_MSG_WARN([Please make sure NOW to create a user and group 'gnunet' and additionall a group 'gnunetdns'. Make sure that '/var/lib/gnunet' is owned (and writable) by user 'gnunet'.]) 1582 [AC_MSG_WARN([Please make sure NOW to create a user and group 'gnunet' and additionally a group 'gnunetdns'. Make sure that '/var/lib/gnunet' is owned (and writable) by user 'gnunet'.])
1627 AS_IF([test "x$HAVE_GNUNET_USER" != "x0"], 1583 AS_IF([test "x$HAVE_GNUNET_USER" != "x0"],
1628 [AC_MSG_NOTICE([To do this on this system, run: 1584 [AC_MSG_NOTICE([To do this on this system, run:
1629# addgroup gnunetdns 1585# addgroup gnunetdns