aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index eae03b01b..017b4836c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -446,6 +446,27 @@ AC_CHECK_LIB(ogg, ogg_stream_flush_fill,
446 ogg=0) 446 ogg=0)
447 447
448 448
449PKG_CHECK_MODULES([GLIB], [glib-2.0])
450# check for pbc library
451pbc=0
452AC_CHECK_HEADER([pbc/pbc.h],pbc=1)
453AC_CHECK_HEADER([gabe.h],abe=1)
454AM_CONDITIONAL(HAVE_PBC, [test "$pbc" = 1])
455AM_CONDITIONAL(HAVE_ABE, [test "$abe" = 1])
456if test "x$pbc" = x1
457then
458 AC_DEFINE([HAVE_PBC],[1],[Have pbc library])
459else
460 AC_DEFINE([HAVE_PBC],[0],[Lacking pbc library])
461fi
462if test "x$abe" = x1
463then
464 AC_DEFINE([HAVE_ABE],[1],[Have ABE library])
465else
466 AC_DEFINE([HAVE_ABE],[0],[Lacking ABE library])
467fi
468
469
449 470
450gst=0 471gst=0
451PKG_CHECK_MODULES( 472PKG_CHECK_MODULES(
@@ -1570,6 +1591,8 @@ src/gnsrecord/Makefile
1570src/hello/Makefile 1591src/hello/Makefile
1571src/identity/Makefile 1592src/identity/Makefile
1572src/identity/identity.conf 1593src/identity/identity.conf
1594src/credential/Makefile
1595src/credential/credential.conf
1573src/include/Makefile 1596src/include/Makefile
1574src/integration-tests/Makefile 1597src/integration-tests/Makefile
1575src/json/Makefile 1598src/json/Makefile
@@ -1635,6 +1658,8 @@ src/vpn/vpn.conf
1635src/zonemaster/Makefile 1658src/zonemaster/Makefile
1636src/zonemaster/zonemaster.conf 1659src/zonemaster/zonemaster.conf
1637src/rest/Makefile 1660src/rest/Makefile
1661src/abe/Makefile
1662src/identity-attribute/Makefile
1638src/identity-provider/Makefile 1663src/identity-provider/Makefile
1639pkgconfig/Makefile 1664pkgconfig/Makefile
1640pkgconfig/gnunetarm.pc 1665pkgconfig/gnunetarm.pc