aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 3 insertions, 36 deletions
diff --git a/configure.ac b/configure.ac
index 770ba499e..8a3574118 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,7 +21,7 @@
21# 21#
22AC_PREREQ([2.69]) 22AC_PREREQ([2.69])
23# Checks for programs. 23# Checks for programs.
24AC_INIT([gnunet],[0.15.4-alpha.0],[bug-gnunet@gnu.org]) 24AC_INIT([gnunet],m4_esyscmd([contrib/get_version.sh]),[bug-gnunet@gnu.org])
25AC_CONFIG_AUX_DIR([build-aux]) 25AC_CONFIG_AUX_DIR([build-aux])
26 26
27# check for legacy option that is no longer supported (#5627) and fail hard 27# check for legacy option that is no longer supported (#5627) and fail hard
@@ -35,7 +35,7 @@ AC_ARG_WITH(nssdir,
35 35
36AC_CANONICAL_TARGET 36AC_CANONICAL_TARGET
37AC_CANONICAL_HOST 37AC_CANONICAL_HOST
38AM_INIT_AUTOMAKE 38AM_INIT_AUTOMAKE([1.9 tar-ustar])
39m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])], [AM_DEFAULT_VERBOSITY=1 AC_SUBST(AM_DEFAULT_VERBOSITY)]) 39m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])], [AM_DEFAULT_VERBOSITY=1 AC_SUBST(AM_DEFAULT_VERBOSITY)])
40AC_CONFIG_HEADERS([gnunet_config.h]) 40AC_CONFIG_HEADERS([gnunet_config.h])
41AH_TOP([#define _GNU_SOURCE 1]) 41AH_TOP([#define _GNU_SOURCE 1])
@@ -1440,8 +1440,7 @@ AC_SUBST(MYSQL_LDFLAGS)
1440AC_SUBST(MYSQL_CPPFLAGS) 1440AC_SUBST(MYSQL_CPPFLAGS)
1441 1441
1442# additional version check for mysql 1442# additional version check for mysql
1443AC_ARG_ENABLE(mysql-version-check, [ --disable-mysql-version-check do not check MySQL version],, enable_mysql_version_check=yes) 1443AS_IF([test "$mysql" = "true"],
1444AS_IF([test "$mysql" = "true" -a "x$enable_mysql_version_check" = "xyes"],
1445 [ 1444 [
1446 AC_MSG_CHECKING(mysql version) 1445 AC_MSG_CHECKING(mysql version)
1447 AC_COMPILE_IFELSE([AC_LANG_PROGRAM( 1446 AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
@@ -1686,20 +1685,6 @@ AC_DEFINE_UNQUOTED([HAVE_GNUTLS_DANE], $gnutls_dane, [We have GnuTLS with DANE s
1686 1685
1687 1686
1688 1687
1689# Test if we are building for superMUC
1690AC_MSG_CHECKING(if GNUnet is being configured to run on the SuperMUC)
1691AC_ARG_ENABLE([supermuc],
1692 [AS_HELP_STRING([--enable-supermuc],
1693 [build GNUnet with support to run on the SuperMUC (default is NO)])],
1694 [AS_IF([test "x$enable_supermuc" = "xno"],
1695 [supermuc=0],
1696 [supermuc=1])],
1697 [supermuc=0
1698 enable_supermuc=no])
1699AC_MSG_RESULT($enable_SUPERMUC)
1700AM_CONDITIONAL([ENABLE_SUPERMUC], [test "x$supermuc" = "x1"])
1701AC_DEFINE_UNQUOTED([ENABLE_SUPERMUC], [$supermuc], [Build with support for SuperMUC])
1702
1703# Check if NSE has to send timestamp information to testbed logger for 1688# Check if NSE has to send timestamp information to testbed logger for
1704# generating histogram of messages received 1689# generating histogram of messages received
1705AC_MSG_CHECKING(if NSE has to send timestamp information to testbed logger) 1690AC_MSG_CHECKING(if NSE has to send timestamp information to testbed logger)
@@ -1739,15 +1724,6 @@ AS_IF([test "x$enable_benchmark" = "xyes"],
1739AM_CONDITIONAL([ENABLE_BENCHMARK], [test "x$enable_benchmark" = "xyes"]) 1724AM_CONDITIONAL([ENABLE_BENCHMARK], [test "x$enable_benchmark" = "xyes"])
1740 1725
1741 1726
1742# should expensive tests be run?
1743AC_MSG_CHECKING(whether to run expensive tests)
1744AC_ARG_ENABLE([expensivetests],
1745 [AS_HELP_STRING([--enable-expensivetests], [enable running expensive testcases])],
1746 [enable_expensive=${enableval}],
1747 [enable_expensive=no])
1748AC_MSG_RESULT($enable_expensive)
1749AM_CONDITIONAL([HAVE_EXPENSIVE_TESTS], [test "x$enable_expensive" = "xyes"])
1750
1751# should ports be open for Java services? 1727# should ports be open for Java services?
1752AC_MSG_CHECKING(whether to enable ports for gnunet-java) 1728AC_MSG_CHECKING(whether to enable ports for gnunet-java)
1753AC_ARG_ENABLE([javaports], 1729AC_ARG_ENABLE([javaports],
@@ -1769,15 +1745,6 @@ AC_ARG_ENABLE([benchmarks],
1769AC_MSG_RESULT($enable_benchmarks) 1745AC_MSG_RESULT($enable_benchmarks)
1770AM_CONDITIONAL([HAVE_BENCHMARKS], [test "x$enable_benchmarks" = "xyes"]) 1746AM_CONDITIONAL([HAVE_BENCHMARKS], [test "x$enable_benchmarks" = "xyes"])
1771 1747
1772# should gnunet-testing be compiled
1773AC_MSG_CHECKING(whether to compile gnunet-testing)
1774AC_ARG_ENABLE([testing],
1775 [AS_HELP_STRING([--disable-testing], [do not build gnunet-testing])],
1776 [enable_testing=${enableval}],
1777 [enable_testing=yes])
1778AC_MSG_RESULT($enable_testing)
1779AM_CONDITIONAL([HAVE_TESTING], [test "x$enable_testing" = "xyes"])
1780
1781# should experimental code be compiled (code that may not yet compile)? 1748# should experimental code be compiled (code that may not yet compile)?
1782AC_MSG_CHECKING(whether to compile experimental code) 1749AC_MSG_CHECKING(whether to compile experimental code)
1783AC_ARG_ENABLE([experimental], 1750AC_ARG_ENABLE([experimental],