aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 101fc77cb..9d1fb9ab3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -565,6 +565,23 @@ AC_CHECK_LIB([kvm],[kvm_open])
565AC_CHECK_LIB([kstat],[kstat_open]) 565AC_CHECK_LIB([kstat],[kstat_open])
566 566
567 567
568# should the build process be restricted to only building
569# the documentation?
570AC_MSG_CHECKING(whether to build documentation ONLY)
571AC_ARG_ENABLE([documentation],
572 [AS_HELP_STRING([--enable-documentation], [only build the documentation])],
573 [doc_only=${enableval}],
574 [doc_only=no])
575AC_MSG_RESULT($doc_only)
576if test "x$doc_only" = "xyes"
577then
578 AM_CONDITIONAL([DOC_ONLY],true)
579 AC_DEFINE([DOC_ONLY],[1],[Building the documentation])
580else
581 AM_CONDITIONAL([DOC_ONLY],false)
582 AC_DEFINE([DOC_ONLY],[0],[Canonical compilation])
583fi
584
568# should the build process be restricted to the code required 585# should the build process be restricted to the code required
569# for GNU Taler wallets? 586# for GNU Taler wallets?
570AC_MSG_CHECKING(whether to compile GNU Taler Wallet library ONLY) 587AC_MSG_CHECKING(whether to compile GNU Taler Wallet library ONLY)