aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 15 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 039652b78..ebbb69465 100644
--- a/configure.ac
+++ b/configure.ac
@@ -557,11 +557,6 @@ AC_ARG_ENABLE([taler-wallet],
557AC_MSG_RESULT($taler_only) 557AC_MSG_RESULT($taler_only)
558AM_CONDITIONAL([TALER_ONLY], [test "x$taler_only" = "xyes"]) 558AM_CONDITIONAL([TALER_ONLY], [test "x$taler_only" = "xyes"])
559 559
560if test "$taler_only" != yes
561then
562
563
564
565# test for libextractor 560# test for libextractor
566extractor=0 561extractor=0
567AC_MSG_CHECKING(for libextractor) 562AC_MSG_CHECKING(for libextractor)
@@ -590,14 +585,22 @@ AC_ARG_WITH(extractor,
590 AC_CHECK_HEADERS(extractor.h, 585 AC_CHECK_HEADERS(extractor.h,
591 AC_CHECK_LIB([extractor], [EXTRACTOR_plugin_add_defaults], 586 AC_CHECK_LIB([extractor], [EXTRACTOR_plugin_add_defaults],
592 extractor=1))]) 587 extractor=1))])
588# restore LIBS
589LIBS=$SAVE_LIBS
590
593if test "$extractor" != 1 591if test "$extractor" != 1
594then 592then
595 AC_MSG_ERROR([GNUnet requires libextractor]) 593 AM_CONDITIONAL(HAVE_LIBEXTRACTOR, false)
594 AC_DEFINE([HAVE_LIBEXTRACTOR],[0],[Lacking libextractor])
595else
596 AM_CONDITIONAL(HAVE_LIBEXTRACTOR, true)
597 AC_DEFINE([HAVE_LIBEXTRACTOR],[1],[Have libextractor])
596fi 598fi
597# restore LIBS
598LIBS=$SAVE_LIBS
599 599
600 600
601if test "$taler_only" != yes
602then
603
601# Check for libltdl header (#2999) 604# Check for libltdl header (#2999)
602ltdl=0 605ltdl=0
603AC_MSG_CHECKING(for libltdl) 606AC_MSG_CHECKING(for libltdl)
@@ -1674,6 +1677,10 @@ then
1674 fi 1677 fi
1675fi 1678fi
1676 1679
1680if test "$extractor" != 1
1681then
1682 AC_MSG_WARN([NOTICE: libextractor not found, but various file-sharing functions require it])
1683fi
1677 1684
1678AC_MSG_NOTICE([NOTICE: Database support is set to MySQL: $mysql, SQLite: $sqlite, Postgres: $postgres]) 1685AC_MSG_NOTICE([NOTICE: Database support is set to MySQL: $mysql, SQLite: $sqlite, Postgres: $postgres])
1679 1686