aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index b958efc7e..2e2b90321 100644
--- a/configure.ac
+++ b/configure.ac
@@ -726,15 +726,15 @@ AC_MSG_RESULT($enable_experimental)
726AM_CONDITIONAL([HAVE_EXPERIMENTAL], [test "x$enable_experimental" = "xyes"]) 726AM_CONDITIONAL([HAVE_EXPERIMENTAL], [test "x$enable_experimental" = "xyes"])
727 727
728# should malicious code be compiled (code used for testing with malicious peers) 728# should malicious code be compiled (code used for testing with malicious peers)
729disable_malicious=yes 729enable_malicious=0
730AC_MSG_CHECKING(whether to compile malicious code) 730AC_MSG_CHECKING(whether to compile malicious code)
731AC_ARG_ENABLE(malicious, 731AC_ARG_ENABLE(malicious,
732 [AS_HELP_STRING([--enable-malicious], 732 [AS_HELP_STRING([--enable-malicious],
733 [enable compiling malicious code (only for developers for testing)])], 733 [enable compiling malicious code (only for developers for testing)])],
734 [enable_malicious=$enableval], 734 [enable_malicious=1],
735 [enable_malicious="no"]) 735 [enable_malicious=0])
736AC_MSG_RESULT($enable_malicious) 736AC_MSG_RESULT($enable_malicious)
737AM_CONDITIONAL([HAVE_MALICIOUS], [test "x$enable_malicious" = "xyes"]) 737AM_CONDITIONAL([HAVE_MALICIOUS], [test "x$enable_malicious" = "x1"])
738AC_DEFINE_UNQUOTED([HAVE_MALICIOUS], $enable_malicious, [Compile malicious code]) 738AC_DEFINE_UNQUOTED([HAVE_MALICIOUS], $enable_malicious, [Compile malicious code])
739 739
740# gcov compilation 740# gcov compilation