aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 14 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index adc777ee0..0fd4d43a1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -485,15 +485,21 @@ AC_DEFINE_UNQUOTED([HAVE_MHD], $lmhd, [We have libmicrohttpd])
485LIBS=$SAVE_LIBS 485LIBS=$SAVE_LIBS
486 486
487# check for python & pexpect (used for some testcases only) 487# check for python & pexpect (used for some testcases only)
488AC_MSG_CHECKING([for python and pexpect]) 488AM_PATH_PYTHON([2.5],, [:])
489/usr/bin/python -c "import pexpect" > /dev/null 2> /dev/null 489AM_CONDITIONAL([HAVE_PYTHON], [test "$PYTHON" != :])
490PYEX=$? 490
491AM_CONDITIONAL(HAVE_PYTHON_PEXPECT, test $PYEX -eq 0) 491if test "$PYTHON" != :
492if test $PYEX -eq 0
493then 492then
494 AC_MSG_RESULT([yes]) 493 AC_MSG_CHECKING([for pexpect])
495else 494 $PYTHON -c "import pexpect" > /dev/null 2> /dev/null
496 AC_MSG_RESULT([not found]) 495 PYEX=$?
496 AM_CONDITIONAL(HAVE_PYTHON_PEXPECT, test $PYEX -eq 0)
497 if test $PYEX -eq 0
498 then
499 AC_MSG_RESULT([yes])
500 else
501 AC_MSG_RESULT([not found])
502 fi
497fi 503fi
498 504
499# libesmtp 505# libesmtp