aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ac8ed60c2..d9e6af74d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,7 +21,7 @@
21# 21#
22AC_PREREQ(2.61) 22AC_PREREQ(2.61)
23# Checks for programs. 23# Checks for programs.
24AC_INIT([gnunet], [0.11.0], [bug-gnunet@gnu.org]) 24AC_INIT([gnunet], [0.11.2], [bug-gnunet@gnu.org])
25AC_CONFIG_AUX_DIR([build-aux]) 25AC_CONFIG_AUX_DIR([build-aux])
26 26
27AC_CANONICAL_TARGET 27AC_CANONICAL_TARGET
@@ -64,12 +64,16 @@ funcstocheck="getnameinfo gethostname gethostbyname gethostbyaddr getaddrinfo ge
64# Srcdir in a form that native compiler understands (i.e. DOS path on W32) 64# Srcdir in a form that native compiler understands (i.e. DOS path on W32)
65native_srcdir=$srcdir 65native_srcdir=$srcdir
66 66
67OLD_LDFLAGS="$LDFLAGS"
68LDFLAGS="$LDFLAGS -Wl,--unresolved-symbols=report-all"
69
67# Check system type 70# Check system type
68case "$host_os" in 71case "$host_os" in
69*darwin* | *rhapsody* | *macosx*) 72*darwin* | *rhapsody* | *macosx*)
70 AC_DEFINE_UNQUOTED(DARWIN,1,[This is an Apple Darwin system]) 73 AC_DEFINE_UNQUOTED(DARWIN,1,[This is an Apple Darwin system])
71 CPPFLAGS="-D_APPLE_C_SOURCE $CPPFLAGS" 74 CPPFLAGS="-D_APPLE_C_SOURCE $CPPFLAGS"
72 CFLAGS="-fno-common $CFLAGS" 75 CFLAGS="-fno-common $CFLAGS"
76 LDFLAGS="$OLD_LDFLAGS"
73 AC_MSG_WARN([WARNING: The VPN application cannot be compiled on your OS]) 77 AC_MSG_WARN([WARNING: The VPN application cannot be compiled on your OS])
74 AC_CHECK_LIB(intl, gettext) 78 AC_CHECK_LIB(intl, gettext)
75 build_target="darwin" 79 build_target="darwin"