aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac122
1 files changed, 0 insertions, 122 deletions
diff --git a/configure.ac b/configure.ac
index 5cfcd0478..5b4e472b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -439,72 +439,6 @@ then
439 AC_MSG_ERROR([GNUnet requires SQLite or MySQL]) 439 AC_MSG_ERROR([GNUnet requires SQLite or MySQL])
440fi 440fi
441 441
442# GNUnet Setup
443dialog=0
444LIBS="-lm $LIBS"
445AC_CHECK_LIB([ncursesw],[wmove])
446AC_MSG_CHECKING([for dialog 1.0-20051207])
447AC_ARG_WITH(dialog,
448 [ --with-dialog=PFX base of dialog installation],
449 [AC_MSG_RESULT([$with_dialog])
450 case $with_dialog in
451 no)
452 ;;
453 yes)
454 AC_CHECK_HEADERS(dialog.h,
455 AC_CHECK_LIB([dialog], [dlg_menu],
456 dialog=1))
457 ;;
458 *)
459 LDFLAGS="-L$with_dialog/lib $LDFLAGS"
460 CPPFLAGS="-I$with_dialog/include $CPPFLAGS"
461 AC_CHECK_HEADERS(dialog.h,
462 AC_CHECK_LIB([dialog], [dlg_menu],
463 EXT_LIB_PATH="-L$with_dialog/lib $EXT_LIB_PATH"
464 dialog=1))
465 ;;
466 esac
467 ],
468 [AC_MSG_RESULT([--with-dialog not specified])
469 AC_CHECK_HEADERS(dialog.h,
470 AC_CHECK_LIB([dialog], [dlg_menu],
471 dialog=1))])
472
473AM_CONDITIONAL(HAVE_DIALOG, test x$dialog = x1)
474AC_DEFINE_UNQUOTED([HAVE_DIALOG], $dialog, [We have dialog])
475
476cdialog=0
477AC_ARG_WITH(cdialog,
478 [ --with-cdialog=PFX base of cdialog installation],
479 [AC_MSG_RESULT([$with_cdialog])
480 case $with_cdialog in
481 no)
482 ;;
483 yes)
484 AC_CHECK_HEADERS(cdialog/dialog.h,
485 AC_CHECK_LIB([cdialog], [dlg_menu],
486 cdialog=1))
487 ;;
488 *)
489 LDFLAGS="-L$with_cdialog/lib $LDFLAGS"
490 CPPFLAGS="-I$with_cdialog/include $CPPFLAGS"
491 AC_CHECK_HEADERS(cdialog/dialog.h,
492 AC_CHECK_LIB([cdialog], [dlg_menu],
493 EXT_LIB_PATH="-L$with_cdialog/lib $EXT_LIB_PATH"
494 cdialog=1))
495 ;;
496 esac
497 ],
498 [AC_MSG_RESULT([--with-cdialog not specified])
499 AC_CHECK_HEADERS(cdialog/dialog.h,
500 AC_CHECK_LIB([cdialog], [dlg_menu],
501 cdialog=1))])
502
503AM_CONDITIONAL(HAVE_CDIALOG, test x$cdialog = x1)
504AC_DEFINE_UNQUOTED([HAVE_CDIALOG], $cdialog, [We have cdialog])
505# restore LIBS
506LIBS=$SAVE_LIBS
507
508# libmicrohttpd 442# libmicrohttpd
509lmhd=0 443lmhd=0
510AC_MSG_CHECKING([for libmicrohttpd]) 444AC_MSG_CHECKING([for libmicrohttpd])
@@ -632,51 +566,6 @@ AC_CHECK_FUNCS([floor gethostname memmove rmdir strncasecmp strrchr strtol atoll
632# restore LIBS 566# restore LIBS
633LIBS=$SAVE_LIBS 567LIBS=$SAVE_LIBS
634 568
635
636
637# check for guile
638guile=0
639AC_MSG_CHECKING(for guile 1.8)
640AC_ARG_WITH(guile,
641 [ --with-guile=PFX base of guile installation],
642 [AC_MSG_RESULT([$with_guile])
643 case $with_guile in
644 no)
645 ;;
646 yes)
647 AC_CHECK_HEADERS(libguile.h,
648 AC_CHECK_LIB([guile], [scm_c_define_gsubr],
649 guile=1, [],
650 -lgmp $LIBLTDL))
651 ;;
652 *)
653 LDFLAGS="-L$with_guile/lib $LDFLAGS"
654 CPPFLAGS="-I$with_guile/include $CPPFLAGS"
655 AC_CHECK_HEADERS(libguile.h,
656 AC_CHECK_LIB([guile], [scm_c_define_gsubr],
657 EXT_LIB_PATH="-L$with_guile/lib $EXT_LIB_PATH"
658 guile=1, [],
659 -lgmp $LIBLTDL))
660 ;;
661 esac
662 ],
663 [AC_MSG_RESULT([--with-guile not specified])
664 AC_CHECK_HEADERS(libguile.h,
665 AC_CHECK_LIB([guile], [scm_c_define_gsubr],
666 guile=1, [], -lgmp $LIBLTDL))])
667
668if test "$guile" = 1
669then
670 AC_CHECK_LIB([guile], [scm_init_guile], [],
671 AC_MSG_ERROR([Guile doesn't provide scm_init_guile(). Please report to bug-gnunet@gnu.org]), -lgmp $LIBLTDL)
672 AC_DEFINE_UNQUOTED([HAVE_GUILE], 1, [We have GUILE])
673else
674 AC_DEFINE_UNQUOTED([HAVE_GUILE], 0, [We do NOT have GUILE])
675fi
676AM_CONDITIONAL(HAVE_GUILE, test x$guile = x1)
677# restore LIBS
678LIBS=$SAVE_LIBS
679
680gn_user_home_dir="~/.gnunet" 569gn_user_home_dir="~/.gnunet"
681AC_ARG_WITH(user-home-dir, 570AC_ARG_WITH(user-home-dir,
682 AC_HELP_STRING( 571 AC_HELP_STRING(
@@ -787,11 +676,6 @@ then
787 AC_MSG_NOTICE([NOTICE: sqlite not found. sqLite support will not be compiled.]) 676 AC_MSG_NOTICE([NOTICE: sqlite not found. sqLite support will not be compiled.])
788fi 677fi
789 678
790if test "x$dialog" != "x1" -a "x$cdialog" != "x1"
791then
792 AC_MSG_NOTICE([NOTICE: curses based gnunet-setup frontends will not be installed.])
793fi
794
795if test "x$lmhd" != "x1" 679if test "x$lmhd" != "x1"
796then 680then
797 AC_MSG_NOTICE([NOTICE: libmicrohttpd not found, http transport will not be installed.]) 681 AC_MSG_NOTICE([NOTICE: libmicrohttpd not found, http transport will not be installed.])
@@ -799,12 +683,6 @@ fi
799 683
800AC_MSG_NOTICE([NOTICE: Database support is set to MySQL: $mysql, SQLite: $sqlite]) 684AC_MSG_NOTICE([NOTICE: Database support is set to MySQL: $mysql, SQLite: $sqlite])
801 685
802# guile
803if test "x$guile" = "x0"
804then
805 AC_MSG_NOTICE([WARNING: Guile not found, gnunet-setup will not be installed.])
806fi
807
808if test "$enable_framework_build" = "yes" 686if test "$enable_framework_build" = "yes"
809then 687then
810 AC_MSG_NOTICE([NOTICE: Mac OS X framework build enabled.]) 688 AC_MSG_NOTICE([NOTICE: Mac OS X framework build enabled.])