aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac58
1 files changed, 16 insertions, 42 deletions
diff --git a/configure.ac b/configure.ac
index 3dd1ce3e6..87a60cb04 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
1# This file is part of GNUnet. 1# This file is part of GNUnet.
2# (C) 2001--2018 GNUnet e.V. 2# (C) 2001--2019 GNUnet e.V.
3# 3#
4# GNUnet is free software: you can redistribute it and/or modify it 4# GNUnet is free software: you can redistribute it and/or modify it
5# under the terms of the GNU Affero General Public License as published 5# under the terms of the GNU Affero General Public License as published
@@ -71,6 +71,7 @@ case "$host_os" in
71 CPPFLAGS="-D_APPLE_C_SOURCE $CPPFLAGS" 71 CPPFLAGS="-D_APPLE_C_SOURCE $CPPFLAGS"
72 CFLAGS="-fno-common $CFLAGS" 72 CFLAGS="-fno-common $CFLAGS"
73 AC_MSG_WARN([WARNING: The VPN application cannot be compiled on your OS]) 73 AC_MSG_WARN([WARNING: The VPN application cannot be compiled on your OS])
74 AC_CHECK_LIB(intl, gettext)
74 build_target="darwin" 75 build_target="darwin"
75 DEFAULT_INTERFACE="\"en0\"" 76 DEFAULT_INTERFACE="\"en0\""
76 LIBPREFIX= 77 LIBPREFIX=
@@ -192,8 +193,8 @@ AC_UNALIGNED_64_ACCESS
192 193
193# some other checks for standard libs 194# some other checks for standard libs
194AC_SEARCH_LIBS([gethostbyname], [nsl ws2_32]) 195AC_SEARCH_LIBS([gethostbyname], [nsl ws2_32])
195AC_SEARCH_LIBS([memrchr], [], [], 196AC_SEARCH_LIBS([memrchr], [],
196 AC_DEFINE(HAVE_MEMRCHR,1,[memrchr supported])) 197 AC_DEFINE(HAVE_MEMRCHR,1,[memrchr supported]), [])
197AC_CHECK_LIB(socket, socket) 198AC_CHECK_LIB(socket, socket)
198AC_CHECK_LIB(m, log) 199AC_CHECK_LIB(m, log)
199AC_CHECK_LIB(c, getloadavg, AC_DEFINE(HAVE_GETLOADAVG,1,[getloadavg supported])) 200AC_CHECK_LIB(c, getloadavg, AC_DEFINE(HAVE_GETLOADAVG,1,[getloadavg supported]))
@@ -206,6 +207,13 @@ AM_CONDITIONAL(HAVE_SSH_BINARY, $VAR_SSH_BINARY)
206AM_CONDITIONAL(HAVE_SSH_KEY, ssh -D 12345 -o "BatchMode yes" -o "UserKnownHostsFile /tmp/gnunet_test_cosks_ssh_garbage" -o "StrictHostKeyChecking no" 127.0.0.1 echo -n) 207AM_CONDITIONAL(HAVE_SSH_KEY, ssh -D 12345 -o "BatchMode yes" -o "UserKnownHostsFile /tmp/gnunet_test_cosks_ssh_garbage" -o "StrictHostKeyChecking no" 127.0.0.1 echo -n)
207rm -f /tmp/gnunet_test_cosks_ssh_garbage 208rm -f /tmp/gnunet_test_cosks_ssh_garbage
208 209
210# autotools' m4 for python has no maximum version!
211# python3.7 for tests
212m4_define_default([_AM_PYTHON_INTERPRETER_LIST],[python3 python3.7 python])
213AM_PATH_PYTHON([3.7],, [:])
214AC_SUBST([PYTHON])
215AM_CONDITIONAL([HAVE_PYTHON], [test "$PYTHON" != :])
216
209# iptables is a soft requirement to run tests 217# iptables is a soft requirement to run tests
210AC_PATH_TARGET_TOOL(VAR_IPTABLES_BINARY, iptables, false) 218AC_PATH_TARGET_TOOL(VAR_IPTABLES_BINARY, iptables, false)
211 219
@@ -369,7 +377,6 @@ AC_ARG_ENABLE(gcc-hardening,
369 LDFLAGS="$LDFLAGS -pie" 377 LDFLAGS="$LDFLAGS -pie"
370fi]) 378fi])
371 379
372
373# Linker hardening options 380# Linker hardening options
374# Currently these options are ELF specific - you can't use this with MacOSX 381# Currently these options are ELF specific - you can't use this with MacOSX
375AC_ARG_ENABLE(linker-hardening, 382AC_ARG_ENABLE(linker-hardening,
@@ -862,7 +869,7 @@ AS_IF([test x$my_with_libidn2 = x1],
862 LIBS="-lidn2 $LIBS" 869 LIBS="-lidn2 $LIBS"
863 AC_DEFINE_UNQUOTED([HAVE_LIBIDN2], 870 AC_DEFINE_UNQUOTED([HAVE_LIBIDN2],
864 [1], 871 [1],
865 [Define to 1 if you have 'libidn2' (-lidn).])], 872 [Define to 1 if you have 'libidn2' (-lidn2).])],
866 [MISSING_DEPS="${MISSING_DEPS}${MISSING_SEP}libidn2" 873 [MISSING_DEPS="${MISSING_DEPS}${MISSING_SEP}libidn2"
867 MISSING_SEP=", "])]) 874 MISSING_SEP=", "])])
868AM_CONDITIONAL(HAVE_LIBIDN2, test x$working_libidn2 = x1) 875AM_CONDITIONAL(HAVE_LIBIDN2, test x$working_libidn2 = x1)
@@ -1208,10 +1215,6 @@ AM_CONDITIONAL(HAVE_JSON, [test x$jansson = x1])
1208# restore LIBS 1215# restore LIBS
1209LIBS=$SAVE_LIBS 1216LIBS=$SAVE_LIBS
1210 1217
1211# check for python & pexpect (used for some testcases only)
1212AM_PATH_PYTHON([2.6],, [:])
1213AM_CONDITIONAL([HAVE_PYTHON], [test "$PYTHON" != :])
1214
1215# check for gettext 1218# check for gettext
1216AM_GNU_GETTEXT([external]) 1219AM_GNU_GETTEXT([external])
1217AM_GNU_GETTEXT_VERSION([0.18.1]) 1220AM_GNU_GETTEXT_VERSION([0.18.1])
@@ -1297,6 +1300,8 @@ AC_SUBST(LIBPREFIX)
1297AC_SUBST(DLLDIR) 1300AC_SUBST(DLLDIR)
1298AC_SUBST(EXT_LIB_PATH) 1301AC_SUBST(EXT_LIB_PATH)
1299 1302
1303DATAROOTDIR=$datarootdir
1304AC_SUBST(DATAROOTDIR)
1300 1305
1301# test for sudo 1306# test for sudo
1302AC_MSG_CHECKING(for sudo) 1307AC_MSG_CHECKING(for sudo)
@@ -1436,23 +1441,6 @@ AC_MSG_RESULT($enable_test_run)
1436AM_CONDITIONAL([ENABLE_TEST_RUN], [test "x$enable_tests_run" = "xyes"]) 1441AM_CONDITIONAL([ENABLE_TEST_RUN], [test "x$enable_tests_run" = "xyes"])
1437 1442
1438 1443
1439# should monkey be used when running (certain) services?
1440AC_MSG_CHECKING(whether to run with monkey)
1441AC_ARG_ENABLE([monkey],
1442 [AS_HELP_STRING([--enable-monkey], [enable running with monkey])],
1443 [enable_monkey=${enableval}],
1444 [enable_monkey=no])
1445AC_MSG_RESULT($enable_monkey)
1446AM_CONDITIONAL([ENABLE_MONKEY], [test "x$enable_monkey" = "xyes"])
1447if test "x$enable_monkey" = "xyes"
1448then
1449 MONKEYPREFIX="pathologist -d $(eval echo ${datarootdir}/gnunet/gnunet.sqlite) -p 30 --"
1450else
1451 MONKEYPREFIX=""
1452fi
1453AC_SUBST(MONKEYPREFIX)
1454
1455
1456AC_MSG_CHECKING([whether to compile in benchmarks (currently for http and crypto)]) 1444AC_MSG_CHECKING([whether to compile in benchmarks (currently for http and crypto)])
1457AC_ARG_ENABLE([benchmark], 1445AC_ARG_ENABLE([benchmark],
1458 [AS_HELP_STRING([--enable-benchmark], [enable benchmarking])], 1446 [AS_HELP_STRING([--enable-benchmark], [enable benchmarking])],
@@ -1542,7 +1530,7 @@ AC_MSG_CHECKING(whether to start peer's services on demand by default)
1542AC_ARG_ENABLE([autostart], 1530AC_ARG_ENABLE([autostart],
1543 [AS_HELP_STRING([--disable-autostart], [do not start peer's services by default])], 1531 [AS_HELP_STRING([--disable-autostart], [do not start peer's services by default])],
1544 [enable_autostart=${enableval} 1532 [enable_autostart=${enableval}
1545 if test "x$enable_autostart" == "xno" 1533 if test "x$enable_autostart" = "xno"
1546 then 1534 then
1547 START_ON_DEMAND="NO" 1535 START_ON_DEMAND="NO"
1548 fi 1536 fi
@@ -1766,8 +1754,6 @@ src/include/Makefile
1766src/integration-tests/Makefile 1754src/integration-tests/Makefile
1767src/json/Makefile 1755src/json/Makefile
1768src/hostlist/Makefile 1756src/hostlist/Makefile
1769src/multicast/Makefile
1770src/multicast/multicast.conf
1771src/my/Makefile 1757src/my/Makefile
1772src/mysql/Makefile 1758src/mysql/Makefile
1773src/namecache/Makefile 1759src/namecache/Makefile
@@ -1787,11 +1773,6 @@ src/peerinfo-tool/Makefile
1787src/peerstore/Makefile 1773src/peerstore/Makefile
1788src/peerstore/peerstore.conf 1774src/peerstore/peerstore.conf
1789src/pq/Makefile 1775src/pq/Makefile
1790src/psycutil/Makefile
1791src/psyc/Makefile
1792src/psyc/psyc.conf
1793src/psycstore/Makefile
1794src/psycstore/psycstore.conf
1795src/pt/Makefile 1776src/pt/Makefile
1796src/regex/Makefile 1777src/regex/Makefile
1797src/regex/regex.conf 1778src/regex/regex.conf
@@ -1805,8 +1786,6 @@ src/scalarproduct/Makefile
1805src/scalarproduct/scalarproduct.conf 1786src/scalarproduct/scalarproduct.conf
1806src/set/Makefile 1787src/set/Makefile
1807src/set/set.conf 1788src/set/set.conf
1808src/social/Makefile
1809src/social/social.conf
1810src/sq/Makefile 1789src/sq/Makefile
1811src/statistics/Makefile 1790src/statistics/Makefile
1812src/statistics/statistics.conf 1791src/statistics/statistics.conf
@@ -1842,7 +1821,6 @@ pkgconfig/gnunetdatacache.pc
1842pkgconfig/gnunetdatastore.pc 1821pkgconfig/gnunetdatastore.pc
1843pkgconfig/gnunetdht.pc 1822pkgconfig/gnunetdht.pc
1844pkgconfig/gnunetdns.pc 1823pkgconfig/gnunetdns.pc
1845pkgconfig/gnunetdv.pc
1846pkgconfig/gnunetenv.pc 1824pkgconfig/gnunetenv.pc
1847pkgconfig/gnunetfragmentation.pc 1825pkgconfig/gnunetfragmentation.pc
1848pkgconfig/gnunetfs.pc 1826pkgconfig/gnunetfs.pc
@@ -1850,21 +1828,17 @@ pkgconfig/gnunetgns.pc
1850pkgconfig/gnunethello.pc 1828pkgconfig/gnunethello.pc
1851pkgconfig/gnunetidentity.pc 1829pkgconfig/gnunetidentity.pc
1852pkgconfig/gnunetmicrophone.pc 1830pkgconfig/gnunetmicrophone.pc
1853pkgconfig/gnunetmulticast.pc
1854pkgconfig/gnunetmysql.pc 1831pkgconfig/gnunetmysql.pc
1855pkgconfig/gnunetnamestore.pc 1832pkgconfig/gnunetnamestore.pc
1856pkgconfig/gnunetnat.pc 1833pkgconfig/gnunetnat.pc
1857pkgconfig/gnunetnse.pc 1834pkgconfig/gnunetnse.pc
1858pkgconfig/gnunetpeerinfo.pc 1835pkgconfig/gnunetpeerinfo.pc
1859pkgconfig/gnunetpq.pc 1836pkgconfig/gnunetpq.pc
1860pkgconfig/gnunetpsyc.pc
1861pkgconfig/gnunetpsycstore.pc
1862pkgconfig/gnunetregex.pc 1837pkgconfig/gnunetregex.pc
1863pkgconfig/gnunetrevocation.pc 1838pkgconfig/gnunetrevocation.pc
1864pkgconfig/gnunetrps.pc 1839pkgconfig/gnunetrps.pc
1865pkgconfig/gnunetscalarproduct.pc 1840pkgconfig/gnunetscalarproduct.pc
1866pkgconfig/gnunetset.pc 1841pkgconfig/gnunetset.pc
1867pkgconfig/gnunetsocial.pc
1868pkgconfig/gnunetspeaker.pc 1842pkgconfig/gnunetspeaker.pc
1869pkgconfig/gnunetstatistics.pc 1843pkgconfig/gnunetstatistics.pc
1870pkgconfig/gnunettestbed.pc 1844pkgconfig/gnunettestbed.pc
@@ -1974,7 +1948,7 @@ require fresh login to come into effect):
1974"USERNAME" with the respective login names). If you have a global IP 1948"USERNAME" with the respective login names). If you have a global IP
1975address, no further configuration is required. 1949address, no further configuration is required.
1976 1950
1977For more detailed setup instructions, see https://gnunet.org/installation 1951For more detailed setup instructions, see https://docs.gnunet.org/
1978 1952
1979Optionally, download and compile gnunet-gtk to get a GUI for 1953Optionally, download and compile gnunet-gtk to get a GUI for
1980file-sharing and configuration. This is particularly recommended 1954file-sharing and configuration. This is particularly recommended