aboutsummaryrefslogtreecommitdiff
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am42
1 files changed, 3 insertions, 39 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index 13fdcdd60..0e8d89c71 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -1,35 +1,10 @@
1# This Makefile.am is in the public domain 1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include -I$(top_builddir)/src/include 2AM_CPPFLAGS = -I$(top_srcdir)/src/include -I$(top_builddir)/src/include
3 3
4SUBDIRS = scripts hellos services 4SUBDIRS = scripts services
5 5
6include Makefile.inc 6include Makefile.inc
7 7
8dist_pkgdata_DATA = \
9 gns/def.tex \
10 gns/gns-bcd.html \
11 gns/gns-bcd.tex \
12 gns/gns-bcd-forbidden.html \
13 gns/gns-bcd-internal-error.html \
14 gns/gns-bcd-invalid-key.html \
15 gns/gns-bcd-not-found.html \
16 gns/gns-bcd-png.tex \
17 gns/gns-bcd-simple.html \
18 gns/gns-bcd-simple.tex \
19 fcfsd/fcfsd-index.html \
20 fcfsd/fcfsd-forbidden.html \
21 fcfsd/fcfsd-notfound.html \
22 branding/logo/gnunet-logo.png \
23 branding/logo/gnunet-logo-dark-text.svg \
24 branding/logo/gnunet-logo-dark-only-text.svg \
25 testing_hostkeys.ecc \
26 netjail/netjail_core.sh \
27 netjail/netjail_exec.sh \
28 netjail/netjail_start.sh \
29 netjail/netjail_stop.sh \
30 netjail/topo.sh \
31 testing-ng/block.sh
32
33INITD_FILES = \ 8INITD_FILES = \
34 services/systemd/gnunet-user.service \ 9 services/systemd/gnunet-user.service \
35 services/systemd/sysusers-gnunet.conf \ 10 services/systemd/sysusers-gnunet.conf \
@@ -209,7 +184,7 @@ EXTRA_DIST = \
209 conf/nss/nssswitch.conf \ 184 conf/nss/nssswitch.conf \
210 testbed_configs/testbed_cluster.conf \ 185 testbed_configs/testbed_cluster.conf \
211 testbed_configs/testbed_supermuc.conf \ 186 testbed_configs/testbed_supermuc.conf \
212 guix.README \ 187 packages/guix/guix.README \
213 web/log.php \ 188 web/log.php \
214 ci/docker/docker-entrypoint.sh \ 189 ci/docker/docker-entrypoint.sh \
215 ci/docker/Dockerfile \ 190 ci/docker/Dockerfile \
@@ -220,10 +195,7 @@ EXTRA_DIST = \
220 docker/Dockerfile \ 195 docker/Dockerfile \
221 docker/README.md \ 196 docker/README.md \
222 benchmark/collect.awk \ 197 benchmark/collect.awk \
223 get_version.sh \ 198 packages/guix/guix.scm \
224 gnunet_infrastructure/handbook_pull.sh \
225 guix.scm \
226 indent_pre-commit \
227 Makefile.inc \ 199 Makefile.inc \
228 vagrant/Vagrantfile \ 200 vagrant/Vagrantfile \
229 vagrant/bootstrap.ubuntu.sh \ 201 vagrant/bootstrap.ubuntu.sh \
@@ -265,12 +237,4 @@ xdgdeentrydir = $(datadir)/applications
265dist_xdgdeentry_DATA = \ 237dist_xdgdeentry_DATA = \
266 xdg-scheme-handler/gnunet-uri.desktop 238 xdg-scheme-handler/gnunet-uri.desktop
267 239
268install-data-hook:
269 chmod o+x '$(DESTDIR)$(pkgdatadir)/netjail_core.sh'
270 chmod o+x '$(DESTDIR)$(pkgdatadir)/netjail_start.sh'
271 chmod o+x '$(DESTDIR)$(pkgdatadir)/netjail_stop.sh'
272 chmod o+x '$(DESTDIR)$(pkgdatadir)/netjail_exec.sh'
273 chmod o+x '$(DESTDIR)$(pkgdatadir)/topo.sh'
274 chmod o+x '$(DESTDIR)$(pkgdatadir)/block.sh'
275
276## EOF 240## EOF