aboutsummaryrefslogtreecommitdiff
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am260
1 files changed, 210 insertions, 50 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index 150e47ff0..464016ee8 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -6,69 +6,226 @@ SUBDIRS = scripts hellos services
6include Makefile.inc 6include Makefile.inc
7 7
8dist_pkgdata_DATA = \ 8dist_pkgdata_DATA = \
9 gns/gns-bcd.html \ 9 gns/gns-form.xslt \
10 gns/gns-bcd.tex \ 10 gns/gns-bcd.html \
11 gns/def.tex \ 11 gns/def.tex \
12 gns/gns-form-fields.xml \ 12 gns/bootstrap.min.css \
13 gns/gns-form.xslt \ 13 gns/gns-form-fields.xml \
14 fcfsd/fcfsd-index.html \ 14 gns/gns-bcd.tex \
15 fcfsd/fcfsd-notfound.html \ 15 fcfsd/fcfsd-index.html \
16 fcfsd/fcfsd-forbidden.html \ 16 fcfsd/fcfsd-forbidden.html \
17 branding/logo/gnunet-logo.pdf \ 17 fcfsd/fcfsd-notfound.html \
18 branding/logo/gnunet-logo.png \ 18 branding/logo/gnunet-logo.png \
19 branding/logo/gnunet-logo-color.png \ 19 branding/logo/lynXified-amirouche-v3.svg \
20 testing_hostkeys.ecc \ 20 branding/logo/gnunet-logo-dark-text.svg \
21 $(BUILDCOMMON_SHLIB_FILES) 21 branding/logo/gnunet-logo-color.png \
22 branding/logo/lynXified-amirouche-anonymous-v3.png \
23 branding/logo/gnunet-logo-dark-only-text.svg \
24 branding/logo/gnunet-logo-big.png \
25 branding/logo/gnunet-logo.pdf \
26 testing_hostkeys.ecc \
27 $(BUILDCOMMON_SHLIB_FILES)
22 28
23INITD_FILES = \ 29INITD_FILES = \
24 services/openrc/gnunet.initd \ 30 services/systemd/gnunet-user.service \
25 services/systemd/gnunet.service 31 services/systemd/sysusers-gnunet.conf \
32 services/systemd/gnunet.service \
33 services/systemd/tmpfiles-gnunet.conf \
34 services/openrc/gnunet.initd
26 35
27PACKAGES_FILES = \ 36PACKAGES_FILES = \
28 packages/guix/guix-env-py2.scm \ 37 packages/guix/guix-env-py2.scm \
29 packages/guix/guix-env-gillmann.scm \ 38 packages/guix/guix-env-gillmann.scm \
30 packages/guix/notest-guix-env.scm \ 39 packages/guix/notest-guix-env.scm \
31 packages/homebrew/gnunet.rb \ 40 packages/alpine/gnunet-gtk/APKBUILD \
32 packages/nix/gnunet-dev.nix \ 41 packages/alpine/gnurl/APKBUILD \
33 packages/nix/default.nix \ 42 packages/alpine/gnunet/gnunet-user-services.initd \
34 packages/alpine/gnunet-gtk/APKBUILD \ 43 packages/alpine/gnunet/gnunet.pre-deinstall \
35 packages/alpine/gnunet/APKBUILD \ 44 packages/alpine/gnunet/gnunet-user.conf \
36 packages/alpine/gnunet/gnunet-system-services.initd \ 45 packages/alpine/gnunet/gnunet.xsession \
37 packages/alpine/gnunet/gnunet-system.conf \ 46 packages/alpine/gnunet/gnunet-system.conf \
38 packages/alpine/gnunet/gnunet-user-services.initd \ 47 packages/alpine/gnunet/APKBUILD \
39 packages/alpine/gnunet/gnunet-user.conf \ 48 packages/alpine/gnunet/gnunet.post-install \
40 packages/alpine/gnunet/gnunet.post-install \ 49 packages/alpine/gnunet/gnunet.pre-install \
41 packages/alpine/gnunet/gnunet.pre-deinstall \ 50 packages/alpine/gnunet/gnunet-system-services.initd \
42 packages/alpine/gnunet/gnunet.pre-install \ 51 packages/alpine/gnunet/gnunet-gns-proxy.initd \
43 packages/alpine/gnunet/gnunet.xsession \ 52 packages/nix/gnunet-dev.nix \
44 packages/alpine/gnurl/APKBUILD 53 packages/nix/default.nix \
54 packages/homebrew/gnunet.rb
45 55
46EXTRA_DIST = \ 56EXTRA_DIST = \
47 conf/colorit/colorit.conf \ 57 sounds/vonlynX-bdbAm-lo.wav \
48 conf/.style.yapf \ 58 sounds/vonlynX-bdbG9-lo.wav \
49 conf/editors/eclipse/gnunet_codingstyle.xml \ 59 sounds/vonlynX-ringtones.txt \
50 conf/gnunet/no_forcestart.conf \ 60 A-Z.ecc \
51 conf/gnunet/no_autostart_above_core.conf \ 61 xdg-scheme-handler/gnunet-uri.desktop \
52 conf/gnunet/gnunet-system.conf \ 62 xdg-scheme-handler/README.md \
53 conf/gnunet/gnunet-user.conf \ 63 apparmor/gnunet-daemon-testbed-blacklist \
54 conf/nss/nssswitch.conf \ 64 apparmor/gnunet-service-identity \
55 conf/wireshark/wireshark.lua \ 65 apparmor/gnunet-cadet \
56 gnunet.m4 \ 66 apparmor/gnunet-service-core \
57 $(PACKAGES_FILES) \ 67 apparmor/gnunet-identity \
58 $(INITD_FILES) \ 68 apparmor/gnunet-service-cadet \
59 Makefile.inc \ 69 apparmor/gnunet-service-dns \
60 $(BUILD_COMMON_FILES) 70 apparmor/gnunet-template \
71 apparmor/gnunet-service-peerstore \
72 apparmor/gnunet-nse \
73 apparmor/gnunet-helper-transport-wlan \
74 apparmor/gnunet-service-set \
75 apparmor/gnunet-uri \
76 apparmor/gnunet-conversation \
77 apparmor/usr.bin.gnunet-helper-nat-server \
78 apparmor/gnunet-transport \
79 apparmor/gnunet-service-nse \
80 apparmor/gnunet-transport-certificate-creation \
81 apparmor/gnunet-daemon-hostlist \
82 apparmor/gnunet-unindex \
83 apparmor/gnunet-nat-server \
84 apparmor/gnunet-setup \
85 apparmor/gnunet-service-testbed \
86 apparmor/gnunet-gtk \
87 apparmor/gnunet-scalarproduct \
88 apparmor/gnunet-statistics \
89 apparmor/gnunet-helper-testbed \
90 apparmor/gnunet-scrypt \
91 apparmor/gnunet-conversation-test \
92 apparmor/gnunet-publish \
93 apparmor/gnunet-helper-audio-playback \
94 apparmor/gnunet-revocation \
95 apparmor/gnunet-helper-vpn \
96 apparmor/gnunet-auto-share \
97 apparmor/gnunet-service-scalarproduct-alice \
98 apparmor/gnunet-service-template \
99 apparmor/gnunet-arm \
100 apparmor/gnunet-search \
101 apparmor/gnunet-ecc \
102 apparmor/gnunet-download-manager.scm \
103 apparmor/gnunet-service-revocation \
104 apparmor/gnunet-gns-proxy-setup-ca \
105 apparmor/gnunet-service-mesh \
106 apparmor/gnunet-helper-transport-wlan-dummy \
107 apparmor/gnunet-service-conversation \
108 apparmor/gnunet-fs \
109 apparmor/gnunet-statistics-gtk \
110 apparmor/gnunet-service-regex \
111 apparmor/gnunet-helper-transport-bluetooth \
112 apparmor/gnunet-service-resolver \
113 apparmor/gnunet-service-fs \
114 apparmor/gnunet-helper-nat-client \
115 apparmor/gnunet-service-arm \
116 apparmor/gnunet-peerinfo-gtk \
117 apparmor/gnunet-vpn \
118 apparmor/gnunet-helper-exit \
119 apparmor/gnunet-set-profiler \
120 apparmor/gnunet-helper-fs-publish \
121 apparmor/gnunet-service-gns \
122 apparmor/gnunet-service-datastore \
123 apparmor/gnunet-service-namestore \
124 apparmor/gnunet-service-dht \
125 apparmor/gnunet-config \
126 apparmor/gnunet-testbed-profiler \
127 apparmor/gnunet-daemon-pt \
128 apparmor/gnunet-peerinfo \
129 apparmor/gnunet-service-ats \
130 apparmor/gnunet-helper-audio-record \
131 apparmor/gnunet-directory \
132 apparmor/gnunet-download \
133 apparmor/gnunet-fs-gtk \
134 apparmor/tunables/gnunet \
135 apparmor/gnunet-ats \
136 apparmor/gnunet-set-ibf-profiler \
137 apparmor/gnunet-dns2gns \
138 apparmor/gnunet-service-peerinfo \
139 apparmor/gnunet-service-namecache \
140 apparmor/gnunet-daemon-exit \
141 apparmor/gnunet-resolver \
142 apparmor/gnunet-bcd \
143 apparmor/gnunet-daemon-regexprofiler \
144 apparmor/gnunet-namestore \
145 apparmor/gnunet-namestore-gtk \
146 apparmor/gnunet-service-testbed-logger \
147 apparmor/gnunet-peerstore \
148 apparmor/gnunet-namestore-fcfsd \
149 apparmor/gnunet-core \
150 apparmor/gnunet-gns-import.sh \
151 apparmor/gnunet-gns-proxy \
152 apparmor/gnunet-identity-gtk \
153 apparmor/gnunet-service-vpn \
154 apparmor/gnunet-daemon-testbed-underlay \
155 apparmor/gnunet-qr \
156 apparmor/gnunet-datastore \
157 apparmor/gnunet-service-statistics \
158 apparmor/gnunet-conversation-gtk \
159 apparmor/gnunet-daemon-latency-logger \
160 apparmor/gnunet-testing \
161 apparmor/gnunet-namecache \
162 apparmor/gnunet-service-transport \
163 apparmor/gnunet-daemon-topology \
164 apparmor/gnunet-helper-dns \
165 apparmor/gnunet-gns \
166 apparmor/gnunet-helper-nat-server \
167 apparmor/abstractions/gnunet-test \
168 apparmor/abstractions/gnunet-db \
169 apparmor/abstractions/gnunet-gtk \
170 apparmor/abstractions/gnunet-common \
171 apparmor/abstractions/gnunet-suid \
172 apparmor/abstractions/gnunet-sgid \
173 apparmor/gnunet-service-scalarproduct-bob \
174 conf/uncrustify.cfg \
175 conf/tox.ini \
176 conf/wireshark/wireshark.lua \
177 conf/.style.yapf \
178 conf/editors/eclipse/gnunet_codingstyle.xml \
179 conf/editors/clang-format \
180 conf/uncrustify_precommit \
181 conf/gnunet/gnunet-user.conf \
182 conf/gnunet/no_autostart_above_core.conf \
183 conf/gnunet/gnunet-system.conf \
184 conf/gnunet/no_forcestart.conf \
185 conf/colorit/colorit.conf \
186 conf/nss/nssswitch.conf \
187 testbed_configs/testbed_cluster.conf \
188 testbed_configs/testbed_supermuc.conf \
189 guix.README \
190 web/log.php \
191 ci/docker/docker-entrypoint.sh \
192 ci/docker/Dockerfile \
193 ci/buildbot/buildbot-update.sh \
194 ci/buildbot/ssh-keys \
195 ci/buildbot/ssh-config \
196 docker/docker-entrypoint.sh \
197 docker/Dockerfile \
198 docker/README.md \
199 docker/gnunet.conf \
200 benchmark/collect.awk \
201 gnunet_infrastructure/handbook_pull.sh \
202 guix.scm \
203 indent_pre-commit \
204 Makefile.inc \
205 gnunet.m4 \
206 vagrant/Vagrantfile \
207 vagrant/bootstrap.ubuntu.sh \
208 privacy-sensitive-symbols.mspec \
209 gnunet-arch-full.svg \
210 patches/texi2html5-indent.diff \
211 patches/transport_ats_years.diff \
212 patches/lrn-indent.diff \
213 test_gnunet_prefix.c \
214 $(PACKAGES_FILES) \
215 $(INITD_FILES) \
216 $(BUILD_COMMON_FILES)
61 217
62check_PROGRAMS = \ 218check_PROGRAMS = \
63 test_gnunet_prefix 219 test_gnunet_prefix
64 220
65if ENABLE_TEST_RUN 221if ENABLE_TEST_RUN
66AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; 222AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
67TESTS = $(check_PROGRAMS) 223TESTS = \
224 $(check_PROGRAMS)
68endif 225endif
69 226
70test_gnunet_prefix_SOURCES = \ 227test_gnunet_prefix_SOURCES = \
71 test_gnunet_prefix.c 228 test_gnunet_prefix.c
72 229
73test_gnunet_prefix_CPPFLAGS = \ 230test_gnunet_prefix_CPPFLAGS = \
74 $(LTDLINCL) $(AM_CPPFLAGS) 231 $(LTDLINCL) $(AM_CPPFLAGS)
@@ -80,4 +237,7 @@ test_gnunet_prefix_LDADD = \
80 $(LIBLTDL) -lunistring $(XLIB) 237 $(LIBLTDL) -lunistring $(XLIB)
81 238
82aclocaldir = $(datadir)/aclocal 239aclocaldir = $(datadir)/aclocal
83aclocal_DATA = gnunet.m4 240aclocal_DATA = \
241 gnunet.m4
242
243## EOF