aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am50
1 files changed, 24 insertions, 26 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 84e7e5fbd..b45362d38 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,39 +1,37 @@
1# This Makefile.am is in the public domain 1# This Makefile.am is in the public domain
2 2
3SUBDIRS = .
3 4
4if DOCUMENTATION 5if HAVE_DOXY_BINARY
5 SUBDIRS = doxygen 6 SUBDIRS += doxygen
7endif
8
9# OpenBSD is a bit iffy wrt sphinx make info
10if OPENBSD
6all-local: 11all-local:
7 cd sphinx && make html 12 cd handbook/texinfo && make || touch gnunet.info
13GNUNET_TEXI =
14else
15GNUNET_TEXI = handbook/texinfo/gnunet.texi
16endif
8 17
9install-data-hook: 18install-data-hook:
10 mkdir -p $(DESTDIR)$(docdir) 19 mkdir -p $(DESTDIR)$(docdir)
11 cp -pr sphinx/_build/html $(DESTDIR)$(docdir) 20 cp -pr handbook/html $(DESTDIR)$(docdir)
12 21 mkdir -p $(DESTDIR)$(infodir)
13_build/man/gnunet.1: Makefile 22 cp -pr handbook/texinfo/gnunet.info $(DESTDIR)$(infodir)
14 cd sphinx && make man
15 23
16if INCLUDE_MANPAGES 24if INCLUDE_MANPAGES
17man_MANS = sphinx/_build/man/gnunet.1 25SUBDIRS += man
18 SUBDIRS += man
19endif
20endif 26endif
21 27
22EXTRA_DIST = \ 28AM_MAKEINFOFLAGS = --no-headers --no-split
23 system_specific/outdated-and-old-installation-instructions.txt \
24 system_specific/FROM_SOURCE \
25 sphinx/about.rst \
26 sphinx/conf.py \
27 sphinx/faq.rst \
28 sphinx/gana.rst \
29 sphinx/guis \
30 sphinx/index.rst \
31 sphinx/installing.rst \
32 sphinx/livingstandards.rst \
33 sphinx/make.bat \
34 sphinx/man_developers \
35 sphinx/man_users \
36 sphinx/preface.rst \
37 sphinx/_static
38 29
30info_TEXINFOS = \
31 $(GNUNET_TEXI)
39 32
33EXTRA_DIST = \
34 handbook/texinfo \
35 system_specific/outdated-and-old-installation-instructions.txt \
36 system_specific/FROM_SOURCE \
37 handbook/html