aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am30
1 files changed, 28 insertions, 2 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index ba3024b12..84e7e5fbd 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -2,12 +2,38 @@
2 2
3 3
4if DOCUMENTATION 4if DOCUMENTATION
5 SUBDIRS = doxygen sphinx 5 SUBDIRS = doxygen
6all-local:
7 cd sphinx && make html
8
9install-data-hook:
10 mkdir -p $(DESTDIR)$(docdir)
11 cp -pr sphinx/_build/html $(DESTDIR)$(docdir)
12
13_build/man/gnunet.1: Makefile
14 cd sphinx && make man
15
6if INCLUDE_MANPAGES 16if INCLUDE_MANPAGES
17man_MANS = sphinx/_build/man/gnunet.1
7 SUBDIRS += man 18 SUBDIRS += man
8endif 19endif
9endif 20endif
10 21
11EXTRA_DIST = \ 22EXTRA_DIST = \
12 system_specific/outdated-and-old-installation-instructions.txt \ 23 system_specific/outdated-and-old-installation-instructions.txt \
13 system_specific/FROM_SOURCE 24 system_specific/FROM_SOURCE \
25 sphinx/about.rst \
26 sphinx/conf.py \
27 sphinx/faq.rst \
28 sphinx/gana.rst \
29 sphinx/guis \
30 sphinx/index.rst \
31 sphinx/installing.rst \
32 sphinx/livingstandards.rst \
33 sphinx/make.bat \
34 sphinx/man_developers \
35 sphinx/man_users \
36 sphinx/preface.rst \
37 sphinx/_static
38
39