aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build20
1 files changed, 19 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index c77833905..43918b9b7 100644
--- a/meson.build
+++ b/meson.build
@@ -19,6 +19,23 @@ cdata.set_quoted('GNUNET_DEFAULT_INTERFACE', 'en0')
19cdata.set_quoted('VCS_VERSION', 'mesonbuild') 19cdata.set_quoted('VCS_VERSION', 'mesonbuild')
20add_project_arguments('-DHAVE_CONFIG_H', language : 'c') 20add_project_arguments('-DHAVE_CONFIG_H', language : 'c')
21 21
22# Compiler settings
23 add_project_arguments('-fno-strict-aliasing', language : 'c')
24if compiler.has_argument('-Wno-address-of-packed-member')
25 add_project_arguments('-Wno-address-of-packed-member', language : 'c')
26endif
27if compiler.has_argument('-Wno-tautological-constant-out-of-range-compare')
28 add_project_arguments('-Wno-tautological-constant-out-of-range-compare', language : 'c')
29endif
30
31
32if host_machine.system() == 'darwin'
33 cdata.set_quoted('GNUNET_DEFAULT_INTERFACE', 'en0')
34 add_project_arguments('-D_APPLE_C_SOURCE', language : 'c')
35 add_project_arguments('-D__APPLE_USE_RFC_3542', language : 'c')
36 add_project_arguments('-fno-common', language : 'c')
37endif
38
22 39
23# FIXME: Not all dependencies here yet 40# FIXME: Not all dependencies here yet
24ltdl_dep = compiler.find_library('ltdl', required : true) 41ltdl_dep = compiler.find_library('ltdl', required : true)
@@ -28,8 +45,9 @@ curl_dep = dependency('libcurl')
28zlib_dep = dependency('zlib') 45zlib_dep = dependency('zlib')
29mhd_dep = dependency('libmicrohttpd') 46mhd_dep = dependency('libmicrohttpd')
30json_dep = compiler.find_library('jansson', required : true) 47json_dep = compiler.find_library('jansson', required : true)
48gcrypt_dep = dependency('libgcrypt')
31gnunetdeps = [mhd_dep, 49gnunetdeps = [mhd_dep,
32 dependency('libgcrypt'), 50 gcrypt_dep,
33 dependency('libsodium'), 51 dependency('libsodium'),
34 curl_dep, 52 curl_dep,
35 json_dep, 53 json_dep,