aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 6 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 62888727d..513a8da99 100644
--- a/meson.build
+++ b/meson.build
@@ -176,11 +176,13 @@ if ssh_bin.found()
176endif 176endif
177 177
178# Optional dependencies 178# Optional dependencies
179mq_dep = dependency('libmysqlclient', required : false) 179
180if not mq_dep.found() 180# FIXME: I think we wanted to retire mysql support
181 mq_dep = cc.find_library('mysqlclient', required : false) 181my_dep = dependency('libmysqlclient', required : false)
182if not my_dep.found()
183 my_dep = cc.find_library('mysqlclient', required : false)
182endif 184endif
183if mq_dep.found() 185if my_dep.found()
184 add_project_arguments('-DHAVE_MYSQL', language : 'c') 186 add_project_arguments('-DHAVE_MYSQL', language : 'c')
185endif 187endif
186pq_dep = dependency('libpq', required : false) 188pq_dep = dependency('libpq', required : false)