aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build28
1 files changed, 13 insertions, 15 deletions
diff --git a/meson.build b/meson.build
index ed0ba4159..10937517f 100644
--- a/meson.build
+++ b/meson.build
@@ -321,27 +321,25 @@ endif
321if ogg_dep.found() 321if ogg_dep.found()
322 add_project_arguments('-DHAVE_OGG', language : 'c') 322 add_project_arguments('-DHAVE_OGG', language : 'c')
323endif 323endif
324gst_dep = dependency('gstreamer-1.0', required : false)
325if not gst_dep.found()
326 gst_dep = cc.find_library('gstreamer-1.0', required : false)
327endif
328gst_app_dep = dependency('gstreamer-app-1.0', required : false)
329if not gst_app_dep.found()
330 gst_app_dep = cc.find_library('gstreamer-app-1.0', required : false)
331endif
332gst_audio_dep = dependency('gstreamer-audio-1.0', required : false)
333if not gst_audio_dep.found()
334 gst_audio_dep = cc.find_library('gstreamer-audio-1.0', required : false)
335endif
324 336
325conversation_backend = 'none' 337conversation_backend = 'none'
326if pulse_dep.found() and opus_dep.found() and ogg_dep.found() 338if pulse_dep.found() and opus_dep.found() and ogg_dep.found()
327 conversation_backend = 'pulse' 339 conversation_backend = 'pulse'
328else 340elif gst_dep.found() and gst_app_dep.found() and gst_audio_dep.found()
329 gst_dep = dependency('gstreamer-1.0', required : false)
330 if not gst_dep.found()
331 gst_dep = cc.find_library('gstreamer-1.0', required : false)
332 endif
333 gst_app_dep = dependency('gstreamer-app-1.0', required : false)
334 if not gst_app_dep.found()
335 gst_app_dep = cc.find_library('gstreamer-app-1.0', required : false)
336 endif
337 gst_audio_dep = dependency('gstreamer-audio-1.0', required : false)
338 if not gst_audio_dep.found()
339 gst_audio_dep = cc.find_library('gstreamer-audio-1.0', required : false)
340 endif
341 if gst_dep.found() and gst_app_dep.found() and gst_audio_dep.found()
342 add_project_arguments('-DHAVE_GST', language : 'c') 341 add_project_arguments('-DHAVE_GST', language : 'c')
343 conversation_backend = 'gst' 342 conversation_backend = 'gst'
344 endif
345endif 343endif
346## END conversation 344## END conversation
347 345