diff options
Diffstat (limited to 'meson.build')
-rw-r--r-- | meson.build | 28 |
1 files changed, 13 insertions, 15 deletions
diff --git a/meson.build b/meson.build index ed0ba4159..10937517f 100644 --- a/meson.build +++ b/meson.build | |||
@@ -321,27 +321,25 @@ endif | |||
321 | if ogg_dep.found() | 321 | if ogg_dep.found() |
322 | add_project_arguments('-DHAVE_OGG', language : 'c') | 322 | add_project_arguments('-DHAVE_OGG', language : 'c') |
323 | endif | 323 | endif |
324 | gst_dep = dependency('gstreamer-1.0', required : false) | ||
325 | if not gst_dep.found() | ||
326 | gst_dep = cc.find_library('gstreamer-1.0', required : false) | ||
327 | endif | ||
328 | gst_app_dep = dependency('gstreamer-app-1.0', required : false) | ||
329 | if not gst_app_dep.found() | ||
330 | gst_app_dep = cc.find_library('gstreamer-app-1.0', required : false) | ||
331 | endif | ||
332 | gst_audio_dep = dependency('gstreamer-audio-1.0', required : false) | ||
333 | if not gst_audio_dep.found() | ||
334 | gst_audio_dep = cc.find_library('gstreamer-audio-1.0', required : false) | ||
335 | endif | ||
324 | 336 | ||
325 | conversation_backend = 'none' | 337 | conversation_backend = 'none' |
326 | if pulse_dep.found() and opus_dep.found() and ogg_dep.found() | 338 | if pulse_dep.found() and opus_dep.found() and ogg_dep.found() |
327 | conversation_backend = 'pulse' | 339 | conversation_backend = 'pulse' |
328 | else | 340 | elif gst_dep.found() and gst_app_dep.found() and gst_audio_dep.found() |
329 | gst_dep = dependency('gstreamer-1.0', required : false) | ||
330 | if not gst_dep.found() | ||
331 | gst_dep = cc.find_library('gstreamer-1.0', required : false) | ||
332 | endif | ||
333 | gst_app_dep = dependency('gstreamer-app-1.0', required : false) | ||
334 | if not gst_app_dep.found() | ||
335 | gst_app_dep = cc.find_library('gstreamer-app-1.0', required : false) | ||
336 | endif | ||
337 | gst_audio_dep = dependency('gstreamer-audio-1.0', required : false) | ||
338 | if not gst_audio_dep.found() | ||
339 | gst_audio_dep = cc.find_library('gstreamer-audio-1.0', required : false) | ||
340 | endif | ||
341 | if gst_dep.found() and gst_app_dep.found() and gst_audio_dep.found() | ||
342 | add_project_arguments('-DHAVE_GST', language : 'c') | 341 | add_project_arguments('-DHAVE_GST', language : 'c') |
343 | conversation_backend = 'gst' | 342 | conversation_backend = 'gst' |
344 | endif | ||
345 | endif | 343 | endif |
346 | ## END conversation | 344 | ## END conversation |
347 | 345 | ||