aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build21
1 files changed, 13 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 50556948f..523645c88 100644
--- a/meson.build
+++ b/meson.build
@@ -263,14 +263,19 @@ if ogg_dep.found()
263 add_project_arguments('-DHAVE_OGG', language : 'c') 263 add_project_arguments('-DHAVE_OGG', language : 'c')
264endif 264endif
265 265
266if pulse_dep.found() or ogg_dep.found() or opus_dep.found() 266gst_dep = dependency('libgst', required : false)
267 gst_dep = dependency('libgst', required : false) 267if not gst_dep.found()
268 if not gst_dep.found() 268 gst_dep = cc.find_library('gstreamer', required : false)
269 gst_dep = cc.find_library('gstreamer', required : false) 269endif
270 endif 270if gst_dep.found()
271 if gst_dep.found() 271 add_project_arguments('-DHAVE_GST', language : 'c')
272 add_project_arguments('-DHAVE_GST', language : 'c') 272endif
273 endif 273
274conversation_backend = 'none'
275if pulse_dep.found() and opus_dep.found() and ogg_dep.found()
276 conversation_backend = 'pulse'
277elif gst_dep.found()
278 conversation_backend = 'gst'
274endif 279endif
275## END conversation 280## END conversation
276 281