aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am96
1 files changed, 5 insertions, 91 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d7c0b51f0..524b989c1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,97 +1,11 @@
1# This Makefile.am is in the public domain 1# This Makefile.am is in the public domain
2 2
3TESTING = testing
4TESTBED = testbed-logger testbed
5
6if HAVE_EXPERIMENTAL
7 EXP_DIR = \
8 rps \
9 abd \
10 auction
11endif
12
13JSON_DIR = json
14CURL_DIR = curl
15
16if BUILD_PULSE_HELPERS
17CONVERSATION_DIR = conversation
18else
19if BUILD_GST_HELPERS
20CONVERSATION_DIR = conversation
21endif
22endif
23
24if HAVE_SQLITE
25 SQLITE_DIR = sq
26endif
27
28if HAVE_MYSQL
29 MYSQL_DIR = mysql my
30endif
31
32if HAVE_POSTGRESQL
33 POSTGRES_DIR = pq
34endif
35
36REST_DIR = rest
37 3
38 4
39SUBDIRS = \ 5SUBDIRS = \
40 include $(INTLEMU_SUBDIRS) \ 6 include $(INTLEMU_SUBDIRS) \
41 util \ 7 lib \
42 nt \ 8 plugin \
43 hello \ 9 service \
44 block \ 10 cli \
45 statistics \ 11 contrib
46 arm \
47 $(TESTING) \
48 $(JSON_DIR) \
49 $(CURL_DIR) \
50 $(REST_DIR) \
51 peerinfo \
52 $(SQLITE_DIR) \
53 $(MYSQL_DIR) \
54 $(POSTGRES_DIR) \
55 datacache \
56 datastore \
57 template \
58 peerstore \
59 ats \
60 nat \
61 nat-auto \
62 fragmentation \
63 transport \
64 ats-tool \
65 core \
66 $(TESTBED) \
67 nse \
68 dhtu \
69 dht \
70 hostlist \
71 topology \
72 regex \
73 dns \
74 identity \
75 gnsrecord \
76 namecache \
77 namestore \
78 peerinfo-tool \
79 cadet \
80 set \
81 seti \
82 setu \
83 consensus \
84 scalarproduct \
85 revocation \
86 vpn \
87 gns \
88 zonemaster \
89 $(CONVERSATION_DIR) \
90 fs \
91 exit \
92 pt \
93 secretsharing \
94 reclaim \
95 messenger \
96 $(EXP_DIR) \
97 integration-tests