aboutsummaryrefslogtreecommitdiff
path: root/src/ats-tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/ats-tests/Makefile.am')
-rw-r--r--src/ats-tests/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/ats-tests/Makefile.am b/src/ats-tests/Makefile.am
index 21366484b..4811bc8d7 100644
--- a/src/ats-tests/Makefile.am
+++ b/src/ats-tests/Makefile.am
@@ -13,6 +13,7 @@ if USE_COVERAGE
13 AM_CFLAGS = -fprofile-arcs -ftest-coverage 13 AM_CFLAGS = -fprofile-arcs -ftest-coverage
14endif 14endif
15 15
16if HAVE_EXPERIMENTAL
16if HAVE_LIBGLPK 17if HAVE_LIBGLPK
17 PERF_MLP = \ 18 PERF_MLP = \
18 perf_ats_mlp_transport_none \ 19 perf_ats_mlp_transport_none \
@@ -22,6 +23,7 @@ if HAVE_LIBGLPK
22 perf_ats_mlp_core_bandwidth \ 23 perf_ats_mlp_core_bandwidth \
23 perf_ats_mlp_core_latency 24 perf_ats_mlp_core_latency
24endif 25endif
26endif
25 27
26if HAVE_TESTING 28if HAVE_TESTING
27TESTING_TESTS = \ 29TESTING_TESTS = \
@@ -44,7 +46,7 @@ check_PROGRAMS = \
44 $(TESTING_TESTS) 46 $(TESTING_TESTS)
45 47
46if ENABLE_TEST_RUN 48if ENABLE_TEST_RUN
47AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH; 49AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
48TESTS = $(check_PROGRAMS) 50TESTS = $(check_PROGRAMS)
49endif 51endif
50 52
@@ -140,7 +142,7 @@ perf_ats_proportional_transport_bandwidth_LDADD = \
140perf_ats_proportional_transport_bandwidth_DEPENDENCIES = \ 142perf_ats_proportional_transport_bandwidth_DEPENDENCIES = \
141 libgnunetatstesting.la \ 143 libgnunetatstesting.la \
142 $(top_builddir)/src/util/libgnunetutil.la 144 $(top_builddir)/src/util/libgnunetutil.la
143 145
144perf_ats_proportional_core_latency_SOURCES = \ 146perf_ats_proportional_core_latency_SOURCES = \
145 perf_ats.c 147 perf_ats.c
146perf_ats_proportional_core_latency_LDADD = \ 148perf_ats_proportional_core_latency_LDADD = \