aboutsummaryrefslogtreecommitdiff
path: root/src/cadet/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/cadet/Makefile.am')
-rw-r--r--src/cadet/Makefile.am225
1 files changed, 0 insertions, 225 deletions
diff --git a/src/cadet/Makefile.am b/src/cadet/Makefile.am
deleted file mode 100644
index d942c6495..000000000
--- a/src/cadet/Makefile.am
+++ /dev/null
@@ -1,225 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage -O0
6 XLIB = -lgcov
7endif
8
9pkgcfgdir= $(pkgdatadir)/config.d/
10
11libexecdir= $(pkglibdir)/libexec/
12
13pkgcfg_DATA = \
14 cadet.conf
15
16plugindir = $(libdir)/gnunet
17
18AM_CLFAGS = -g
19
20libexec_PROGRAMS = \
21 gnunet-service-cadet \
22 $(EXP_LIBEXEC)
23
24bin_PROGRAMS = \
25 gnunet-cadet
26
27lib_LTLIBRARIES = \
28 libgnunetcadet.la \
29 $(EXP_LIB)
30
31libgnunetcadet_la_SOURCES = \
32 cadet_api.c \
33 cadet_api_drop_message.c \
34 cadet_api_get_channel.c \
35 cadet_api_get_path.c \
36 cadet_api_list_peers.c \
37 cadet_api_list_tunnels.c \
38 cadet_api_helper.c
39libgnunetcadet_la_LIBADD = \
40 $(top_builddir)/src/util/libgnunetutil.la \
41 $(XLIB) \
42 $(LTLIBINTL)
43libgnunetcadet_la_LDFLAGS = \
44 $(GN_LIB_LDFLAGS) \
45 -version-info 7:0:0
46
47gnunet_cadet_SOURCES = \
48 gnunet-cadet.c
49gnunet_cadet_LDADD = \
50 libgnunetcadet.la \
51 $(top_builddir)/src/util/libgnunetutil.la
52gnunet_cadet_LDFLAGS = \
53 $(GN_LIBINTL)
54
55gnunet_service_cadet_SOURCES = \
56 gnunet-service-cadet.c gnunet-service-cadet.h \
57 gnunet-service-cadet_channel.c gnunet-service-cadet_channel.h \
58 gnunet-service-cadet_connection.c gnunet-service-cadet_connection.h \
59 gnunet-service-cadet_core.c gnunet-service-cadet_core.h \
60 gnunet-service-cadet_dht.c gnunet-service-cadet_dht.h \
61 gnunet-service-cadet_hello.c gnunet-service-cadet_hello.h \
62 gnunet-service-cadet_tunnels.c gnunet-service-cadet_tunnels.h \
63 gnunet-service-cadet_paths.c gnunet-service-cadet_paths.h \
64 gnunet-service-cadet_peer.c gnunet-service-cadet_peer.h
65gnunet_service_cadet_LDADD = \
66 $(top_builddir)/src/util/libgnunetutil.la \
67 $(top_builddir)/src/ats/libgnunetats.la \
68 $(top_builddir)/src/core/libgnunetcore.la \
69 $(top_builddir)/src/dht/libgnunetdht.la \
70 $(top_builddir)/src/statistics/libgnunetstatistics.la \
71 $(top_builddir)/src/transport/libgnunettransport.la \
72 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
73 $(top_builddir)/src/hello/libgnunethello.la \
74 $(top_builddir)/src/block/libgnunetblock.la
75if LINUX
76 gnunet_service_cadet_LDFLAGS = -lrt \
77 $(GN_LIBINTL)
78endif
79
80
81 noinst_LTLIBRARIES = libgnunetcadettest.la $(noinst_LIB_EXP)
82# noinst_PROGRAMS = gnunet-cadet-profiler
83
84check_PROGRAMS = \
85 test_cadet_local_mq \
86 test_cadet_2_forward \
87 test_cadet_2_forward \
88 test_cadet_2_signal \
89 test_cadet_2_keepalive \
90 test_cadet_2_speed \
91 test_cadet_2_speed_ack \
92 test_cadet_2_speed_backwards \
93 test_cadet_2_speed_reliable \
94 test_cadet_2_speed_reliable_backwards \
95 test_cadet_2_reopen \
96 test_cadet_2_destroy \
97 test_cadet_5_forward \
98 test_cadet_5_signal \
99 test_cadet_5_keepalive \
100 test_cadet_5_speed \
101 test_cadet_5_speed_ack \
102 test_cadet_5_speed_reliable \
103 test_cadet_5_speed_reliable_backwards \
104 test_cadet_5_speed_backwards \
105 test_cadet_5_reopen
106
107
108#gnunet_cadet_profiler_SOURCES = \
109# gnunet-cadet-profiler.c
110#gnunet_cadet_profiler_LDADD = $(ld_cadet_test_lib)
111
112
113test_cadet_local_mq_SOURCES = \
114 test_cadet_local_mq.c
115test_cadet_local_mq_LDADD = \
116 libgnunetcadet.la \
117 $(top_builddir)/src/testing/libgnunettesting.la \
118 $(top_builddir)/src/util/libgnunetutil.la
119
120
121libgnunetcadettest_la_SOURCES = \
122 cadet_test_lib.c cadet_test_lib.h
123libgnunetcadettest_la_LIBADD = \
124 $(top_builddir)/src/util/libgnunetutil.la \
125 $(top_builddir)/src/testbed/libgnunettestbed.la \
126 libgnunetcadet.la
127
128ld_cadet_test_lib = \
129 $(top_builddir)/src/util/libgnunetutil.la \
130 $(top_builddir)/src/testing/libgnunettesting.la \
131 libgnunetcadet.la \
132 libgnunetcadettest.la \
133 $(top_builddir)/src/testbed/libgnunettestbed.la \
134 $(top_builddir)/src/statistics/libgnunetstatistics.la
135dep_cadet_test_lib = \
136 libgnunetcadet.la \
137 libgnunetcadettest.la \
138 $(top_builddir)/src/statistics/libgnunetstatistics.la
139
140test_cadet_2_forward_SOURCES = \
141 test_cadet.c
142test_cadet_2_forward_LDADD = $(ld_cadet_test_lib)
143
144test_cadet_2_signal_SOURCES = \
145 test_cadet.c
146test_cadet_2_signal_LDADD = $(ld_cadet_test_lib)
147
148test_cadet_2_keepalive_SOURCES = \
149 test_cadet.c
150test_cadet_2_keepalive_LDADD = $(ld_cadet_test_lib)
151
152test_cadet_2_speed_SOURCES = \
153 test_cadet.c
154test_cadet_2_speed_LDADD = $(ld_cadet_test_lib)
155
156test_cadet_2_speed_ack_SOURCES = \
157 test_cadet.c
158test_cadet_2_speed_ack_LDADD = $(ld_cadet_test_lib)
159
160test_cadet_2_speed_backwards_SOURCES = \
161 test_cadet.c
162test_cadet_2_speed_backwards_LDADD = $(ld_cadet_test_lib)
163
164test_cadet_2_speed_reliable_SOURCES = \
165 test_cadet.c
166test_cadet_2_speed_reliable_LDADD = $(ld_cadet_test_lib)
167
168test_cadet_2_speed_reliable_backwards_SOURCES = \
169 test_cadet.c
170test_cadet_2_speed_reliable_backwards_LDADD = $(ld_cadet_test_lib)
171
172test_cadet_5_forward_SOURCES = \
173 test_cadet.c
174test_cadet_5_forward_LDADD = $(ld_cadet_test_lib)
175
176test_cadet_5_signal_SOURCES = \
177 test_cadet.c
178test_cadet_5_signal_LDADD = $(ld_cadet_test_lib)
179
180test_cadet_5_keepalive_SOURCES = \
181 test_cadet.c
182test_cadet_5_keepalive_LDADD = $(ld_cadet_test_lib)
183
184test_cadet_5_speed_SOURCES = \
185 test_cadet.c
186test_cadet_5_speed_LDADD = $(ld_cadet_test_lib)
187
188test_cadet_5_speed_ack_SOURCES = \
189 test_cadet.c
190test_cadet_5_speed_ack_LDADD = $(ld_cadet_test_lib)
191
192test_cadet_5_speed_backwards_SOURCES = \
193 test_cadet.c
194test_cadet_5_speed_backwards_LDADD = $(ld_cadet_test_lib)
195
196test_cadet_5_speed_reliable_SOURCES = \
197 test_cadet.c
198test_cadet_5_speed_reliable_LDADD = $(ld_cadet_test_lib)
199
200test_cadet_5_speed_reliable_backwards_SOURCES = \
201 test_cadet.c
202test_cadet_5_speed_reliable_backwards_LDADD = $(ld_cadet_test_lib)
203
204test_cadet_2_reopen_SOURCES = \
205 test_cadet.c
206test_cadet_2_reopen_LDADD = $(ld_cadet_test_lib)
207
208test_cadet_5_reopen_SOURCES = \
209 test_cadet.c
210test_cadet_5_reopen_LDADD = $(ld_cadet_test_lib)
211
212test_cadet_2_destroy_SOURCES = \
213 test_cadet.c
214test_cadet_2_destroy_LDADD = $(ld_cadet_test_lib)
215
216if ENABLE_TEST_RUN
217AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
218TESTS = \
219 $(check_PROGRAMS)
220endif
221
222EXTRA_DIST = \
223 cadet.h cadet_protocol.h \
224 test_cadet.conf \
225 test_cadet_drop.conf