aboutsummaryrefslogtreecommitdiff
path: root/src/cadet/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/cadet/meson.build')
-rw-r--r--src/cadet/meson.build16
1 files changed, 11 insertions, 5 deletions
diff --git a/src/cadet/meson.build b/src/cadet/meson.build
index 9534fc35b..ca7a5a91b 100644
--- a/src/cadet/meson.build
+++ b/src/cadet/meson.build
@@ -18,11 +18,13 @@ gnunetservicecadet_src = ['gnunet-service-cadet.c',
18 'gnunet-service-cadet_peer.c'] 18 'gnunet-service-cadet_peer.c']
19 19
20 20
21if gnunet_monolith == false 21if get_option('monolith') == false
22 libgnunetcadet = library('gnunetcadet', 22 libgnunetcadet = library('gnunetcadet',
23 libgnunetcadet_src, 23 libgnunetcadet_src,
24 dependencies: libgnunetutil_dep, 24 dependencies: libgnunetutil_dep,
25 include_directories: [incdir, configuration_inc]) 25 include_directories: [incdir, configuration_inc],
26 install: true,
27 install_dir: get_option('libdir'))
26 libgnunetcadet_dep = declare_dependency(link_with : libgnunetcadet) 28 libgnunetcadet_dep = declare_dependency(link_with : libgnunetcadet)
27 executable ('gnunet-cadet', 29 executable ('gnunet-cadet',
28 gnunetservicecadet_src, 30 gnunetservicecadet_src,
@@ -35,7 +37,9 @@ if gnunet_monolith == false
35 libgnunetats_dep, 37 libgnunetats_dep,
36 libgnunettransport_dep, 38 libgnunettransport_dep,
37 libgnunethello_dep], 39 libgnunethello_dep],
38 include_directories: [incdir, configuration_inc]) 40 include_directories: [incdir, configuration_inc],
41 install: true,
42 install_dir: get_option('bindir'))
39 executable ('gnunet-service-cadet', 43 executable ('gnunet-service-cadet',
40 gnunetservicecadet_src, 44 gnunetservicecadet_src,
41 dependencies: [libgnunetcadet_dep, 45 dependencies: [libgnunetcadet_dep,
@@ -48,9 +52,11 @@ if gnunet_monolith == false
48 libgnunetpeerinfo_dep, 52 libgnunetpeerinfo_dep,
49 libgnunethello_dep, 53 libgnunethello_dep,
50 libgnunetblock_dep], 54 libgnunetblock_dep],
51 include_directories: [incdir, configuration_inc]) 55 include_directories: [incdir, configuration_inc],
56 install: true,
57 install_dir: get_option('libdir') / 'gnunet' / 'libexec')
52else 58else
53 foreach p : libgnunetcadet_src + gnunetservicecadet_src + gnunetcadet_src 59 foreach p : libgnunetcadet_src + gnunetservicecadet_src
54 gnunet_src += 'cadet/' + p 60 gnunet_src += 'cadet/' + p
55 endforeach 61 endforeach
56endif 62endif