aboutsummaryrefslogtreecommitdiff
path: root/src/chat/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/chat/Makefile.am')
-rw-r--r--src/chat/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/src/chat/Makefile.am b/src/chat/Makefile.am
new file mode 100644
index 000000000..ad099e6b1
--- /dev/null
+++ b/src/chat/Makefile.am
@@ -0,0 +1,39 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
5endif
6
7if USE_COVERAGE
8 AM_CFLAGS = -fprofile-arcs -ftest-coverage
9endif
10
11lib_LTLIBRARIES = libgnunetchat.la
12
13libgnunetchat_la_SOURCES = \
14 chat.c chat.h
15
16libgnunetchat_la_LIBADD = \
17 $(top_builddir)/src/util/libgnunetutil.la
18
19libgnunetchat_la_LDFLAGS = \
20 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
21 -version-info 0:0:0
22
23bin_PROGRAMS = \
24 gnunet-service-chat \
25 gnunet-chat
26
27gnunet_service_chat_SOURCES = \
28 gnunet-service-chat.c
29gnunet_service_chat_LDADD = \
30 $(top_builddir)/src/core/libgnunetcore.la \
31 $(top_builddir)/src/util/libgnunetutil.la \
32 $(GN_LIBINTL)
33
34gnunet_chat_SOURCES = \
35 gnunet-chat.c
36gnunet_chat_LDADD = \
37 $(top_builddir)/src/chat/libgnunetchat.la \
38 $(top_builddir)/src/util/libgnunetutil.la \
39 $(GN_LIBINTL)