aboutsummaryrefslogtreecommitdiff
path: root/src/cli/gns/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/cli/gns/Makefile.am')
-rw-r--r--src/cli/gns/Makefile.am108
1 files changed, 108 insertions, 0 deletions
diff --git a/src/cli/gns/Makefile.am b/src/cli/gns/Makefile.am
new file mode 100644
index 000000000..ae167bca5
--- /dev/null
+++ b/src/cli/gns/Makefile.am
@@ -0,0 +1,108 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4pkgdata_DATA = \
5 gnunet-gns-proxy-ca.template
6
7if USE_COVERAGE
8 AM_CFLAGS = --coverage -O0
9endif
10
11if HAVE_LIBIDN
12 LIBIDN= -lidn
13else
14 LIBIDN=
15endif
16
17if HAVE_LIBIDN2
18 LIBIDN2= -lidn2
19else
20 LIBIDN2=
21endif
22
23pkgcfgdir = $(pkgdatadir)/config.d/
24
25libexecdir= $(pkglibdir)/libexec/
26
27plugindir = $(libdir)/gnunet
28
29bin_PROGRAMS = \
30 gnunet-gns
31
32bin_SCRIPTS = \
33 gnunet-gns-proxy-setup-ca
34
35gnunet-gns-proxy-setup-ca: gnunet-gns-proxy-setup-ca.in Makefile
36 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/scripts/dosubst.awk < $(srcdir)/gnunet-gns-proxy-setup-ca.in > gnunet-gns-proxy-setup-ca
37 @chmod +x gnunet-gns-proxy-setup-ca
38
39test_gnunet_gns.sh: test_gnunet_gns.sh.in Makefile
40 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/scripts/dosubst.awk < $(srcdir)/test_gnunet_gns.sh.in > test_gnunet_gns.sh
41 @chmod +x test_gnunet_gns.sh
42
43CLEANFILES = test_gnunet_gns.sh
44
45gnunet_gns_SOURCES = \
46 gnunet-gns.c
47gnunet_gns_LDADD = \
48 $(top_builddir)/src/service/gns/libgnunetgns.la \
49 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
50 $(top_builddir)/src/service/identity/libgnunetidentity.la \
51 $(top_builddir)/src/lib/util/libgnunetutil.la \
52 $(LIBIDN) $(LIBIDN2) \
53 $(GN_LIBINTL)
54
55check_SCRIPTS = \
56 test_gns_lookup.sh \
57 test_gns_config_lookup.sh \
58 test_gns_ipv6_lookup.sh\
59 test_gns_txt_lookup.sh\
60 test_gns_caa_lookup.sh\
61 test_gns_mx_lookup.sh \
62 test_gns_gns2dns_lookup.sh \
63 test_gns_gns2dns_zkey_lookup.sh \
64 test_gns_gns2dns_cname_lookup.sh \
65 test_gns_dht_lookup.sh\
66 test_gns_delegated_lookup.sh \
67 test_gns_at_lookup.sh\
68 test_gns_zkey_lookup.sh\
69 test_gns_rel_expiration.sh\
70 test_gns_soa_lookup.sh\
71 test_gns_revocation.sh\
72 test_gns_redirect_lookup.sh
73
74EXTRA_DIST = \
75 test_gns_defaults.conf \
76 test_gns_lookup.conf \
77 test_gns_simple_lookup.conf \
78 openssl.cnf \
79 gnunet-gns-proxy-setup-ca.in \
80 zonefiles/J7POEUT41A8PBFS7KVVDRF88GBOU4HK8PSU5QKVLVE3R9T91E99G.zkey \
81 zonefiles/OEFL7A4VEF1B40QLEMTG5D8G1CN6EN16QUSG5R2DT71GRJN34LSG.zkey \
82 zonefiles/test_zonekey \
83 test_gns_lookup.sh \
84 test_gns_config_lookup.sh \
85 test_gns_ipv6_lookup.sh\
86 test_gns_txt_lookup.sh\
87 test_gns_caa_lookup.sh\
88 test_gns_mx_lookup.sh \
89 test_gns_gns2dns_lookup.sh \
90 test_gns_gns2dns_zkey_lookup.sh \
91 test_gns_gns2dns_cname_lookup.sh \
92 test_gns_dht_lookup.sh\
93 test_gns_delegated_lookup.sh \
94 test_gns_at_lookup.sh\
95 test_gns_zkey_lookup.sh\
96 test_gns_rel_expiration.sh\
97 test_gns_soa_lookup.sh\
98 test_gns_revocation.sh\
99 test_gns_redirect_lookup.sh\
100 $(pkgdata_DATA) \
101 test_gnunet_gns.sh.in
102
103if ENABLE_TEST_RUN
104if HAVE_SQLITE
105 AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
106 TESTS = $(check_SCRIPTS)
107endif
108endif