aboutsummaryrefslogtreecommitdiff
path: root/src/cli/gns/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/cli/gns/meson.build')
-rw-r--r--src/cli/gns/meson.build69
1 files changed, 69 insertions, 0 deletions
diff --git a/src/cli/gns/meson.build b/src/cli/gns/meson.build
new file mode 100644
index 000000000..bb6bfc477
--- /dev/null
+++ b/src/cli/gns/meson.build
@@ -0,0 +1,69 @@
1configure_file(input : 'gnunet-gns-proxy-setup-ca.in',
2 output : 'gnunet-gns-proxy-setup-ca',
3 configuration : cdata,
4 install: true,
5 install_mode: 'rwxr-xr-x',
6 install_dir: get_option('bindir'))
7
8install_data('gnunet-gns-proxy-ca.template',
9 install_dir: get_option('datadir')/'gnunet')
10install_data('openssl.cnf',
11 install_dir: get_option('datadir')/'gnunet')
12
13executable ('gnunet-gns',
14 'gnunet-gns.c',
15 dependencies: [libgnunetgns_dep,
16 libgnunetgnsrecord_dep,
17 idn_dep,
18 libgnunetutil_dep],
19 include_directories: [incdir, configuration_inc],
20 install: true,
21 install_dir: get_option('bindir'))
22
23testgns = [
24 'test_dns2gns',
25 'test_gns_at_lookup',
26 'test_gns_caa_lookup',
27 'test_gns_config_lookup',
28 'test_gns_delegated_lookup',
29 'test_gns_dht_lookup',
30 'test_gns_gns2dns_cname_lookup',
31 'test_gns_gns2dns_lookup',
32 'test_gns_gns2dns_zkey_lookup',
33 'test_gns_ipv6_lookup',
34 'test_gns_lookup',
35 'test_gns_mx_lookup',
36 'test_gns_quickupdate',
37 'test_gns_redirect_lookup',
38 'test_gns_rel_expiration',
39 'test_gns_revocation',
40 'test_gns_soa_lookup',
41 'test_gns_txt_lookup',
42 'test_gns_zkey_lookup',
43 'test_gns_sbox_simple',
44 'test_gns_sbox',
45 'test_gns_box_sbox',
46 ]
47
48testconfigs = [
49 'test_dns2gns.conf',
50 'test_gns_defaults.conf',
51 'test_gns_lookup.conf',
52 'test_gns_lookup_peer1.conf',
53 'test_gns_lookup_peer2.conf',
54 'test_gns_simple_lookup.conf'
55 ]
56
57foreach f : testconfigs
58 configure_file(input: f, output: f, copy: true)
59endforeach
60
61foreach t : testgns
62
63 test_filename = t + '.sh'
64 test_file = configure_file(input : test_filename,
65 output : test_filename,
66 copy: true)
67
68 test(t, test_file, suite: 'gns', workdir: meson.current_build_dir(), is_parallel: false)
69endforeach