aboutsummaryrefslogtreecommitdiff
path: root/src/cli/gns/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/cli/gns/meson.build')
-rw-r--r--src/cli/gns/meson.build64
1 files changed, 64 insertions, 0 deletions
diff --git a/src/cli/gns/meson.build b/src/cli/gns/meson.build
new file mode 100644
index 000000000..4374b8413
--- /dev/null
+++ b/src/cli/gns/meson.build
@@ -0,0 +1,64 @@
1configure_file(input : 'gnunet-gns-proxy-setup-ca.in',
2 output : 'gnunet-gns-proxy-setup-ca',
3 configuration : cdata,
4 install: true,
5 install_dir: get_option('bindir'))
6
7install_data('gnunet-gns-proxy-ca.template',
8 install_dir: get_option('datadir')/'gnunet')
9
10executable ('gnunet-gns',
11 'gnunet-gns.c',
12 dependencies: [libgnunetgns_dep,
13 libgnunetgnsrecord_dep,
14 idn_dep,
15 libgnunetutil_dep],
16 include_directories: [incdir, configuration_inc],
17 install: true,
18 install_dir: get_option('bindir'))
19
20testgns = [
21 'test_dns2gns',
22 'test_gns_at_lookup',
23 'test_gns_caa_lookup',
24 'test_gns_config_lookup',
25 'test_gns_delegated_lookup',
26 'test_gns_dht_lookup',
27 'test_gns_gns2dns_cname_lookup',
28 'test_gns_gns2dns_lookup',
29 'test_gns_gns2dns_zkey_lookup',
30 'test_gns_ipv6_lookup',
31 'test_gns_lookup',
32 'test_gns_multiple_record_lookup',
33 'test_gns_mx_lookup',
34 'test_gns_quickupdate',
35 'test_gns_redirect_lookup',
36 'test_gns_rel_expiration',
37 'test_gns_revocation',
38 'test_gns_soa_lookup',
39 'test_gns_txt_lookup',
40 'test_gns_zkey_lookup',
41]
42
43testconfigs = [
44 'test_dns2gns.conf',
45 'test_gns_defaults.conf',
46 'test_gns_lookup.conf',
47 'test_gns_lookup_peer1.conf',
48 'test_gns_lookup_peer2.conf',
49 'test_gns_simple_lookup.conf'
50]
51
52foreach f : testconfigs
53 configure_file(input: f, output: f, copy: true)
54endforeach
55
56foreach t : testgns
57
58 test_filename = t + '.sh'
59 test_file = configure_file(input : test_filename,
60 output : test_filename,
61 copy: true)
62
63 test(t, test_file, suite: 'gns', workdir: meson.current_build_dir(), is_parallel: false)
64endforeach