aboutsummaryrefslogtreecommitdiff
path: root/src/cli/identity/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/cli/identity/Makefile.am')
-rw-r--r--src/cli/identity/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/cli/identity/Makefile.am b/src/cli/identity/Makefile.am
new file mode 100644
index 000000000..be2c2f1c6
--- /dev/null
+++ b/src/cli/identity/Makefile.am
@@ -0,0 +1,36 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4plugindir = $(libdir)/gnunet
5
6if USE_COVERAGE
7 AM_CFLAGS = --coverage -O0
8 XLIB = -lgcov
9endif
10
11pkgcfgdir= $(pkgdatadir)/config.d/
12
13bin_PROGRAMS = \
14 gnunet-identity
15
16gnunet_identity_SOURCES = \
17 gnunet-identity.c
18gnunet_identity_LDADD = \
19 $(top_builddir)/src/service/libgnunetidentity.la \
20 $(top_builddir)/src/statistics/libgnunetstatistics.la \
21 $(top_builddir)/src/lib/util/libgnunetutil.la \
22 $(GN_LIBINTL)
23
24check_SCRIPTS = \
25 test_identity_messages.sh
26
27# if ENABLE_TEST_RUN
28# AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
29# TESTS = $(check_PROGRAMS) $(check_SCRIPTS)
30# endif
31
32
33EXTRA_DIST = \
34 test_identity_messages.sh
35
36