aboutsummaryrefslogtreecommitdiff
path: root/src/cli/namestore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/cli/namestore/Makefile.am')
-rw-r--r--src/cli/namestore/Makefile.am70
1 files changed, 70 insertions, 0 deletions
diff --git a/src/cli/namestore/Makefile.am b/src/cli/namestore/Makefile.am
new file mode 100644
index 000000000..b666c8851
--- /dev/null
+++ b/src/cli/namestore/Makefile.am
@@ -0,0 +1,70 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include $(POSTGRESQL_CPPFLAGS)
3
4plugindir = $(libdir)/gnunet
5
6pkgcfgdir= $(pkgdatadir)/config.d/
7
8libexecdir= $(pkglibdir)/libexec/
9
10sqldir = $(prefix)/share/gnunet/sql/
11
12if USE_COVERAGE
13 AM_CFLAGS = --coverage -O0
14 XLIBS = -lgcov
15endif
16
17
18bin_PROGRAMS = \
19 gnunet-namestore \
20 gnunet-namestore-dbtool \
21 gnunet-namestore-zonefile \
22 gnunet-zoneimport
23
24gnunet_namestore_zonefile_SOURCES = \
25 gnunet-namestore-zonefile.c
26gnunet_namestore_zonefile_LDADD = \
27 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
28 $(top_builddir)/src/service/identity/libgnunetidentity.la \
29 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
30 $(top_builddir)/src/lib/util/libgnunetutil.la \
31 $(GN_LIBINTL)
32
33gnunet_zoneimport_SOURCES = \
34 gnunet-zoneimport.c
35gnunet_zoneimport_LDADD = \
36 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
37 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
38 $(top_builddir)/src/service/identity/libgnunetidentity.la \
39 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
40 $(top_builddir)/src/lib/util/libgnunetutil.la \
41 $(GN_LIBINTL)
42
43gnunet_namestore_SOURCES = \
44 gnunet-namestore.c
45gnunet_namestore_LDADD = \
46 $(top_builddir)/src/service/identity/libgnunetidentity.la \
47 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
48 $(top_builddir)/src/lib/util/libgnunetutil.la \
49 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
50 $(GN_LIBINTL)
51
52gnunet_namestore_dbtool_SOURCES = \
53 gnunet-namestore-dbtool.c
54gnunet_namestore_dbtool_LDADD = \
55 $(top_builddir)/src/lib/util/libgnunetutil.la \
56 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
57 $(GN_LIBINTL)
58
59
60
61check_SCRIPTS = \
62 test_namestore_put.sh \
63 test_namestore_put_stdin.sh \
64 test_namestore_lookup.sh \
65 test_namestore_delete.sh \
66 test_namestore_zonefile_import.sh
67
68EXTRA_DIST = \
69 example_zonefile \
70 $(check_SCRIPTS)