aboutsummaryrefslogtreecommitdiff
path: root/src/consensus/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/consensus/Makefile.am')
-rw-r--r--src/consensus/Makefile.am29
1 files changed, 8 insertions, 21 deletions
diff --git a/src/consensus/Makefile.am b/src/consensus/Makefile.am
index f77f49f94..a88b8bc60 100644
--- a/src/consensus/Makefile.am
+++ b/src/consensus/Makefile.am
@@ -18,9 +18,6 @@ endif
18libexec_PROGRAMS = \ 18libexec_PROGRAMS = \
19 gnunet-service-consensus 19 gnunet-service-consensus
20 20
21#noinst_PROGRAMS = \
22# gnunet-consensus-profiler
23
24if ENABLE_MALICIOUS 21if ENABLE_MALICIOUS
25libexec_PROGRAMS += \ 22libexec_PROGRAMS += \
26 gnunet-service-evil-consensus 23 gnunet-service-evil-consensus
@@ -38,20 +35,10 @@ check-python-style:
38lib_LTLIBRARIES = \ 35lib_LTLIBRARIES = \
39 libgnunetconsensus.la 36 libgnunetconsensus.la
40 37
41# TNG
42#gnunet_consensus_profiler_SOURCES = \
43# gnunet-consensus-profiler.c
44#gnunet_consensus_profiler_LDADD = \
45# $(top_builddir)/src/util/libgnunetutil.la \
46# libgnunetconsensus.la \
47# $(top_builddir)/src/testing/libgnunettesting.la \
48# $(top_builddir)/src/testbed/libgnunettestbed.la \
49# $(GN_LIBINTL)
50
51gnunet_service_consensus_SOURCES = \ 38gnunet_service_consensus_SOURCES = \
52 gnunet-service-consensus.c 39 gnunet-service-consensus.c
53gnunet_service_consensus_LDADD = \ 40gnunet_service_consensus_LDADD = \
54 $(top_builddir)/src/util/libgnunetutil.la \ 41 $(top_builddir)/src/lib/util/libgnunetutil.la \
55 $(top_builddir)/src/core/libgnunetcore.la \ 42 $(top_builddir)/src/core/libgnunetcore.la \
56 $(top_builddir)/src/set/libgnunetset.la \ 43 $(top_builddir)/src/set/libgnunetset.la \
57 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 44 $(top_builddir)/src/statistics/libgnunetstatistics.la \
@@ -61,7 +48,7 @@ gnunet_service_evil_consensus_SOURCES = \
61 gnunet-service-consensus.c \ 48 gnunet-service-consensus.c \
62 consensus_protocol.h 49 consensus_protocol.h
63gnunet_service_evil_consensus_LDADD = \ 50gnunet_service_evil_consensus_LDADD = \
64 $(top_builddir)/src/util/libgnunetutil.la \ 51 $(top_builddir)/src/lib/util/libgnunetutil.la \
65 $(top_builddir)/src/core/libgnunetcore.la \ 52 $(top_builddir)/src/core/libgnunetcore.la \
66 $(top_builddir)/src/set/libgnunetset.la \ 53 $(top_builddir)/src/set/libgnunetset.la \
67 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 54 $(top_builddir)/src/statistics/libgnunetstatistics.la \
@@ -72,7 +59,7 @@ libgnunetconsensus_la_SOURCES = \
72 consensus_api.c \ 59 consensus_api.c \
73 consensus.h 60 consensus.h
74libgnunetconsensus_la_LIBADD = \ 61libgnunetconsensus_la_LIBADD = \
75 $(top_builddir)/src/util/libgnunetutil.la \ 62 $(top_builddir)/src/lib/util/libgnunetutil.la \
76 $(LTLIBINTL) 63 $(LTLIBINTL)
77libgnunetconsensus_la_LDFLAGS = \ 64libgnunetconsensus_la_LDFLAGS = \
78 $(GN_LIB_LDFLAGS) 65 $(GN_LIB_LDFLAGS)
@@ -84,9 +71,9 @@ plugin_LTLIBRARIES = \
84libgnunet_plugin_block_consensus_la_SOURCES = \ 71libgnunet_plugin_block_consensus_la_SOURCES = \
85 plugin_block_consensus.c 72 plugin_block_consensus.c
86libgnunet_plugin_block_consensus_la_LIBADD = \ 73libgnunet_plugin_block_consensus_la_LIBADD = \
87 $(top_builddir)/src/block/libgnunetblock.la \ 74 $(top_builddir)/src/lib/block/libgnunetblock.la \
88 $(top_builddir)/src/block/libgnunetblockgroup.la \ 75 $(top_builddir)/src/lib/block/libgnunetblockgroup.la \
89 $(top_builddir)/src/util/libgnunetutil.la \ 76 $(top_builddir)/src/lib/util/libgnunetutil.la \
90 $(LTLIBINTL) 77 $(LTLIBINTL)
91libgnunet_plugin_block_consensus_la_LDFLAGS = \ 78libgnunet_plugin_block_consensus_la_LDFLAGS = \
92 $(GN_PLUGIN_LDFLAGS) 79 $(GN_PLUGIN_LDFLAGS)
@@ -94,7 +81,7 @@ libgnunet_plugin_block_consensus_la_LDFLAGS = \
94 81
95 82
96check_PROGRAMS = \ 83check_PROGRAMS = \
97 # test_consensus_api 84 test_consensus_api
98 85
99if ENABLE_TEST_RUN 86if ENABLE_TEST_RUN
100AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; 87AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
@@ -104,7 +91,7 @@ endif
104test_consensus_api_SOURCES = \ 91test_consensus_api_SOURCES = \
105 test_consensus_api.c 92 test_consensus_api.c
106test_consensus_api_LDADD = \ 93test_consensus_api_LDADD = \
107 $(top_builddir)/src/util/libgnunetutil.la \ 94 $(top_builddir)/src/lib/util/libgnunetutil.la \
108 $(top_builddir)/src/testing/libgnunettesting.la \ 95 $(top_builddir)/src/testing/libgnunettesting.la \
109 libgnunetconsensus.la 96 libgnunetconsensus.la
110 97