aboutsummaryrefslogtreecommitdiff
path: root/src/consensus/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/consensus/Makefile.am')
-rw-r--r--src/consensus/Makefile.am19
1 files changed, 5 insertions, 14 deletions
diff --git a/src/consensus/Makefile.am b/src/consensus/Makefile.am
index 82af29c87..a0edb1d65 100644
--- a/src/consensus/Makefile.am
+++ b/src/consensus/Makefile.am
@@ -17,8 +17,7 @@ endif
17 17
18bin_PROGRAMS = \ 18bin_PROGRAMS = \
19 gnunet-consensus \ 19 gnunet-consensus \
20 gnunet-consensus-start-peers \ 20 gnunet-consensus-start-peers
21 gnunet-consensus-ibf
22 21
23libexec_PROGRAMS = \ 22libexec_PROGRAMS = \
24 gnunet-service-consensus 23 gnunet-service-consensus
@@ -52,33 +51,25 @@ gnunet_consensus_start_peers_LDADD = \
52gnunet_consensus_start_peers_DEPENDENCIES = \ 51gnunet_consensus_start_peers_DEPENDENCIES = \
53 libgnunetconsensus.la 52 libgnunetconsensus.la
54 53
55gnunet_consensus_ibf_SOURCES = \
56 gnunet-consensus-ibf.c \
57 ibf.c
58gnunet_consensus_ibf_LDADD = \
59 $(top_builddir)/src/util/libgnunetutil.la \
60 $(GN_LIBINTL)
61 54
62gnunet_service_consensus_SOURCES = \ 55gnunet_service_consensus_SOURCES = \
63 gnunet-service-consensus.c \ 56 gnunet-service-consensus.c
64 ibf.c \
65 strata_estimator.c
66gnunet_service_consensus_LDADD = \ 57gnunet_service_consensus_LDADD = \
67 $(top_builddir)/src/util/libgnunetutil.la \ 58 $(top_builddir)/src/util/libgnunetutil.la \
68 $(top_builddir)/src/core/libgnunetcore.la \ 59 $(top_builddir)/src/core/libgnunetcore.la \
69 $(top_builddir)/src/stream/libgnunetstream.la \ 60 $(top_builddir)/src/stream/libgnunetstream.la \
70 $(top_builddir)/src/mesh/libgnunetmesh.la \ 61 $(top_builddir)/src/mesh/libgnunetmesh.la \
62 $(top_builddir)/src/set/libgnunetset.la \
71 $(GN_LIBINTL) 63 $(GN_LIBINTL)
72 64
73gnunet_service_evil_consensus_SOURCES = \ 65gnunet_service_evil_consensus_SOURCES = \
74 gnunet-service-consensus.c \ 66 gnunet-service-consensus.c
75 ibf.c \
76 strata_estimator.c
77gnunet_service_evil_consensus_LDADD = \ 67gnunet_service_evil_consensus_LDADD = \
78 $(top_builddir)/src/util/libgnunetutil.la \ 68 $(top_builddir)/src/util/libgnunetutil.la \
79 $(top_builddir)/src/core/libgnunetcore.la \ 69 $(top_builddir)/src/core/libgnunetcore.la \
80 $(top_builddir)/src/stream/libgnunetstream.la \ 70 $(top_builddir)/src/stream/libgnunetstream.la \
81 $(top_builddir)/src/mesh/libgnunetmesh.la \ 71 $(top_builddir)/src/mesh/libgnunetmesh.la \
72 $(top_builddir)/src/set/libgnunetset.la \
82 $(GN_LIBINTL) 73 $(GN_LIBINTL)
83gnunet_service_evil_consensus_CFLAGS = -DEVIL 74gnunet_service_evil_consensus_CFLAGS = -DEVIL
84 75