aboutsummaryrefslogtreecommitdiff
path: root/src/consensus/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/consensus/Makefile.am')
-rw-r--r--src/consensus/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/src/consensus/Makefile.am b/src/consensus/Makefile.am
new file mode 100644
index 000000000..2041ec1ac
--- /dev/null
+++ b/src/consensus/Makefile.am
@@ -0,0 +1,48 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3pkgcfgdir= $(pkgdatadir)/config.d/
4
5libexecdir= $(pkglibdir)/libexec/
6
7pkgcfg_DATA = \
8 consensus.conf
9
10if MINGW
11 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
12endif
13
14if USE_COVERAGE
15 AM_CFLAGS = -fprofile-arcs -ftest-coverage
16endif
17
18#bin_PROGRAMS = \
19# gnunet-consensus
20
21libexec_PROGRAMS = \
22 gnunet-service-consensus
23
24#gnunet_consensus_SOURCES = \
25# gnunet-consensus.c
26#gnunet_consensus_LDADD = \
27# $(top_builddir)/src/util/libgnunetutil.la \
28# $(GN_LIBINTL)
29
30gnunet_service_consensus_SOURCES = \
31 gnunet-service-consensus.cc
32gnunet_service_consensus_LDADD = \
33 $(top_builddir)/src/util/libgnunetutil.la \
34 $(GN_LIBINTL)
35
36
37#check_PROGRAMS = \
38# test_consensus_api
39
40#if ENABLE_TEST_RUN
41#TESTS = $(check_PROGRAMS)
42#endif
43#
44#test_consensus_api_SOURCES = \
45# test_consensus_api.c
46#test_consensus_api_LDADD = \
47# $(top_builddir)/src/util/libgnunetutil.la
48