aboutsummaryrefslogtreecommitdiff
path: root/src/contrib/service/abd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/contrib/service/abd/Makefile.am')
-rw-r--r--src/contrib/service/abd/Makefile.am106
1 files changed, 106 insertions, 0 deletions
diff --git a/src/contrib/service/abd/Makefile.am b/src/contrib/service/abd/Makefile.am
new file mode 100644
index 000000000..f199d72ed
--- /dev/null
+++ b/src/contrib/service/abd/Makefile.am
@@ -0,0 +1,106 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4EXTRA_DIST = \
5 test_abd_defaults.conf \
6 test_abd_lookup.conf \
7 $(check_SCRIPTS) \
8 $(pkgdata_DATA)
9
10
11if USE_COVERAGE
12 AM_CFLAGS = --coverage -O0
13endif
14
15pkgcfgdir = $(pkgdatadir)/config.d/
16
17libexecdir= $(pkglibdir)/libexec/
18
19plugindir = $(libdir)/gnunet
20
21pkgcfg_DATA = \
22 abd.conf
23
24
25# /usr/lib - compiles a layer which can be used to be communicagte with the service
26lib_LTLIBRARIES = \
27 libgnunetabd.la
28
29# /usr/lib/gnunet/libexec - Business logic . Separate process
30libexec_PROGRAMS = \
31 gnunet-service-abd
32
33bin_PROGRAMS = \
34 gnunet-abd
35
36plugin_LTLIBRARIES = \
37 libgnunet_plugin_gnsrecord_abd.la
38
39
40gnunet_abd_SOURCES = \
41 gnunet-abd.c
42gnunet_abd_LDADD = \
43 libgnunetabd.la \
44 $(top_builddir)/src/lib/util/libgnunetutil.la \
45 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
46 $(top_builddir)/src/service/identity/libgnunetidentity.la \
47 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
48 $(GN_LIBINTL)
49
50
51libgnunet_plugin_gnsrecord_abd_la_SOURCES = \
52 plugin_gnsrecord_abd.c
53libgnunet_plugin_gnsrecord_abd_la_LIBADD = \
54 libgnunetabd.la \
55 $(top_builddir)/src/lib/util/libgnunetutil.la \
56 $(top_builddir)/src/service/identity/libgnunetidentity.la \
57 $(LTLIBINTL)
58libgnunet_plugin_gnsrecord_abd_la_LDFLAGS = \
59 $(GN_PLUGIN_LDFLAGS)
60
61
62
63gnunet_service_abd_SOURCES = \
64 gnunet-service-abd.c
65gnunet_service_abd_LDADD = \
66 libgnunetabd.la \
67 $(top_builddir)/src/lib/util/libgnunetutil.la \
68 $(top_builddir)/src/service/gns/libgnunetgns.la \
69 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
70 $(top_builddir)/src/service/identity/libgnunetidentity.la \
71 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
72 $(GN_LIBINTL)
73
74
75libgnunetabd_la_SOURCES = \
76 abd_api.c abd.h\
77 abd_serialization.c \
78 abd_serialization.h \
79 delegate_misc.c \
80 delegate_misc.h
81libgnunetabd_la_LIBADD = \
82 $(top_builddir)/src/lib/util/libgnunetutil.la \
83 $(top_builddir)/src/service/identity/libgnunetidentity.la \
84 $(XLIB)
85libgnunetabd_la_LDFLAGS = \
86 $(GN_LIB_LDFLAGS)
87
88
89
90check_SCRIPTS = \
91 test_abd_issue.sh
92 # test_abd_verify_simple.sh \
93 # test_abd_verify.sh \
94 # test_abd_verify_and.sh
95
96if ENABLE_TEST_RUN
97if HAVE_SQLITE
98 AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;
99 TESTS = $(check_SCRIPTS)
100endif
101endif
102
103
104
105
106