aboutsummaryrefslogtreecommitdiff
path: root/src/contrib/service/conversation/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/contrib/service/conversation/Makefile.am')
-rw-r--r--src/contrib/service/conversation/Makefile.am263
1 files changed, 263 insertions, 0 deletions
diff --git a/src/contrib/service/conversation/Makefile.am b/src/contrib/service/conversation/Makefile.am
new file mode 100644
index 000000000..b573208e6
--- /dev/null
+++ b/src/contrib/service/conversation/Makefile.am
@@ -0,0 +1,263 @@
1# This Makefile.am is in the public domain
2SUBDIRS = .
3
4plugindir = $(libdir)/gnunet
5
6AM_CPPFLAGS = \
7 $(GNUNET_CPPFLAGS) \
8 -I$(top_srcdir)/src/include \
9 -I$(top_srcdir)
10
11
12if BUILD_CONVERSATION
13lib_LTLIBRARIES = \
14 libgnunetmicrophone.la \
15 libgnunetspeaker.la \
16 libgnunetconversation.la
17
18bin_PROGRAMS = \
19 gnunet-conversation-test \
20 gnunet-conversation
21
22libexec_PROGRAMS = \
23 gnunet-service-conversation
24
25check_PROGRAMS = \
26 test_conversation_api \
27 test_conversation_api_reject \
28 test_conversation_api_twocalls
29
30pkgcfg_DATA = conversation.conf
31endif
32
33pkgcfgdir= $(pkgdatadir)/config.d/
34
35libexecdir= $(pkglibdir)/libexec/
36
37plugin_LTLIBRARIES = \
38 libgnunet_plugin_gnsrecord_conversation.la
39
40
41libgnunet_plugin_gnsrecord_conversation_la_SOURCES = \
42 plugin_gnsrecord_conversation.c
43libgnunet_plugin_gnsrecord_conversation_la_LIBADD = \
44 $(top_builddir)/src/lib/util/libgnunetutil.la \
45 $(LTLIBINTL)
46libgnunet_plugin_gnsrecord_conversation_la_LDFLAGS = \
47 $(GN_PLUGIN_LDFLAGS)
48
49
50libgnunetmicrophone_la_SOURCES = \
51 microphone.c
52libgnunetmicrophone_la_LIBADD = \
53 $(top_builddir)/src/lib/util/libgnunetutil.la
54libgnunetmicrophone_la_LDFLAGS = \
55 $(GN_LIB_LDFLAGS) \
56 -version-info 0:0:0
57
58libgnunetspeaker_la_SOURCES = \
59 speaker.c
60libgnunetspeaker_la_LIBADD = \
61 $(top_builddir)/src/lib/util/libgnunetutil.la
62libgnunetspeaker_la_LDFLAGS = \
63 $(GN_LIB_LDFLAGS) \
64 -version-info 0:0:0
65
66
67libgnunetconversation_la_SOURCES = \
68 conversation_api.c \
69 conversation_api_call.c \
70 conversation.h
71libgnunetconversation_la_LIBADD = \
72 $(top_builddir)/src/service/gns/libgnunetgns.la \
73 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
74 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
75 $(top_builddir)/src/service/identity/libgnunetidentity.la \
76 $(top_builddir)/src/lib/util/libgnunetutil.la
77
78libgnunetconversation_la_LDFLAGS = \
79 $(GN_LIB_LDFLAGS) \
80 -version-info 0:0:0
81
82
83if BUILD_PULSE_HELPERS
84AUDIO_HELPER_RECD=gnunet-helper-audio-record
85AUDIO_HELPER_PLAY=gnunet-helper-audio-playback
86AUDIO_TESTS=$(check_PROGRAMS)
87else
88if BUILD_GST_HELPERS
89AUDIO_HELPER_RECD=gnunet-helper-audio-record
90AUDIO_HELPER_PLAY=gnunet-helper-audio-playback
91AUDIO_TESTS=$(check_PROGRAMS)
92else
93if BUILD_EXPERIMENTAL_HELPERS
94AUDIO_HELPER_RECD=gnunet-helper-audio-record
95AUDIO_HELPER_PLAY=gnunet-helper-audio-playback
96AUDIO_TESTS=$(check_PROGRAMS)
97endif
98endif
99endif
100
101if BUILD_CONVERSATION
102libexec_PROGRAMS += \
103 $(AUDIO_HELPER_RECD) \
104 $(AUDIO_HELPER_PLAY)
105endif
106
107AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
108if ENABLE_TEST_RUN
109TESTS = $(AUDIO_TESTS)
110endif
111
112if BUILD_PULSE_HELPERS
113gnunet_helper_audio_record_SOURCES = \
114 gnunet-helper-audio-record.c
115gnunet_helper_audio_record_LDADD = \
116 $(top_builddir)/src/lib/util/libgnunetutil.la \
117 -lpulse -lopus -logg \
118 $(INTLLIBS)
119#gnunet_helper_audio_record_LDFLAGS = \
120#
121
122gnunet_helper_audio_playback_SOURCES = \
123 gnunet-helper-audio-playback.c
124gnunet_helper_audio_playback_LDADD = \
125 $(top_builddir)/src/lib/util/libgnunetutil.la \
126 -lpulse -lopus -logg \
127 $(INTLLIBS)
128#gnunet_helper_audio_playback_LDFLAGS = \
129#
130else
131if BUILD_GST_HELPERS
132gnunet_helper_audio_record_SOURCES = \
133 gnunet-helper-audio-record-gst.c
134gnunet_helper_audio_record_LDADD = \
135 $(top_builddir)/src/lib/util/libgnunetutil.la \
136 $(GST_LIBS) \
137 $(INTLLIBS)
138gnunet_helper_audio_record_LDFLAGS = \
139 $(GST_LDFLAGS)
140gnunet_helper_audio_record_CFLAGS = \
141 $(GST_CFLAGS)
142
143gnunet_helper_audio_playback_SOURCES = \
144 gnunet-helper-audio-playback-gst.c
145gnunet_helper_audio_playback_LDADD = \
146 $(top_builddir)/src/lib/util/libgnunetutil.la \
147 $(GST_LIBS) \
148 $(INTLLIBS)
149gnunet_helper_audio_playback_LDFLAGS = \
150 $(GST_LDFLAGS)
151gnunet_helper_audio_playback_CFLAGS = \
152 $(GST_CFLAGS) -DIS_SPEAKER
153else
154if BUILD_EXPERIMENTAL_HELPERS
155gnunet_helper_audio_record_SOURCES = \
156 gnunet_gst_test.c gnunet_gst.c
157gnunet_helper_audio_record_LDADD = \
158 $(top_builddir)/src/lib/util/libgnunetutil.la \
159 $(GST_LIBS) \
160 $(INTLLIBS)
161gnunet_helper_audio_record_LDFLAGS = \
162 $(GST_LDFLAGS)
163gnunet_helper_audio_record_CFLAGS = \
164 $(GST_CFLAGS) -DIS_MIC
165
166gnunet_helper_audio_playback_SOURCES = \
167 gnunet_gst_test.c gnunet_gst.c
168gnunet_helper_audio_playback_LDADD = \
169 $(top_builddir)/src/lib/util/libgnunetutil.la \
170 $(GST_LIBS) \
171 $(INTLLIBS)
172gnunet_helper_audio_playback_LDFLAGS = \
173 $(GST_LDFLAGS)
174gnunet_helper_audio_playback_CFLAGS = \
175 $(GST_CFLAGS) -DIS_SPEAKER
176endif
177endif
178endif
179
180gnunet_service_conversation_SOURCES = \
181 gnunet-service-conversation.c
182gnunet_service_conversation_LDADD = \
183 libgnunetconversation.la \
184 libgnunetspeaker.la \
185 libgnunetmicrophone.la \
186 $(top_builddir)/src/service/cadet/libgnunetcadet.la \
187 $(top_builddir)/src/lib/util/libgnunetutil.la \
188 $(top_builddir)/src/service/identity/libgnunetidentity.la \
189 $(INTLLIBS)
190#gnunet_service_conversation_LDFLAGS = \
191#
192
193gnunet_conversation_SOURCES = \
194 gnunet-conversation.c
195gnunet_conversation_LDADD = \
196 libgnunetmicrophone.la \
197 libgnunetspeaker.la \
198 libgnunetconversation.la \
199 $(top_builddir)/src/service/gns/libgnunetgns.la \
200 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
201 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
202 $(top_builddir)/src/service/identity/libgnunetidentity.la \
203 $(top_builddir)/src/lib/util/libgnunetutil.la \
204 $(INTLLIBS)
205#gnunet_conversation_LDFLAGS = \
206#
207
208gnunet_conversation_test_SOURCES = \
209 gnunet-conversation-test.c
210gnunet_conversation_test_LDADD = \
211 libgnunetmicrophone.la \
212 libgnunetspeaker.la \
213 $(top_builddir)/src/lib/util/libgnunetutil.la \
214 $(INTLLIBS)
215#gnunet_conversation_test_LDFLAGS = \
216#
217
218
219test_conversation_api_SOURCES = \
220 test_conversation_api.c
221test_conversation_api_LDADD = \
222 libgnunetconversation.la \
223 libgnunetspeaker.la \
224 libgnunetmicrophone.la \
225 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
226 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
227 $(top_builddir)/src/service/identity/libgnunetidentity.la \
228 $(top_builddir)/src/service/testing/libgnunettesting.la \
229 $(top_builddir)/src/lib/util/libgnunetutil.la
230test_conversation_api_LDFLAGS = \
231 -export-dynamic
232
233test_conversation_api_twocalls_SOURCES = \
234 test_conversation_api_twocalls.c
235test_conversation_api_twocalls_LDADD = \
236 libgnunetconversation.la \
237 libgnunetspeaker.la \
238 libgnunetmicrophone.la \
239 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
240 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
241 $(top_builddir)/src/service/identity/libgnunetidentity.la \
242 $(top_builddir)/src/service/testing/libgnunettesting.la \
243 $(top_builddir)/src/lib/util/libgnunetutil.la
244test_conversation_api_twocalls_LDFLAGS = \
245 -export-dynamic
246
247test_conversation_api_reject_SOURCES = \
248 test_conversation_api_reject.c
249test_conversation_api_reject_LDADD = \
250 libgnunetconversation.la \
251 libgnunetspeaker.la \
252 libgnunetmicrophone.la \
253 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
254 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
255 $(top_builddir)/src/service/identity/libgnunetidentity.la \
256 $(top_builddir)/src/service/testing/libgnunettesting.la \
257 $(top_builddir)/src/lib/util/libgnunetutil.la
258test_conversation_api_reject_LDFLAGS = \
259 -export-dynamic
260
261
262
263EXTRA_DIST = test_conversation.conf