aboutsummaryrefslogtreecommitdiff
path: root/src/contrib/service/rps/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/contrib/service/rps/Makefile.am')
-rw-r--r--src/contrib/service/rps/Makefile.am149
1 files changed, 149 insertions, 0 deletions
diff --git a/src/contrib/service/rps/Makefile.am b/src/contrib/service/rps/Makefile.am
new file mode 100644
index 000000000..1a3c9fa3a
--- /dev/null
+++ b/src/contrib/service/rps/Makefile.am
@@ -0,0 +1,149 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage -O0
6 XLIB = -lgcov
7endif
8
9pkgcfgdir= $(pkgdatadir)/config.d/
10
11libexecdir= $(pkglibdir)/libexec/
12
13pkgcfg_DATA = \
14 rps.conf
15
16bin_PROGRAMS = gnunet-rps
17
18gnunet_rps_SOURCES = \
19 gnunet-rps.c
20
21gnunet_rps_LDADD = \
22 libgnunetrps.la \
23 $(top_builddir)/src/lib/util/libgnunetutil.la \
24 $(XLIB) $(GN_LIBINTL)
25
26lib_LTLIBRARIES = libgnunetrps.la
27
28libgnunetrps_la_SOURCES = \
29 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
30 rps-test_util.h rps-test_util.c \
31 rps-sampler_common.h rps-sampler_common.c \
32 rps-sampler_client.h rps-sampler_client.c \
33 rps_api.c rps.h
34libgnunetrps_la_LIBADD = \
35 $(top_builddir)/src/service/nse/libgnunetnse.la \
36 $(top_builddir)/src/lib/util/libgnunetutil.la \
37 $(GN_LIBINTL) $(XLIB)
38libgnunetrps_la_LDFLAGS = \
39 $(GN_LIB_LDFLAGS) \
40 -version-info 0:0:0
41# Fix 'created both with libtool and without' error:
42libgnunetrps_la_CFLAGS = $(AM_CFLAGS)
43
44
45libexec_PROGRAMS = \
46 gnunet-service-rps
47
48gnunet_service_rps_SOURCES = \
49 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
50 rps-sampler_common.h rps-sampler_common.c \
51 gnunet-service-rps_sampler.h gnunet-service-rps_sampler.c \
52 gnunet-service-rps_custommap.h gnunet-service-rps_custommap.c \
53 gnunet-service-rps_view.h gnunet-service-rps_view.c \
54 gnunet-service-rps.c
55
56
57gnunet_service_rps_LDADD = \
58 libgnunetrps.la \
59 $(top_builddir)/src/lib/util/libgnunetutil.la \
60 $(top_builddir)/src/service/peerstore/libgnunetpeerstore.la \
61 $(top_builddir)/src/service/cadet/libgnunetcadet.la \
62 $(top_builddir)/src/service/nse/libgnunetnse.la \
63 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
64 $(top_builddir)/src/service/core/libgnunetcore.la \
65 $(LIBGCRYPT_LIBS) \
66 -lm -lgcrypt \
67 $(GN_LIBINTL)
68
69
70check_PROGRAMS = \
71 test_service_rps_view \
72 test_service_rps_custommap \
73 test_service_rps_sampler_elem
74 # test_rps_single_req \
75 # test_rps_churn
76 # test_rps_sub \
77 # test_rps_seed_request
78#if ENABLE_MALICIOUS
79#check_PROGRAMS += \
80# test_rps_malicious_1 \
81# test_rps_malicious_2 \
82# test_rps_malicious_3
83#endif
84
85rps_test_src = \
86 test_rps.c \
87 rps-test_util.h rps-test_util.c \
88 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
89 rps-sampler_common.h rps-sampler_common.c \
90 gnunet-service-rps_sampler.h gnunet-service-rps_sampler.c
91
92#ld_rps_test_lib = \
93# libgnunetrps.la \
94# $(top_builddir)/src/lib/util/libgnunetutil.la \
95# $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
96# $(top_builddir)/src/testbed/libgnunettestbed.la \
97# -lm
98
99if ENABLE_TEST_RUN
100AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
101TESTS = $(check_PROGRAMS)
102endif
103
104test_service_rps_view_SOURCES = \
105 gnunet-service-rps_view.h gnunet-service-rps_view.c \
106 test_service_rps_view.c
107test_service_rps_view_LDADD = $(top_builddir)/src/lib/util/libgnunetutil.la
108
109test_service_rps_custommap_SOURCES = \
110 gnunet-service-rps_custommap.h gnunet-service-rps_custommap.c \
111 test_service_rps_custommap.c
112test_service_rps_custommap_LDADD = \
113 $(top_builddir)/src/lib/util/libgnunetutil.la
114
115test_service_rps_sampler_elem_SOURCES = \
116 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
117 rps-test_util.h rps-test_util.c \
118 test_service_rps_sampler_elem.c
119test_service_rps_sampler_elem_LDADD = $(top_builddir)/src/lib/util/libgnunetutil.la
120
121#test_rps_single_req_SOURCES = $(rps_test_src)
122#test_rps_single_req_LDADD = $(ld_rps_test_lib)
123#
124#test_rps_seed_request_SOURCES = $(rps_test_src)
125#test_rps_seed_request_LDADD = $(ld_rps_test_lib)
126#
127#test_rps_req_cancel_SOURCES = $(rps_test_src)
128#test_rps_req_cancel_LDADD = $(ld_rps_test_lib)
129#
130#test_rps_sub_SOURCES = $(rps_test_src)
131#test_rps_sub_LDADD = $(ld_rps_test_lib)
132#
133#test_rps_seed_big_SOURCES = $(rps_test_src)
134#test_rps_seed_big_LDADD = $(ld_rps_test_lib)
135#
136#test_rps_churn_SOURCES = $(rps_test_src)
137#test_rps_churn_LDADD = $(ld_rps_test_lib)
138#
139#test_rps_malicious_1_SOURCES = $(rps_test_src)
140#test_rps_malicious_1_LDADD = $(ld_rps_test_lib)
141#
142#test_rps_malicious_2_SOURCES = $(rps_test_src)
143#test_rps_malicious_2_LDADD = $(ld_rps_test_lib)
144#
145#test_rps_malicious_3_SOURCES = $(rps_test_src)
146#test_rps_malicious_3_LDADD = $(ld_rps_test_lib)
147
148EXTRA_DIST = \
149 test_rps.conf