aboutsummaryrefslogtreecommitdiff
path: root/src/contrib/service/rps/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/contrib/service/rps/Makefile.am')
-rw-r--r--src/contrib/service/rps/Makefile.am167
1 files changed, 167 insertions, 0 deletions
diff --git a/src/contrib/service/rps/Makefile.am b/src/contrib/service/rps/Makefile.am
new file mode 100644
index 000000000..28aa3e050
--- /dev/null
+++ b/src/contrib/service/rps/Makefile.am
@@ -0,0 +1,167 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage -O0
6 XLIB = -lgcov
7endif
8
9pkgcfgdir= $(pkgdatadir)/config.d/
10
11libexecdir= $(pkglibdir)/libexec/
12
13pkgcfg_DATA = \
14 rps.conf
15
16bin_PROGRAMS = gnunet-rps
17
18gnunet_rps_SOURCES = \
19 gnunet-rps.c
20
21gnunet_rps_LDADD = \
22 libgnunetrps.la \
23 $(top_builddir)/src/lib/util/libgnunetutil.la \
24 $(XLIB) $(GN_LIBINTL)
25
26lib_LTLIBRARIES = libgnunetrps.la
27
28libgnunetrps_la_SOURCES = \
29 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
30 rps-test_util.h rps-test_util.c \
31 rps-sampler_common.h rps-sampler_common.c \
32 rps-sampler_client.h rps-sampler_client.c \
33 rps_api.c rps.h
34libgnunetrps_la_LIBADD = \
35 $(top_builddir)/src/service/nse/libgnunetnse.la \
36 $(top_builddir)/src/lib/util/libgnunetutil.la \
37 $(GN_LIBINTL) $(XLIB)
38libgnunetrps_la_LDFLAGS = \
39 $(GN_LIB_LDFLAGS) \
40 -version-info 0:0:0
41# Fix 'created both with libtool and without' error:
42libgnunetrps_la_CFLAGS = $(AM_CFLAGS)
43
44
45libexec_PROGRAMS = \
46 gnunet-service-rps
47
48#noinst_PROGRAMS = \
49# gnunet-rps-profiler
50
51
52gnunet_service_rps_SOURCES = \
53 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
54 rps-sampler_common.h rps-sampler_common.c \
55 gnunet-service-rps_sampler.h gnunet-service-rps_sampler.c \
56 gnunet-service-rps_custommap.h gnunet-service-rps_custommap.c \
57 gnunet-service-rps_view.h gnunet-service-rps_view.c \
58 gnunet-service-rps.c
59
60
61gnunet_service_rps_LDADD = \
62 libgnunetrps.la \
63 $(top_builddir)/src/lib/util/libgnunetutil.la \
64 $(top_builddir)/src/service/peerstore/libgnunetpeerstore.la \
65 $(top_builddir)/src/service/cadet/libgnunetcadet.la \
66 $(top_builddir)/src/service/nse/libgnunetnse.la \
67 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
68 $(top_builddir)/src/service/core/libgnunetcore.la \
69 $(LIBGCRYPT_LIBS) \
70 -lm -lgcrypt \
71 $(GN_LIBINTL)
72
73
74check_PROGRAMS = \
75 test_service_rps_view \
76 test_service_rps_custommap \
77 test_service_rps_sampler_elem
78 # test_rps_single_req \
79 # test_rps_churn
80 # test_rps_sub \
81 # test_rps_seed_request
82#if ENABLE_MALICIOUS
83#check_PROGRAMS += \
84# test_rps_malicious_1 \
85# test_rps_malicious_2 \
86# test_rps_malicious_3
87#endif
88
89rps_test_src = \
90 test_rps.c \
91 rps-test_util.h rps-test_util.c \
92 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
93 rps-sampler_common.h rps-sampler_common.c \
94 gnunet-service-rps_sampler.h gnunet-service-rps_sampler.c
95
96#ld_rps_test_lib = \
97# libgnunetrps.la \
98# $(top_builddir)/src/lib/util/libgnunetutil.la \
99# $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
100# $(top_builddir)/src/testbed/libgnunettestbed.la \
101# -lm
102
103if ENABLE_TEST_RUN
104AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
105TESTS = $(check_PROGRAMS)
106endif
107
108test_service_rps_view_SOURCES = \
109 gnunet-service-rps_view.h gnunet-service-rps_view.c \
110 test_service_rps_view.c
111test_service_rps_view_LDADD = $(top_builddir)/src/lib/util/libgnunetutil.la
112
113test_service_rps_custommap_SOURCES = \
114 gnunet-service-rps_custommap.h gnunet-service-rps_custommap.c \
115 test_service_rps_custommap.c
116test_service_rps_custommap_LDADD = \
117 $(top_builddir)/src/lib/util/libgnunetutil.la
118
119test_service_rps_sampler_elem_SOURCES = \
120 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
121 rps-test_util.h rps-test_util.c \
122 test_service_rps_sampler_elem.c
123test_service_rps_sampler_elem_LDADD = $(top_builddir)/src/lib/util/libgnunetutil.la
124
125#test_rps_single_req_SOURCES = $(rps_test_src)
126#test_rps_single_req_LDADD = $(ld_rps_test_lib)
127#
128#test_rps_seed_request_SOURCES = $(rps_test_src)
129#test_rps_seed_request_LDADD = $(ld_rps_test_lib)
130#
131#test_rps_req_cancel_SOURCES = $(rps_test_src)
132#test_rps_req_cancel_LDADD = $(ld_rps_test_lib)
133#
134#test_rps_sub_SOURCES = $(rps_test_src)
135#test_rps_sub_LDADD = $(ld_rps_test_lib)
136#
137#test_rps_seed_big_SOURCES = $(rps_test_src)
138#test_rps_seed_big_LDADD = $(ld_rps_test_lib)
139#
140#test_rps_churn_SOURCES = $(rps_test_src)
141#test_rps_churn_LDADD = $(ld_rps_test_lib)
142#
143#test_rps_malicious_1_SOURCES = $(rps_test_src)
144#test_rps_malicious_1_LDADD = $(ld_rps_test_lib)
145#
146#test_rps_malicious_2_SOURCES = $(rps_test_src)
147#test_rps_malicious_2_LDADD = $(ld_rps_test_lib)
148#
149#test_rps_malicious_3_SOURCES = $(rps_test_src)
150#test_rps_malicious_3_LDADD = $(ld_rps_test_lib)
151
152#gnunet_rps_profiler_SOURCES = \
153# gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
154# rps-sampler_common.h rps-sampler_common.c \
155# gnunet-service-rps_sampler.h gnunet-service-rps_sampler.c \
156# rps-test_util.h rps-test_util.c \
157# gnunet-rps-profiler.c
158#gnunet_rps_profiler_LDADD = \
159# $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
160# libgnunetrps.la \
161# $(top_builddir)/src/lib/util/libgnunetutil.la \
162# $(top_builddir)/src/testbed/libgnunettestbed.la \
163# -lm
164
165
166EXTRA_DIST = \
167 test_rps.conf