aboutsummaryrefslogtreecommitdiff
path: root/src/contrib/service/template/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/contrib/service/template/Makefile.am')
-rw-r--r--src/contrib/service/template/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/src/contrib/service/template/Makefile.am b/src/contrib/service/template/Makefile.am
new file mode 100644
index 000000000..4661266d7
--- /dev/null
+++ b/src/contrib/service/template/Makefile.am
@@ -0,0 +1,41 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4pkgcfgdir= $(pkgdatadir)/config.d/
5
6libexecdir= $(pkglibdir)/libexec/
7
8dist_pkgcfg_DATA = \
9 template.conf
10
11if USE_COVERAGE
12 AM_CFLAGS = -fprofile-arcs -ftest-coverage
13endif
14
15# Note: In a real installation,
16# bin_PROGRAMS should be used for gnunet-template
17# libexec_PROGRAMS should be used for gnunet-service-template
18
19noinst_PROGRAMS = \
20 gnunet-service-template
21
22
23gnunet_service_template_SOURCES = \
24 gnunet-service-template.c
25gnunet_service_template_LDADD = \
26 $(top_builddir)/src/lib/util/libgnunetutil.la \
27 $(GN_LIBINTL)
28
29
30check_PROGRAMS = \
31 test_template_api
32
33if ENABLE_TEST_RUN
34AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
35TESTS = $(check_PROGRAMS)
36endif
37
38test_template_api_SOURCES = \
39 test_template_api.c
40test_template_api_LDADD = \
41 $(top_builddir)/src/lib/util/libgnunetutil.la