aboutsummaryrefslogtreecommitdiff
path: root/src/datacache/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/datacache/Makefile.am')
-rw-r--r--src/datacache/Makefile.am206
1 files changed, 0 insertions, 206 deletions
diff --git a/src/datacache/Makefile.am b/src/datacache/Makefile.am
deleted file mode 100644
index 14778e0a3..000000000
--- a/src/datacache/Makefile.am
+++ /dev/null
@@ -1,206 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4plugindir = $(libdir)/gnunet
5
6pkgcfgdir= $(pkgdatadir)/config.d/
7
8dist_pkgcfg_DATA = \
9 datacache.conf
10
11sqldir = $(prefix)/share/gnunet/sql/
12
13sql_DATA = \
14 datacache-0001.sql \
15 datacache-drop.sql
16
17
18if USE_COVERAGE
19 AM_CFLAGS = --coverage -O0
20 XLIBS = -lgcov
21endif
22
23if HAVE_SQLITE
24 SQLITE_PLUGIN = libgnunet_plugin_datacache_sqlite.la
25endif
26if HAVE_POSTGRESQL
27 POSTGRES_PLUGIN = libgnunet_plugin_datacache_postgres.la
28endif
29
30lib_LTLIBRARIES = \
31 libgnunetdatacache.la
32
33libgnunetdatacache_la_SOURCES = \
34 datacache.c
35libgnunetdatacache_la_LIBADD = \
36 $(top_builddir)/src/statistics/libgnunetstatistics.la \
37 $(top_builddir)/src/util/libgnunetutil.la \
38 $(GN_LIBINTL)
39libgnunetdatacache_la_LDFLAGS = \
40 $(GN_LIB_LDFLAGS) \
41 -version-info 0:1:0
42
43
44plugin_LTLIBRARIES = \
45 $(SQLITE_PLUGIN) \
46 $(POSTGRES_PLUGIN) \
47 libgnunet_plugin_datacache_heap.la
48
49# Real plugins should of course go into
50# plugin_LTLIBRARIES
51noinst_LTLIBRARIES = \
52 libgnunet_plugin_datacache_template.la
53
54
55libgnunet_plugin_datacache_sqlite_la_SOURCES = \
56 plugin_datacache_sqlite.c
57libgnunet_plugin_datacache_sqlite_la_LIBADD = \
58 $(top_builddir)/src/statistics/libgnunetstatistics.la \
59 $(top_builddir)/src/sq/libgnunetsq.la \
60 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lsqlite3 \
61 $(LTLIBINTL)
62libgnunet_plugin_datacache_sqlite_la_LDFLAGS = \
63 $(GN_PLUGIN_LDFLAGS)
64
65libgnunet_plugin_datacache_heap_la_SOURCES = \
66 plugin_datacache_heap.c
67libgnunet_plugin_datacache_heap_la_LIBADD = \
68 $(top_builddir)/src/statistics/libgnunetstatistics.la \
69 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
70 $(LTLIBINTL)
71libgnunet_plugin_datacache_heap_la_LDFLAGS = \
72 $(GN_PLUGIN_LDFLAGS)
73
74libgnunet_plugin_datacache_postgres_la_SOURCES = \
75 plugin_datacache_postgres.c
76libgnunet_plugin_datacache_postgres_la_LIBADD = \
77 $(top_builddir)/src/pq/libgnunetpq.la \
78 $(top_builddir)/src/statistics/libgnunetstatistics.la \
79 $(top_builddir)/src/util/libgnunetutil.la \
80 $(GN_PLUGIN_LDFLAGS) -lpq
81libgnunet_plugin_datacache_postgres_la_CPPFLAGS = \
82 $(POSTGRESQL_CPPFLAGS) $(AM_CPPFLAGS)
83libgnunet_plugin_datacache_postgres_la_LDFLAGS = \
84 $(GN_PLUGIN_LDFLAGS) $(POSTGRESQL_LDFLAGS)
85
86libgnunet_plugin_datacache_template_la_SOURCES = \
87 plugin_datacache_template.c
88libgnunet_plugin_datacache_template_la_LIBADD = \
89 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
90 $(LTLIBINTL)
91libgnunet_plugin_datacache_template_la_LDFLAGS = \
92 $(GN_PLUGIN_LDFLAGS)
93
94
95if HAVE_SQLITE
96if HAVE_BENCHMARKS
97 SQLITE_BENCHMARKS = \
98 perf_datacache_sqlite
99endif
100SQLITE_TESTS = \
101 test_datacache_sqlite \
102 test_datacache_quota_sqlite \
103 $(SQLITE_BENCHMARKS)
104
105if HAVE_BENCHMARKS
106 HEAP_BENCHMARKS = \
107 perf_datacache_heap
108endif
109HEAP_TESTS = \
110 test_datacache_heap \
111 test_datacache_quota_heap \
112 $(HEAP_BENCHMARKS)
113
114if HAVE_POSTGRESQL
115if HAVE_BENCHMARKS
116 POSTGRES_BENCHMARKS = \
117 perf_datacache_postgres
118endif
119POSTGRES_TESTS = \
120 test_datacache_postgres \
121 test_datacache_quota_postgres \
122 $(POSTGRES_BENCHMARKS)
123endif
124endif
125
126check_PROGRAMS = \
127 $(SQLITE_TESTS) \
128 $(HEAP_TESTS) \
129 $(POSTGRES_TESTS)
130
131if ENABLE_TEST_RUN
132AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
133TESTS = $(check_PROGRAMS)
134endif
135
136test_datacache_sqlite_SOURCES = \
137 test_datacache.c
138test_datacache_sqlite_LDADD = \
139 $(top_builddir)/src/testing/libgnunettesting.la \
140 libgnunetdatacache.la \
141 $(top_builddir)/src/util/libgnunetutil.la
142
143test_datacache_quota_sqlite_SOURCES = \
144 test_datacache_quota.c
145test_datacache_quota_sqlite_LDADD = \
146 $(top_builddir)/src/testing/libgnunettesting.la \
147 libgnunetdatacache.la \
148 $(top_builddir)/src/util/libgnunetutil.la
149
150perf_datacache_sqlite_SOURCES = \
151 perf_datacache.c
152perf_datacache_sqlite_LDADD = \
153 $(top_builddir)/src/testing/libgnunettesting.la \
154 libgnunetdatacache.la \
155 $(top_builddir)/src/util/libgnunetutil.la
156
157test_datacache_heap_SOURCES = \
158 test_datacache.c
159test_datacache_heap_LDADD = \
160 $(top_builddir)/src/testing/libgnunettesting.la \
161 libgnunetdatacache.la \
162 $(top_builddir)/src/util/libgnunetutil.la
163
164test_datacache_quota_heap_SOURCES = \
165 test_datacache_quota.c
166test_datacache_quota_heap_LDADD = \
167 $(top_builddir)/src/testing/libgnunettesting.la \
168 libgnunetdatacache.la \
169 $(top_builddir)/src/util/libgnunetutil.la
170
171perf_datacache_heap_SOURCES = \
172 perf_datacache.c
173perf_datacache_heap_LDADD = \
174 $(top_builddir)/src/testing/libgnunettesting.la \
175 libgnunetdatacache.la \
176 $(top_builddir)/src/util/libgnunetutil.la
177
178test_datacache_postgres_SOURCES = \
179 test_datacache.c
180test_datacache_postgres_LDADD = \
181 $(top_builddir)/src/testing/libgnunettesting.la \
182 libgnunetdatacache.la \
183 $(top_builddir)/src/util/libgnunetutil.la
184
185test_datacache_quota_postgres_SOURCES = \
186 test_datacache_quota.c
187test_datacache_quota_postgres_LDADD = \
188 $(top_builddir)/src/testing/libgnunettesting.la \
189 libgnunetdatacache.la \
190 $(top_builddir)/src/util/libgnunetutil.la
191
192perf_datacache_postgres_SOURCES = \
193 perf_datacache.c
194perf_datacache_postgres_LDADD = \
195 $(top_builddir)/src/testing/libgnunettesting.la \
196 libgnunetdatacache.la \
197 $(top_builddir)/src/util/libgnunetutil.la
198
199EXTRA_DIST = \
200 test_datacache_data_sqlite.conf \
201 perf_datacache_data_sqlite.conf \
202 test_datacache_data_heap.conf \
203 perf_datacache_data_heap.conf \
204 test_datacache_data_postgres.conf \
205 perf_datacache_data_postgres.conf \
206 $(sql_DATA)